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Introduction
Hardware and software requirements
A punching system consists of a Proel TSI Millennium III software and of
a hardware, in other words a computer that manages the software and the
other peripheral equipment such as scanner, printer, mouse, etc..
Before installing Millennium III, check that the computer satisfies the
minimum system requirements, or, better still, that the configuration
corresponds to or is better than the recommended configuration.

Minimum system requirements
Microsoft Windows XP or Windows Vista or Windows 7 or Windows 8
3 GHz or faster processor
1 GB of RAM
10 GB of free disc space
32 bit video card with resolution of 1280x1024

Recommended system configuration
Microsoft Windows 7
3 GHz or faster processor
4 GB of RAM
20 GB of free disc space
32 bit video card with resolution of 1280x1024
Acrobat Reader for opening the on-line guide to the program
E-mail Client to activate or to registering the program
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Introduction
Thank you for selecting Proel TSI software.
Millennium III is a complete application at the cutting edge of innovation for
the creation and modification of embroideries, designed and produced
specifically to answer the needs of professional production. Thanks to
Millennium III’s optimized tools, you will be able to considerably reduce the
time needed to create embroideries. Starting with version 3 of Millennium III
we decided to equip the Millennium III also a software protection key as an
alternative to hardware protection key.

Information about Proel TSI srl
Established in 1977, Proel (2013 became Proel TSI) is a company with
headquarters in Italy and is renowned internationally for its innovative
products (that include software, electronic equipment and machines)
dedicated mainly to the textile and embroidery industries. For further
information about Proel TSI and to learn about the entire range of products
commercially available visit the site www.proeltsi.com or contact one of
the following addresses:

Laser Cutting Technology - Embroidery Software Solutions
Via Lino Zanussi, 20 - 33033 Codroipo (Udine) Italy
Tel: +39 0432 815047
Fax: +39 0432 905710
Web: www.proeltsi.com
Informations: info@proeltsi.com
Technical support: support@proeltsi.com
Sales Office: sales@proeltsi.com
Registration: activation@proeltsi.com
Software & Web: software@proeltsi.com
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Technical Support
In case of problems, you may contact the Technical Support Service:





by calling +39.0432.815047
by faxing to +39.0432.905710
by sending an e-mail message to support@proeltsi.com

Before contacting the Technical Support Service, please make a note of
the following information on a sheet of paper in order to make it possible for
our technicians to assist you as efficiently and rapidly as possible:
- any error message that has been displayed and/or a brief
description of the problem and of the steps required to recreate it;
- the PC Configuration used (processor, RAM memory, video card,
monitor etc.);
- the versions of Microsoft Windows and of Millennium III that have
been installed;
- a list of any other programs that were in use at the same time as
Millennium III.
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What is software protection
Starting with version 3 of Millennium III we decided to equip the Millennium
III also software protection key as an alternative to hardware protection key
in order to meet the needs of our customers, current and future, eliminating
the problems associated with using a hardware device (faults, wear,
purchase and delivery costs, not user friendly, repair or replacement costs,
etc).
The protection system is based on an activation file that will be sent via email and without any additional cost to all users who request it.
More information about activating a system with software protection and
the various tasks to be performed can be found online at the web site:
www.proelembroiderysoftware.com

System Requirements
Before installing Millennium III, check that the computer satisfies the
minimum system requirements, or, better still, that the configuration
corresponds to or is better than the recommended configuration.

Minimum system requirements
•

Microsoft Microsoft Windows XP(TM), Windows Vista(TM), Windows 7
(TM)
, Windows 8(TM)
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•
•
•
•

3 GHz or faster processor
1 GByte of RAM
10 GByte of free disc space
32 bit video card with resolution of 1024x768

Recommended system configuration
Microsoft Windows XP
1.0 GHz or faster processor
512 MB of RAM
200 MB of free disc space
32 bit video card with resolution of 1024x768
Acrobat Reader for opening the on-line guide to the program
E-mail Client to activate the program

Installing the software
Millennium III may be installed using an exe file downloaded from the web
site www.proelembroiderysoftware.com. In this web site you can follow
step by step the Millennium III installation.

In this page you can download other files, options of the program:
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MIII_ArchiveSample.exe

Allows you to install a demo version of the
Archive (database) to manage the
embroideries on the local PC or on the
LAN.
M3SamplesSetup.exe
Allows you to install a series of sample
files comprising embroideries, clipart,
backgrounds, etc.
TrueTypeLetteringSetup.exe Allows you to install the Millennium III
fonts True Type to create embroidered
words with TrueTypeLettering.
M3Man_Ita.exe
Allows you to install the on-line guide in
Italian.
(Requires Adobe Reader)
M3Man_Eng.exe
Allows you to install the on-line guide in
English.
(Requires Adobe Reader)
M3Man_Fre.exe
Allows you to install the on-line guide in
French.
(Requires Adobe Reader)
M3Man_Spa.exe
Allows you to install the on-line guide in
Spanish.
(Requires Adobe Reader)
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Starting and activating Millennium III
To be able to operate, Millennium III (with software protection key) needs
an activation file that you will receive, upon request, from the Proel TSI srl
Activation Service.
The steps for activate the Millennium III software are displayed in the
Download page in the web site: www.proelembroiderysoftware.com .
It will not be possible to use Millennium III until you receive the
activation file (license.enc) from the Activation Service.
The Activation Service is available Monday to Friday from 08.30
to 12.00 and from 13.30 to 17.30. We guarantee that the
activation file will be sent within 48 working hours.
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Information about Millennium III
To obtain information about Millennium III, Select “View / Help” , and click
on “About”
The Information about Millennium III window will be displayed.

This window, that we recommend you consult each time that you wish to
contact our Technical Support Service (support@proeltsi.com), allows
you to find the Type of System, the version number, the name of the
registered user of the program and the corresponding authorization code.
Another particularly important piece of information that may be obtained
from this window is the “Expiry Date” that will tell you until which date the
program may be used and, in parentheses, the number of days left for
using the program. In the case of systems without a time limit, you will find
a hyphen “-“ next to this item.
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Information about the options installed
Millennium III is a program that has been designed to adapt itself to the
needs of the customer and to satisfy any production, economic and use
requirement.
For this reason, as well as offering different systems (Database, Edit,
Lettering, Punch Entry, Punch Advanced, Punch Professional), Millennium
III also offers many options.
To check which options have been installed select Settings > Program
Options > View Status

Legend:
= option disabled
= option enabled

How to change the system or install new options
To find out how to change the system or install new options, contact our
Sales Office at sales@proeltsi.com
If you are using a demo version, we kindly ask you to read the paragraph
“The Millennium III demo version”.
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The Millennium III trial version
Receiving from the Activation Service an activation file for a Millennium III
trial version, also called demo Version, means having a completely
operational Millennium III available for 30 days and having the possibility of
trying different systems.
The system to try are: "Edit II Full Option", "Punch Advanced Full
Option", "Punch Entry Full Option", "Punch Entry Offer" and "Punch
Professional Full Option". In the Configuration dialog (Settings >
Preferences) you can select the Millennium III system to use.

We have decided to send you five different systems to allow you to
evaluate Millennium III better and to decide which of the four systems is
best suited to your needs.
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Limitations of the Millennium III trial version
The demo version is fully operational. Its limitation is that it lasts for only 30
days and it is only enabled to save a file called "millenniumIII.cxm" that is
found, at least initially, in the Millennium III installation folder
(...\Programs\Millennium 3\). For those of you that have never used
Millennium III, "cxm" is the proprietary format of the program. While you are
evaluating the program, we ask you to bear in mind that some tools (Archive,
Alphabets, User Manual, Sample Files) must be installed separately using
the specific files that you may download from the download area or that you
can find in the installation CD.

Extension of the trial period
If you have not been able to evaluate Millennium III during the trial period,
you may contact our Sales Office (sales@proeltsi.com) to request an
extension of the trial period.

Purchasing Millennium III
We hope that Millennium III has lived up to your expectations.
If you wish to purchase the program contact our Sales Office at
sales@proeltsi.com or call +39 0432 815047.

Uninstalling the software
1. Close all applications
2. Click
on
the
Start
button
on
the
Microsoft
Windows™applications bar and then select Settings>Control
Panel>Install Applications
3. Select Millennium III from the list of programs and then click
on the Remove button.
4. Follow the instructions shown in the uninstall dialogue boxes
that will be displayed in sequence.
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The Protection key
Avoid damaging the protection key and allowing it to be used by
unauthorized persons. Should the protection key be damaged, contact your
authorized Proel TSI distributor directly.
Insert USB Hasp protection Key before run Millennium III.
If you try to run Millennium III without protection Key appears this message:

HASP USB KEY
HASP USB KEY

USB Port

When you install Millennium III for the first time is better turn ON the PC
before insert the USB Hasp Key.
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If you have problems with the protection Key contact us:

Laser Cutting Technology - Embroidery Software Solutions
Via Lino Zanussi, 20 - 33033 Codroipo (Udine) Italy
Tel: +39 0432 815047
Fax: +39 0432 905710
Web: www.proeltsi.com
Informations: info@proeltsi.com
Technical support: support@proeltsi.com
Sales Office: sales@proeltsi.com
Registration: activation@proeltsi.com
Software & Web: software@proeltsi.com

Installation
To install the program, follow these instructions:
Insert the hardware protection key on the USB Port.
Insert the Millennium III CD-Rom in the drive. The following window is
displayed:
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Click on Millennium III to install the program;
Click on Alphabets to install the proel alphabets;
Click on Background Editor to install the Background stitch effect
editor;
Click on TrueType Lettering to install the Millennium III fonts True Type
to create embroidered words with TrueType Lettering;
Click on Archive Sample to install a sample of Millennium III Archive to
manage the embroideries on the local PC or on the LAN.;
Click on M3 Samples to install a series of sample files comprising
embroideries, clip-art, backgrounds;
Click on Help to install the Millennium III on-line guide;
Click on Release Notes to display the Millennium III last release note;
Click on Drivers to install protection key drivers or floppy drive drivers.
Click on Explore Manuals to install Acrobat Reader (is needed to open
the Manuals on line) or display Millennium III manuals.
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Installing Millennium III
If in the installation window you clicked on the “Millennium III” button, the
following windows will be displayed in sequence:

If in the PC is installed an other version of Millennium III, a message will
appear asking if you extend it, repair it or uninstall it.
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If in the PC is NOT installed an other version of Millennium III, will appear
this window.

Press Next to continue.
Appear the license window

Read the license and if you want accept it; for accept tick the "I accept ..."
and click Next to continue the installation .
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Now appears the installation type window

choose the type of installation (we recommend Complete) and click Next to
continue.
Now appears the window for language selection and data configuration
for not overwrite the data of a previous installation of Millennium III. If it is a
first installation, the part of the data configuration does not appear.

Select language, data configuration and click Next to continue
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Now appears the installation start window

click Next to continue.
At the end of the installation which may take several minutes the following
window appears.

The window indicates that the installation is completed. It is proposed to
restart the computer. It is advisable to restart it by pressing Finish
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What install CD-Rom
In addition to the applications Millennium III and Archive are installed two
utilities:
• Backup: backup tool that allows you to create (or restore) backups
of various configuration files of Millennium III
• Compact-Repair Database: Tool that allows you to compact or
repair the Database

Millennium III registration
Quando avvierete Millennium III per la prima volta, si aprirà la seguente
finestra. In questa finestra dovrete digitare il Codice di Registrazione che
Vi forniremo e quindi fare click sul pulsante Registra Ora.
When Millennium III start for the first time, appears the Registration
window. In this window, you must enter the Registration Code that will
provide you and then click on Register Now.

Nota: Potete decidere di rimandare di alcuni giorni la registrazione facendo
click sul pulsante Registra Dopo (potrete aprire la finestra di registrazione
in qualsiasi momento selezionando Vista/Aiuto>Registrazione).
Note: You can decide to postpone for a few days the registration click on
Register Later (you can open the Registration window at any time by
selecting View/Help > Registration).
Remember that you have 30 days to register Millennium III after which
you can not use it !
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How to obtain your personal Registration Code.
There are two easy ways to obtain your Registration Code:

Online Registration
Click on the Obtain Registration Code button of the registration window
that will open when you start your Millennium III. Appears a on-line
Registration window on the Proel TSI website.

Fill in the Registration Form and submit it click on SEND button. In a short
time you will receive an email with your personal Registration Code.
Warning, this procedure requires connection to the Internet. If it is not
possible to connect to the Internet from the PC where Millennium III is
installed, you may access and fill in the on-line Registration window from
any other PC at the following address:
www.proeltsi.com/registration.html

Email Registration
Send an email to activation@proeltsi.com containing the serial number of
the product visible in the Registration window and the number of the
C3-11

Millennium III

hardware key that you can read on the USB protection key. In a short time
you will receive an email reply with your personal Registration Code.
For any questions on Milennium III registration contact the Registration
Service:





by calling +39.0432.815047
by faxing to +39.0432.905710
by sending an e-mail message to activation@proeltsi.com

The Registration Service is available Monday to Friday from
08.30 to 12.00 and from 13.30 to 17.30. We guarantee that the
Registration Code will be sent within 48 working hours.
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Starting Millennium III
Start the program by selecting Programs > Millennium > MillenniumIII
from the Windows(TM)

start menu.

How to display the installed options
To display the Millennium III options installed on your computer, select
Settings > Program options > View Status.
The program will read the options and their status (enabled / disabled) and
will display the list represented in the figure.

List of the options available

Status of the options (enabled
/ disabled)

How to install additional options to the program
The additional options installed after the first installation of the program
may be installed in several ways:
• With an unlocking code supplied (via fax or telephone).
• With a file containing the unlocking code supplied via electronic mail.
Depending on the method used, it is necessary to follow the procedures
described below:
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1. In the first case, select Settings > Program options > Enable options
from the menu and insert the code received.
2. In the second case, select Settings > Program options > Enable
options from file from the menu and select the file received.
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Use of the Manual on-line
To consult the Manual on-line select View/Help > Help.
If you are working in a language other than the one selected during
installation of the program and the relative Manual is not installed, the
following message will appear:

The manuals written in a language other than the installation language may
be installed at any time by using the Millennium III installation CD-Rom.
If, instead, the Manual is installed, Adobe Acrobat Reader is started and
the on-line Manual will be displayed:

The left part of the window will display the index of the Manual whereas the
right part will display the page corresponding to the index item selected by
clicking
on it with the left button of the mouse.
The way the pages are displayed may be modified by using the
buttons or by modifying the zoom value.

.

To search for a specific topic in the Manual, press the
button, insert
the term being searched for in the following window, and then press the
Find button:
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Menu symbols and commands
Conventions adopted
Often, in order to simplify reading, the typographical symbol ">" has been
used for the sequences of operations to be followed from the menu bar.
Therefore, for example, "select File>Open" means "select the Open
command from the File menu".

Symbols used in the manual
corresponds to a single click with the left button of the mouse.
corresponds to a single click with the right button of the mouse.
symbol used to describe contours, indicates pressing the left button of
the mouse and identifies the start of a curve or a corner of the curve itself.
symbol used to describe contours, indicates pressing the right button of
the mouse and defines the internal points of curves and arcs.
symbol used to describe contours, indicates pressing the space bar on
the keyboard and identifies the end of the segment being described.

Cursors and carets
Throughout this manual, the term cursor denotes a mobile symbol that
identifies the position of the mouse on the work area, whereas the term
caret denotes a symbol that may be placed in a fixed position on the same
work area. The cursor assumes different shapes depending on the
operation being performed.

Types of caret
•
•
•
•

symbol that identifies the thread entry point
symbol that identifies the thread exit point
symbol that identifies the starting point of an embroidery
symbol that identifies the extremity of a stitch

Types of cursor
•

symbol that the mouse cursor assumes when the line description
tool is being used
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•

symbol that the mouse cursor assumes when the circle/ellipse
description tool is being used

•

symbol that the mouse cursor assumes when the polygon
description tool is being used

•
•
•
•
•
•

symbol that the mouse cursor assumes
rectangle/square description tool is being used

when

the

symbol that the mouse cursor assumes when the automatic image
outline description tool is being used (outline
symbol that the mouse cursor assumes when the measuring tool
is being used
symbol that the mouse cursor assumes during modification of the
thread entry and exit points
symbol that the mouse cursor assumes when moving an entity
o symbol that the mouse cursor assumes during modification of
an entity

•
•

symbol that the mouse cursor assumes during rotation of an entity
o symbol that the mouse cursor assumes during distortion of an
entity

•

symbol that the mouse cursor assumes when the window zoom
tool is being used

•

symbol that the mouse cursor assumes during simple selection

•

symbol that the mouse cursor assumes when a knot is being
modified

•

symbol that the mouse cursor assumes when the Region
selection tool is being used

•

symbol that the mouse cursor assumes when the Extended
selection tool is being used

•

symbol that the mouse cursor assumes when the stitch selection
tool is being used

C4-9

Millennium III

Handles and nodes
Throughout this manual the terms handle and node denote squares that
appear on any entity that has been selected using a selection tool. The
handles ( ) allow modification of the entire entity, whereas the nodes ( )
allow modification of a specific part of the entity.

Millennium III toolbars
Standard toolbar
create a new file
open an existing file
open from Archive
save the active file
cut the selection, copying it onto the Windows clipboard
copy the selection onto the Windows clipboard
paste selection
undo the last modification
repeat the last modification
print

Work toolbar
activate the simple selection mode
activate the extended selection mode
activate the selection stitches
curve: lines description tool
ellipse:ellipses/circles description tool
polygon: polygons description tool
rectangle: rectangles/squares description tool
outline: tool for automatically describing the outlines of an image.
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zoom box (for activation, equivalent to pressing the F9 key on the
keyboard)
zoom + (equivalent to pressing the F11 key on the keyboard)
zoom – (equivalent to pressing the F12 key on the keyboard)
see all (equivalent to pressing the F10 key on the keyboard)
redraw the screen
enable/disable the grid
enable/disable snap
enable / disable stitch display
enable / disable display of connections between blocks
display the embroidery in a realistic way
enable / disable stitch display
enable / disable image display
enable / disable description curve display
enable / disable special functions display
set the display scale of the embroidery

Punch toolbar

work status selection and needle selection

Special Functions toolbar
Stop
High speed
Low speed
Frame out
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Begin chenille - End chain
End chenille - Begin Chain
Begin sequins
End sequins
Deposit sequin
Thread trim

Navigator toolbar
move the caret to the start of the embroidery
move the caret to the end of the embroidery
move the caret to the start of the selected entity
move the caret to the end of the selected entity
move the caret backward by 100 stitches
move the caret forward by 100 stitches
move the caret backward by 10 stitches
move the caret forward by 10 stitches
move the caret backward by 1 stitch
move the caret forward by 1 stitch
move the caret to the preceding short stitch
move the caret to the next short stitch
move the caret to the preceding long stitch
move the caret to the next long stitch
inserts the selected stitches in the shopping cart
deletes the contents of the shopping cart
moves the caret to the opposite side of the selection
is an alternative to the shift lock key on the keyboard
selects the stitches in an irregular area
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moves the caret to the point specified by the user in the window that
follows (alternative: key G)
splits the entity
clean short stitches
makes it possible to specify the length in mm of: long stitch, short stitch
and the stitch hooking distance.

Slow Draw toolbar
move the caret to the start of the embroidery (or HOME Key)
move the caret to the end of the embroidery (or END Key)
move the caret to the start of the selected entity (or Page UP Key)
move the caret to the end of the selected entity (or Page DOWN)
move the caret backward by 100 stitches (SHIFT + left arrow)
move the caret forward by 100 stitches (SHIFT + right arrow)
move the caret backward by 10 stitches (CTRL + left arrow)
move the caret forward by 10 stitches (CTRL + right arrow)
move the caret backward by 1 stitch (left arrow)
move the caret forward by 1 stitch (right arrow)
move the caret to the preceding short stitch (Shift+S)
move the caret to the next short stitch (S key)
move the caret to the preceding long stitch (Shift+L)
move the caret to the next long stitch (L key)
moves the caret to the point specified by the user in the window that
follows
move the caret backward at the specified speed, until a command on
toolbar, or on keyboard, is pressed.
move the caret forward at the specified speed, until a command on
toolbar, or on keyboard, is pressed.
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makes it possible to specify the speed of

and

makes it possible to specify the length in mm of: long stitch, short stitch
and the stitch hooking distance.

Status bar
Changes on the basis of the work mode selected
Rapid recall to setting of the main
parameters of the selected mode

Selection of
style type

On-line info /
help
message

The example
represents
setting
of
column width

Type of
selected

Setting of stitch
length

objectTotal
number
stitches deposited
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Setting
density

of

of

Access button for
setting all the
parameters
of
the selected work
mode

Positioning of the cursor alon the
X and Y axes (if the numbers
displayed are enclosed within
square brackets, they indicate
the relative coordinates)
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Rulers
By selecting View>Rulers it is possible to display, on the X and Y axes of
the embroidery window, the respective Rulers (graduated in millimeters)
whose function is to aid the user in determining the size of the work area
and of the objects contained within it.

By using the Rulers in combination with the Grid (refer to the chapter "Grid
Configuration") it is possible to make the work on the embroidery window
even simpler and more functional:
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Special Windows: Tree View, Aerial View, Stitch
View
Tree View
The Tree View can be enabled or disabled from Window menu, selecting
Tree View.
The tree allows four different views of the Embroidery document.
1.
2.
3.
4.

Document
Embroidery
Blocks
Functions

The Document view lists all objects contained into the object:
•
•
•

Images (it is possible to have more then one image open at the
same time in the document).
Embroidery (it is possible to have only one embroidery per
document)
Drawing objects (all the objects created with the drawing tools and
not used to generate stitches).

Click with the mouse left button on one of the list items; the corresponding
object is selected. If the list item is the embroidery, the whole embroidery
will be selected.
It is possible to select more then one object, also of different kind.
 To select more then one adjacent object:
 Move the mouse cursor on the first object and click on it with the
left button.
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Press the Shift key
and holding it down click on the second
object with the left mouse button. All objects between the first and
the second object included will be selected.
 To select more then one non contiguous objects:
 Move the mouse cursor on the first object and click on it with the
left button.




Press the Ctrl button
objects you want to select.

and holding it down click on all other

The Embroidery View lists all stitch and function objects that are in the
embroidery:
The functions are visible in this list only if the function display button is
down

.

 Punching objects:
 Manual
 Automatic
 Column
 Satin/Fills
 Tatami
 Text
If an object contains other objects, like:
 Column
 Curve
 Satin/Fill
 One or more curves
 Text
 One or more curves
 All characters of the text
If with the mouse you click on an object inside another, the object will be
selected.
For example clicking on a column, the column and all objects contained are
selected, where clicking on an item curve, only this last will be selected.
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The Block View shows the embroidery objects, grouped by color.
In the Block view it is possible to expand any color group to see the
grouped objects, but not the objects inside the group, like Columns or
Satin, etc.

The Function View shows the functions contained in the embroidery.
Only if the button Functions
view.

is down, it is possible to activate this

NOTE: When there is a click on the Tree pane (or the buttons Ctrl+R are
pressed) the program gives the control to the tree window and
activates
the
Simple
Selection
tool.
Going back to the embroidery window with a click of the mouse,
to activate again the last used tool, press the key
C4-18
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In the Tree view window, and in particular in the Embroidery view and in
the Blocks view, it is possible to change the sequence of the single entities
that constitute the embroidery, selecting them and dragging them by using
either the left or the right button of the mouse.
In the first case it is possible only to move the entity, whereas, in the
second case, it is also possible to duplicate it.
In both cases, however, the entity being moved is placed before the entity
where the mouse is positioned before the button is released.
Example: In the following Tree view, the Text entity is to be moved
between the Tatami entity and the Satin entity:
Before:
After:

Use of the left button of the mouse
Select the Text entity using the left button of the mouse and, keeping the
button pressed, drag it towards the bottom and bring it above the Filling
entity, then release the button of the mouse.
Note: in the case where the entity being moved is dragged above the last
entity of the Tree view, the following menu appears:
that makes it possible to choose whether the entity in movement must be
moved before or after this last entity.
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Use of the right button of the mouse
Select the Text entity using the right button of the mouse and, keeping the
button pressed, drag it towards the bottom so as to bring it above the
Filling entity, then release the button of the mouse. The following contextual
menu appears:

that makes it possible to choose whether the entity in movement must be
moved (Move) or duplicated (Copy).
Note: in this case also, if the entity that is being moved is dragged above
the last entity of the Tree view, then the following menu appears:

that makes it possible to choose whether the entity in movement must be
moved, or copied, before or after this last entity.
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Representation of the entities in the Tree view
In the Tree view window, and in particular in the Embroidery view and in
the Blocks view, it is possible to represent the entities using different types
of icons. Using the right button of the mouse, press on the Tree view
window and select the Properties command from the contextual menu.
The following window appears:

Select No Icons if each entity is to be represented by a generic icon:

Select Small Icons if each entity is to be represented by an icon of a small
size (16x16 pixel) reproducing the shape of the entity:
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Select Large Icons (Proportional) if each entity is to be represented by an
icon of a larger size (up to 64x64 pixel) that will be proportionate to the
other entities of the embroidery:

Select Large Icons (Show All) if each entity is to be represented by an
icon of maximum size (64x64 pixel):
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Functions view of the tree view
In the Tree View window, and in particular in the Functions view, it is
possible to select the color change and thread trim functions in order to
delete them or to modify their properties.

Thread trim function
By selecting a thread trim function using the right button of the mouse it is
possible to select the following from the contextual menu that appears:

-

Cancel if you wish to delete de function (you may use also the Del
key).
Properties if you wish to open the properties window and modify the
thread tie parameters:

Consult the chapter "How to set thread tie and thread trim" for further
details on how to set these parameters.
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Color change function

C4-24

Millennium III

C4-25

Millennium III

C4-26

Millennium III

C4-27

Millennium III

By selecting a Color change function (Needle N) with the right button of the
mouse it is possible to select one of the following from the contextual menu

that appears:
- Delete if the function is to be deleted (it is also possible to do this by
using the Canc key).
- Change Needle to open the properties window and modify the color of
the needle:

Consult the chapter "How to set and modify needle color" for further details
on how to set the color of the needle.

Representation of the entities in the Tree View
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In the Tree View window it is possible to represent the entities using
different types of icons, in the Embroidery view, as well as in the Blocks
view and in the Functions view. As regards the first two functions, this
topic has already been discussed in the chapter "Representation of the
entities in the Tree view" in the 1.25 version Manual.
To change the representation modalities of the entities in the Functions
view, press on the Tree view window with the right button of the mouse
(after having selected the Functions command) and select the Properties
command from the Contextual menu.
The following window appears:

In the Icons section:
- Select Large Icons (proportional) if each entity is to be represented
by a large icon (up to 64x64 pixel) that in any case will be in proportion
to the other entities of the embroidery:
- Select Large Icons (Show All) if each entity is to be represented by an
icon of maximum size (64x64 pixel).
In the Functions view section:
Select Blocks if between each function and the next, only the stitches that
have been deposited between these functions are to be represented:
Example:
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In the Functions view section:
Select Film if between each function and the next all the stitches that have
been deposited from the start of the embroidery until the specific function
represented are to be shown in sequence.
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Example:

Aerial view
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The Aerial view allows a quick change of the area of embroidery displayed
on the screen.
The Aerial view can be activated from the menu Window activating the
menu item Aerial View.

To change the displayed area of the embroidery, press the left button of the
mouse inside the dotted rectangular area in the Aerial View pane and,
keeping it pressed, move the rectangle over the desired area.

Stitch View
Allows seeing the list of stitches as numerical values and the list of the
functions.
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This view can be enabled through the menu Window and the item Stitch
View.
This view shows information only if Stitch Selection
Slow Draw is activated.
The displayed values are not modifiable.

is enabled or

Click on the pane with the right button and select Properties to configure
the columns you want to show in the list.
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Setting the work parameters (Properties)
Before starting an embroidery it is necessary to set the work parameters
recommended in the Properties window that may be displayed by selecting
Embroidery>Properties, or by pressing the combination of keys Ctrl+G or
even by clicking with the right button of the mouse in a free section of the
Millennium III work area and then selecting the Properties command from
the contextual menu.

This window contains two buttons:
OK = allows the work parameters, that you have set in the various folders
in the window, to be used only in that one embroidery that you will create.
Set as Default = allows the work parameters, that you have set in the
various folders in the window, to be used in all the new embroideries that
you will create.
Therefore, the Set as Default button is particularly useful for memorizing
those work parameters that recur in your jobs or for using the parameters
from an old embroidery in a new one. In the latter case, open the old
embroidery, display the Properties window and then press the Set as
default button. After closing the old embroidery and opening a new work
sheet you will be able to see (by displaying the Properties window) that the
work parameters that have been set really are those of the old embroidery.
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Setting of general parameters
Field where the name of
the created embroidery
is inserted
Allows the work area to be
delimited visually
Field for inserting notes of
any type

Setting of the punch parameters
From the table, select thread,Enabling / disabling of the parameters relative to thread tie and
fabric and style to be used forthread trim and setting of maximum stitch length, after which the
the new embroidery
system automatically adds a thread tie and a thread trim
Enables/disables
parameters
relative
compensation

the
to

Press
to
enable
manual
movement of of the starting stitch
of the embroidery
Press to enable automatic movement of
the starting stitch of the embroidery

Press to make the starting and ending stitches of the
embroidery coincide and movable manually.
Setting of Borer depth
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Setting the needles (colors)
The program supplies a set of default colors (Proel RGB) associated to the
relative needles, to be used for the different parts of the embroidery.
To obtain on screen an effect that is very similar to the end result of the
embroidery, it is possible to modify these colors, attributing to each needle
the true color of the thread that will be used.
List of the default colours (Proel RGB)
set at the start of the program

Press the button to add a new
needle
Press the button to change
the colour of the selected
needle
Press the button to remove
the selected needle from
the list
Press the button to reset
the default needles (Proel
RGB)
Press the button to move
the selected needle up or
down

Press the button to select the background colour of embroidery
window (default = white)
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How to add a new color to the list
•

Press the Add button

1. select the type
2. select the thread Code
or the Pantone desired
3. press OK to confirm

Press to obtain a list of the
threads, ordered by code
number

Press to obtain a list of the
threads, ordered by pantone
number.

At this point, the selected color will be present in the list.
NB: the program during the course of punching will fill in the fields relative
to Operations list and Information automatically (in an incremental way).
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Setting the work parameters (Configuration)
Select Tools >configuration from the menu

General configuration
Set
the
language

program

Maximum
number
of
“undo/redo”
operations.
The higher this number,
the slower the system.

Enable/disable display of the
“Properties” window when the
program starts up

Millennium III uses millimeters (mm) as the default unit of measure.
However by selecting Tools>Program Configuration it is possible to
select the Inches command in the General folder to have the rulers and
the dimensional values expressed in inches (in).
Even if the units of measure are set in inches, the punching parameters
indicated in the different windows (for example stitch density and length)
will still remain expressed in millimeters.
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Configuration of special functions

Select the type of sequin

Set the size of the sequin

Video configuration

Video correction (mm) = To obtain a video display of the embroidery
dimensions that is very close to reality it is necessary to measure the X and
Y dimensions (in millimeters) of the useful area of the monitor and enter
them in the corresponding boxes (for a 17” monitor, the usual
measurements are X=320mm and Y = 240mm).
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Cross hair cursor = if you check this box, the mouse pointer will be
identified by a cross covering the entire screen, as well as by the usual
arrow.
Automatic pan type = in this box you may select two types of automatic
panning (the function that allows the work window to scroll automatically
when you drag beyond its edges).
¼ = the window scrolls automatically by snaps that are ¼ of the size
of the window.
Continuous = the window scrolls continuously.
Warning, to activate the Automatic Pan function, select View>Automatic
Pan (the function is active if a check sign appears to the left of the
Automatic Pan menu command.
Line drawing: node snap area (pixel) = in the relative boxes, set the
snapping distance (X and Y) from the pointer to the important points. For
further details, consult the paragraph “Snapping of important points”.

Save configuration
Set the time interval between
one automatic save and the
next
Check the box
to
enable
autosave of the
embroidery

Enable save image together with
the embroidery, thus re-opening
the embroidery will also re-open
the image used

Enable save image path,
reopening the embroidery will
also reopen the image used

Does not save the image, therefore
reopening the embroidery will not display
the image used previously
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Draw configuration
Customize the colours of the
different types of curves generated
during the outline description
phase.
To modify the default colour, select
the type of curve and press the
Modify button.
Then select the desired colour and
press OK.

To modify the default colour, select
the type of curve and press the
Modify button.
Then select the desired colour and
press OK.
Set the number of sides
that will be created using
the polygon creation tool

Punch configuration
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Enables automatic inclinations
in columns

Enables
inclinations
tatami

in

automatic
fills and

Refer also to the chapter “How
to set the inclinations”
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Grid configuration
Set the original X and
coordinates of the grid

Y

To modify the default
colour press the Modify
button. Then select the
desired colour and press
OK

Set
the
dimensions of
the grid cells
in mm

Set the type of
grid line

Check the box
to
enable
display of the
origin of the X
and Y axes

Set grid split

Set change line type
every N squares

Grid split: is the stitch subdivision into which the dimensions of each cell of
the grid are virtually subdivided (height, width, and diagonals). During
description, modification or movement of any entity, obviously when grid
blockage is activated (
button on the Tool bar) the cursor is hooked to
the grid and moves according to the intervals set by the Grid split.
If Grid split = 1 is set, the cursor, to describe a dimension of the cell (height,
width, diagonals), must move by one interval, setting Grid split = 2, the
cursor, to describe a dimension of the cell (height, width, diagonals) moves
by two intervals, and so on.
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Configuration of the general parameters
By selecting the tools > general parameters command it is possible to set
the parameters relative to thread tables, fabric tables, style tables and
styles.
Management of the parameters
relative to the creation of thread
tables
Management of the parameters
relative to the creation of fabric
tables

Creation of style directories. Each
directory contains the group of
styles associated to it.

Creation of styles. Style means the
group of characteristics set for each
work mode

Exit from
parameters
program

the general
configuration

Thread table
The thread tables allow the user to set the general parameters of the
stitches (minimum length, minimum density, maximum number of
shortenings, shortening percentage) and the densities for columns, fills
and tatamis, for any type of thread.
By default, Millennium III provides some thread tables with parameters
suitable for threads of different thicknesses, however the user may create
other tables with the desired settings.
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How to create a new thread table
•
•
•

Click on the New command, and insert the name of the new thread
table that is being created and insert the density value in the window
that appears.
Press the OK button to confirm
At this point it is possible to set all the other parameters described
above.

How to modify a thread table
•
•
•

Select the thread table whose parameters are to be modified.
Modify the desired parameters
Press the Save button

How to delete a thread table
•

Select the thread table to be deleted and press the Delete button.

How to set the parameters of the thread tables

Button for saving the
modifications made to
a table

Button for creating a
new table

List of the thread tables
created

Setting of the general
parameters relative to
stitch management (for
the meaning of each
single item see the
relative explanations in
the manual
Setting of the densities
for the various types of
columns, fills and tatami
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To recall the created or modified thread table during punching it is
necessary to:

Select the thread
table at the start
of the work (or
recall it by
pressing the
combination of
keys Ctrl+G)
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Fabric tables
The fabric tables allow the user to set the parameters relative to underlay
and fabric pull compensation for any type of fabric (jeans, cotton, silk,
viscose, etc) and for any type of stitch (column, fill, tatami).
By default, Millennium III provides some thread tables with parameters
suitable for light, medium and heavy weight fabrics; however the user may
create other tables with the settings desired.
Default fabric table
provided by the program.

Press the new button to create
a new table

Button for deleting
a table after having
selected it

Set the
underlay and
pull parameters
for column, fill
and tatami

How to create a fabric table
•
•
•

Click on the New command and insert the name of the new fabric table
in the window that appears
Set the underlay and pull values for the desired modes.
Press the Save button to confirm.
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How to modify a fabric table
•
•
•

Select the fabric table whose parameters are to be modified
Modify the desired parameters
Press the Save button.

How to delete a fabric table
•

Select the fabric table to be deleted and press the Delete button.

To recall the created or modified fabric table during punching it is
necessary to:

Select the fabric
table at the start
of the work (or
recall
it
by
pressing
the
combination
of
keys Ctrl+G)
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Style tables
The style tables contain a group of styles that may be customized by the
user.
Millennium III is provided with a default style table, however the user may
create other tables with customized styles, by beginning with an empty
table or by modifying the default table proposed by the program
List of style tables
created
Check the desired
box to create a new
table

Press the New button to
create a new table

To delete a style
table, select the
desired table and
press the Delete
button

Button for
restoring the
original default
parameters

How to create a new style table
•
•
•
•

Set the type of table to be created (empty table, duplicate existing
table, duplicate a table using tread and fabric tables) by checking the
appropriate box.
Press the New button
Type in the name to be given to the new table
Press the Save button
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How to create a style
A style represents a working mode (for example automatic) with all the
associated and memorized parameters (stitch length, density, etc) set
with suitable values according to the needs of the user.
In this way, depending on the type of work, the type of fabric, the type of
thread used, it will be possible to define the most suitable styles and
therefore recall them when needed.
To create a new style, follow the example below:
1 – Select the desired style table3 – Select the type of
4 – Press the New button and
(prova in the example)
Automatic
desired
insert the name of the new
(normal in the example)
style (aut 0.50 in the example)
and press OK

2 – select the
working mode that
will be used to
create
a
style
[Automatic
(Running) mode in
the example]
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5 – set the parameters to be memorized in
the created style
6 – press the
save button to
save the style
created

At this point the style aut 0.50 has been created in the test style table. To
recall it during punching it is necessary to:

Select the test
style table (or
recall it by
pressing the
combination of
keys Ctrl+G)
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Now by selecting automatic mode from the working mode bar

in the style type selection,

the style created, aut 0.50, will be available

Saving the modes defined by the user
The program makes it possible, starting with the work mode currently in
use (Automatic, Column, Tatami or Satin), to create new work modes and
to rename or delete the existing mode tables.
To do this, it is necessary to select Embroidery>Update Styles Tables,
the Style Table Management dialogue box appears:
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having done this, it is possible to press the button
to delete the table or
the style created, or press the OK button to confirm and therefore add the
new Style Table and the new Style to the database that may be displayed
by selecting Tools>General Parameters>Style Table e Tools>General
Parameters>Styles.
Each time that the work mode to which the new Style Table and the new
Style are associated is selected, the new Style created will be present also
in the Favorites list of the relative tool bar:

The Properties button, present in the Style Table Management window,
makes it possible to display the Properties window of the mode that
contains a list (that cannot be modified) of the properties associated to the
saved mode.
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The Update button, instead, makes it possible to update the parameters of
the new Style created, each time that these parameters are modified.
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Use of the default style tables
As explained in the chapter “Configuration of the general parameters”,
Millennium III supplies by default some Thread tables that contain
parameters relative to different types of threads, and Fabric tables that
contain parameters relative to light, medium and heavy weight fabrics.
However the user may create other tables containing the desired settings.
The Properties window of version 1.26 of Millennium contains a new
command (Use default) that, if checked, enables the use of these default
tables.
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How to set the threads
Millennium III contains a database with many threads inserted. Each color
of the same thread is associated to a unique numeric identification code,
a Pantone code if available and the respective graphic image of the color
represented. Select Tools>Treads:
List of the threads
available in the
default database

Thread Type

Button for sorting
the colours of the
selected thread in
increasing order with
respect to the
Pantone code
associated to each
colour

Button for sorting
the colours of the
selected thread in
increasing
order
with respect to the
identification code
of each colour

Button that makes
it possible to find
threads of different
brands that are
equivalent to the
selected thread

Possibility of
applying a
thread type
filter
(polyester,
cotton, etc.)

Press to print the list
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How to create a “thread card”
1- Position the mouse cursor on
the last free field (marked with the
symbol) in the “Card” column
2- Insert the name of the thread
to be introduced (NB:when you
begin to write, a new box marked
by the symbol
is created
automatically)

4- At this point, to end card
creation, it is necessary to
press once either the up
arrow or down arrow key on
the keyboard, or click with
the mouse on an existing
row.

3- From among the types available, select the type of
thread to be associated to the thread card created
5- - Position the mouse cursor on the last free field
(marked by the symbol ) in the “Code” column
6- Insert the desired code (NB: when you begin to write,
a new box marked by the symbol
is created
automatically)

7- insert, if possible the
corresponding Pantone
code

8- position the mouse
cursor on the “Colour”
field and click on the
symbol
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9- From the “Colour”
window, select the RGB
colour desired and press OK
to confirm

10- At this point, to end thread
creation, it is necessary to
press once either the up arrow
or down arrow key on the
keyboard, or click with the
mouse on an existing row.

How to modify a “thread card”
• Select the card to be modified
• Modify the desired field
• Press the Exit button

How to delete a “thread card”
To delete a thread card, it is necessary first to delete all its contents
In other words:
• One by one, select all the rows that contain threads to be deleted and
press the Del key on the keyboard
To select an entire row it is
necessary to position the
mouse cursor on the point
indicated in the figure (Note:
the mouse cursor assumes
the following graphic symbol
►)

Then select the thread card and press the Del key on the keyboard.
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Working with objects
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Using the drawing tools for describing contours
This chapter explains the use of all the tools needed to start punching a
drawing.
Punching means following the outline of a figure and then filling it with a
type of stitch that could give a pleasing effect. The program makes tools
available to facilitate this operation and to make it as rapid as possible.
NB: if the “draw shapes” method is used, drawings are created without
depositing stitches inside them. If instead any other method is used,
(automatic, column, text, tatami), the stitches are deposited by pressing the
Enter button at the end of outline description.
An outline may contain straight lines, curves, arcs, circles, ellipses,
polygons or a mixed combination of these objects.

Drawing tools
creation of lines
creation of circles/ellipses
creation of polygons
creation of rectangles
creation of automatic image outline

Use of the mouse
indicates that the left button of the mouse has been pressed and
identifies the start of a line, or the intermediate points of a multi-line, or the
start of a circle/ellipse, of a rectangle or of a polygon.
indicates that the right button of the mouse has been pressed and
defines the internal points of a curved line or of an arc.
indicates pressing the space bar on the keyboard and identifies the
end of the segment being described.
An outline may be open or closed.
The description of a closed outline makes the program behave differently
with respect to an open outline.
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Example of a closed outline

Example of an open outline
Open and closed outlines may be recognized on screen because they are
indicated by different colors that may be configured at will in the
Configuration table of the Tools menu, using the Draw command.
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To modify the color of the contours
•
•

Select the type of description curve whose color is to be modified.
Press the Modify button.

•

Select the desired color and press OK:

Examples of contour description
Description of a straight line
• Use the

button on the toolbar

• Pressing the
button indicates the
start of the straight line.
• Pressing the
button indicates the
end of the straight line.

Description of multiple straight lines

• Use the
• Pressing the

button on the toolbar
button indicates the start of the straight line.
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• Pressing the
button indicates the end of the first segment and the
start of the second.
• Pressing the
button indicates the end of the second segment and the
start of the third.
• Pressing the
button indicates the end of the third segment and the
start of the fourth.

Description of a curved line

• Use the

button on the toolbar

• Pressing the

button defines the start of the curve.

• Pressing the
• Pressing the

button describes the intermediate points of the curve.
button defines the end of the curve.

Description of multiple curved lines

• Use the

button on the toolbar.

• Pressing the

button defines the start of the first curve.

• Pressing the
curve.

button describes the intermediate points of the first

• Pressing the
the second.

button defines the end of the first curve and the start of
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• Pressing the
button describes the intermediate points of the second
curve (3 points).
• Pressing the
button defines the end of the second curve and the
end of the entire section.

Description of an arc

• Use the

button on the toolbar.

• Identify the first point with

.

• With shift
, identify a point halfway along the arc.
• With
, identify the final point of the arc.

Description of multiple arcs

• Use the

button on the toolbar

• Start of the first arc with

.

• Intermediate point of the first arc with shift .
• Continue as above for the other arcs.
• With
, identify the final point of the last arc.

Description of a mixed line
• Use the
button on the toolbar
The outline described is composed of straight lines, curves, arcs.
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Description of a single segment curve
Method used when one side of the figure is very jagged and the other has
no corners.
• Use the

button on the toolbar

• Identify the first point of the first curve with a .
• Trace the outline of the figure as previously described.
• Identify the final point of the first curve with a
.
• Describe the second curve in the same way
The first and final points of the curve give the orientation of the stitches.

C6-9

Millennium III

Description of curves with symmetrical sides:

Description of curves with non-symmetrical sides:

Description of curves that have first or final points that coincide
The effect is parallel to the segment that joins the first points.
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Description of curves that have first and final points that
coincide
The effect is perpendicular to the segment that joins the first and final
points.

Note: for more information refer to the chapter “How to set the
inclinations”.

Closure of curved and straight lines
To obtain a closed outline, it is sufficient to press the
keyboard and the outline will close automatically.

+ key on the numbers

Example:
• Use the

button on the toolbar.

•
•

Trace an outline.
Press the + key on the numbers keyboard.

•

The outline closes

and changes color.
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NB: by pressing the + key the outline is closed with a straight line, by
pressing the combination of keys Ctrl + the outline is closed with a curved
line.

Description of an ellipse or circle
•
•

Select the tool
for creating circles/ellipses.
Position the mouse cursor on the starting point of the rectangle that will
contain the circle or ellipse.

•

Press the
button of the mouse and keeping it pressed, drag it to the
final point, then release it.

To draw a circle, press the Ctrl key before releasing the mouse, the
rectangle is transformed into a square where the circle is inscribed.
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Description of a circle passing through three points
From version 1.30 it is possible to draw circles passing through three
points.

B
A

C

A circle passing through points A, B
and C is to be described
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1. Press the
work toolbar.

button on the

2. Indicate point A with
3. With Shift +

.

indicate point B.

4. Indicate point C with the + key on
the keyboard.

The arc passing through the three
points A, B, C is closed - thus
transforming it into a circle.

Note: if the three points through which the circle has to pass are important
points of an entity described earlier, we suggest using the method for
snapping important points, described in the next paragraph.

Description of a polygon
•
•

Select the tool
for creating polygons
Position the mouse cursor on the starting point of the rectangle that will
contain the polygon

•

Press the
button of the mouse and keeping it pressed, drag it to the
final point, then release it.
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NB: it is possible to set the number of sides of the polygon by means of the
Configuration window of the Tools menu using the Draw > Polygon
sides command.

Description of rectangles and squares
•
•

Select the tool
for creating rectangles and squares
Position the mouse cursor on the starting point of the rectangle /
square.

•

Press the
button of the mouse and keeping it pressed, drag it to the
final point, then release it.
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NB: if the Ctrl key on the keyboard is pressed before releasing the mouse,
the rectangle is transformed into a square.
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How to select and modify the entity created
The operations described here may be effected on entities with or without
internal stitches.
Naturally, if the modified entity contains internal stitches, these stitches will
be modified also, automatically adapting themselves to the new shape
and/or size that has been set.
Millennium III allows three different selection levels of the created entity:
•
•
•

Simple selection: allows to move, modify, rotate and deform the entire
entity selected
Extended selection: allows modification of the parts of the entity
selected
Stitches selection: allows modification of embroidery stitches

Simple selection
To activate simple selection mode press the
button on the toolbar.
Position the mouse cursor on the desired entity.
With a single click
•
•

Move the selected entity by moving the center of the entity identified by
the symbol .
modify the x and y dimensions of the entity by acting on the movement
handles identified by the symbol .

With a second click
•
•

on the entity the system makes it possible to:

on the entity the system makes it possible to:

rotate the selected entity by acting on the rotation points identified by
the symbol
deform the entity along the x and y axes by acting on the deformation
points identified by the symbol .
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Example of a entity selected with a single click
As may be seen from the figure, particular symbols appear along the
borders
of
the
selection:

Hooking
handles
for
modifying the
curve along the
x and y axes

Center
of
the
selected curve

To move the selected entity to another point in the work area:
•

position the mouse cursor on the symbol, at this point the mouse
cursor assumes the following graphic symbol ,

•

click
and keeping the button pressed, move the entity to the desired
position
release the mouse button.

•

To modify the dimensions of the selected entity:
•
•
•

position the mouse cursor on the hooking handles (identified by the
symbol ) for modifying the entity along the x and y axes.
Depending on the handle hooked, the mouse cursor assumes the
following graphic symbols
click
and keeping the button pressed, move the mouse until the
desired effect is obtained.
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Example of modifying the dimensions of the selected entity
Modifying along the X axis
Original curve

Hooking handle dragged towards
the outside

Modifying along the Y axis

C6-19

Result obtained after
the modification

Millennium III

Result
obtained
modification

Original curve

Hooking handle
dragged towards
the outside

Reduction of both dimensions
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Result
obtained
modification

Original curve
Hooking
handle
dragged towards
the inside

C6-21

after

Millennium III

Increase of both dimensions
Result obtained after modification

Original curve

Hooking
handle
dragged towards the
outside

Example of a entity selected with a second click
As may be seen from the figure, particular symbols appear along the
borders of the selections:
Hooking
handles
for rotation

Hooking handles for
distortion

Center of rotation of
the curve

To rotate the selected entity to another point of the work area:
•

position the center of rotation (identified by the symbol) in the desired
position, position the mouse cursor on one of the rotation hooking
handles (identified by the
symbol), at this point the mouse cursor
assumes the following graphic symbol
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•

click
and keeping it pressed, move the mouse upward to rotate in a
clockwise direction, downward to rotate in a counter-clockwise
direction.

•

Release the mouse button.

To distort the selected entity:
•
•
•

Position the mouse cursor on the distortion hooking handles of the
entity (identified by the symbol) along the x and y axes.
Depending on the handle hooked, the mouse cursor assumes the
following graphic symbols
click
and keeping it pressed move the mouse until the desired effect
is obtained.

Example of distortion of the selected entity
Distortion along the X axis
Original curve

Hooking
handles
distortion

Result obtained after modification

for
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Distortion along the Y axis
Result
obtained
modification

after

Original curve

Hooking handle
for distortion

Simple selection: further details
When you select an object using the simple selector, an X will appear in the
center of the entity itself and eight selection handles will appear in
correspondence with the corners and median points used to define a
rectangle.
To select a single entity, move the pointer above the entity itself and then
click with the left button of the mouse.

Instead, once the entity is selected, to change the type of selection handle
it is sufficient to click on any point in the area defined by the selection
handles themselves.
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The same rule applies for the activation of the contextual menu of a
selected entity (that may be activated using the right button of the mouse).
Therefore, even in this case, it is sufficient to click on any point in the area
defined by the selection handles:

If you need to select several entities at the same time, draw a selection
window by dragging the mouse whilst keeping the left button pressed; all
the entities completely contained within the selection window will be
selected.
Instead, if you need to select all the entities present on the work area,
select Edit>Select All (or use the combination of keys Ctrl+F).
To deselect one or more entities, click with the left button of the mouse on
an empty section of the work area or press the ESC key.
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Note: It is very important to always bear in mind the simple selection rules
in order to avoid some situations that could be mistaken for program
malfunctions (refer to the two examples shown below).
Example 1:
I am unable to select a second entity included in the area defined by the
selection handles of a first entity that has already been selected. Solution:
unless you wish to select both entities using the Shift key, it is necessary to
deselect the first entity and then select the second entity.

Example 2:
I click with the right button of the mouse on an empty section of the work
area, but the contextual menu of a typical embroidery entity is displayed.
Solution: probably the zoom level is such that the area displayed, that
seems empty to you, is in fact situated within the selection handles of a
selected entity.

by looking at the aerial view, it is possible to immediately identify which
section of the embroidery is displayed on the work area at that moment;
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Decreasing the zoom....

...we realize that the U shaped entity was selected and therefore the
contextual menu that was displayed initially referred to this entity:
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Extended selection
Extended selection makes it possible to modify the selected entity in a
more extensive way.
To enable the extended selection mode, press the
toolbar.
Position the mouse cursor

button on the

on the desired entity.

At this point:
•

if the entity does not contain stitches (in other words, if you are
working with the draw shapes method or if stitches have not been
deposited), to select the entity it is necessary to click once with the
mouse

On the entity
that
allow
•

.

its

shape

the nodes identified by the
to
be
modified
will

symbol
appear.

If the entity contains stitches there are two further selection levels:
1. Pressing the
button of the mouse, the program makes it
possible to modify:

A Move entire entity
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B Move the thread entry point

C Modify the inclinations (refer to inclinations chapter)
D Move the thread exit point
2. By pressing instead the
button of the mouse together with the
Ctrl key on the keyboard, the program makes it possible to modify

the shape of the entity :

To modify the shape of the entity
•

•

Position the mouse cursor on the node
desired (when the mouse
cursor is positioned above the node it assumes the following graphic
symbol
)
At this point it is possible to move or delete the selected node.

To move the node
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•

click
(the node assumes this graphic symbol ) and keeping the
button pressed move the mouse until the desired effect is obtained.

•

When the mouse button is released, the system will automatically
proceed to recalculate the stitches.

To delete a node
•
•

click
(the node assumes this graphic symbol
key on the keyboard.
Original curve

•

Selected handle

) and press the Del

Curve after deletion

When the mouse button is released, the system will automatically
proceed to recalculate the stitches (if the entity contains any).

Otherwise:
Click with the right key of the mouse
displayed.
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click on Delete Node.
To cancel more than one node
It is possible to cancel several nodes at the same time by selecting them
using a window described with the extended selection tool. The selected
nodes assume this graphic symbol and may be canceled by pressing the
Del key on the keyboard.
Insert node
Push on the Extended Selection button.
Select the entity with

and enable the display of entity nodes (If the entity

contains stitches click again with Ctrl +

).

Click with the right key of the mouse
on the entity (not on one existing
node).
On the displayed menu, click on Insert point item.
Close/Open entity
If the entity does not contain stitches (in other words, if you are working
with the draw shapes method or if stitches have not yet been calculated)
Proceeding as described in Insert point paragraph, you get also the
following Menu items:
If the entity is an open entity, can be closed using the two following
methods:
1. Close with Standard connection
2. Close with Smooth connection
If the entity is a closed entity can be opened selecting Open Shape
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Editing curves
Using the extended selection tool
on any drawing made with the
Drawing Mode method will display all the nodes that define it.
These nodes may be of three types and each is identified by a different
symbol:
= corner node
= smooth node
= arc node
Examples:
corner node

smooth node

arc node

The program makes it possible to replace any one of the three types of
node with one of the others in order to modify the shape of the selected
object.
To do this, it is sufficient to click with the right button of the mouse on the
node to be modified and, from the contextual menu that appears, select the
type of change to be made:

Note: remember that, to display the nodes of an embroidery entity, it is
necessary to keep the Ctrl key pressed before pressing the left button of
the mouse.
Example: to round off the two opposite corners of a square:
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Before:

After:

Procedure:
One at a time, select the two corner nodes to be modified and from the
contextual menu that appears, select the Change to Smooth Node
command:
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Entity structure and selection levels
The embroidery entities created in Millennium III consist of several entities
that may be selected and modified individually. Each entity defines a
selection level that may be accessed by using the left button of the mouse
in combination with the Ctrl key and/or the Shift key. The main level may
be defined as Parent of the entity and the sub levels as Children. It is
possible to see this immediately by consulting the Tree View of a text entity
(Parent entity), for example:

As sub levels (Child entities), the text entity has a Spline entity and the
character entities:

In turn, each character entity has Satin, Automatic entities, etc. as sub
levels (other Child entities):
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In turn, the individual Satin, Automatic entities etc. have Spline levels as
sub levels (further Child entities):

Simple selection and selection levels
With the Simple selection tool active, by using the left button of the mouse
together with the Ctrl key, it is possible to make continually more detailed
selections in the different levels. For example, in the case of a text, the first
click of the mouse allows you to select a single character, the second click
to select a section of the character and the third click a curve.

FIRST CLICK
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SECOND CLICK

THIRD CLICK

Extended selection and selection levels
The same rules apply for Extended selection as for Simple selection. In
fact, even in this case, by using the left button of the mouse together with
the Ctrl key, it is possible to make continually more detailed selections in
the different levels.
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Selection: using the mouse buttons
Below is a summary table that allows you to understand the use of the
mouse buttons better.
Left button of the mouse
Action
I click on an entity that is not
selected
I click on an entity that is already
selected
I click on an entity that is not
selected when one or more
selected entities are present on the
work area

Result
I select the entity
I change the type of selection
handles
I deselect everything and select the
entity that I have clicked on
I may easily select the individual
curve entities.

I disable stitch display using the
button
Shift key + left button of the mouse
Action
I click on an entity that is not
selected
I click on an entity that is already
selected

Result
I select the entity

I deselect the object, removing it
from a group of selected entities, if
applicable
I click on an entity that is not I add the entity on which I clicked to
selected when one or more the other entities already selected.
selected entities are present on the
work area

Ctrl key + left button of mouse
Action
Result
I click on an entity that is not I select the first sub level of the
selected
entity (for example a curve in the
case of a Fill entity and a character
in the case of a text)
I click on an entity that is already With each click I go one level more
selected
detailed
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I click on an entity that is not I deselect everything and select a
selected when one or more sub level of the entity that I have
selected entities are present on the clicked on
work area
Shift key + Ctrl key + left button of mouse
Action
Result
I click on an entity that is not I select the first sub level of the
selected
entity (for example a curve in the
case of a Fill entity and a character
in the case of a Text)
I click on an entity that is already If the selected entity is a sub level,
selected (it is the only selection)
nothing happens when I click on it.
If the selected entity is a starting
level (Parent entity) all the sub
levels (Child entities) for that entity
will be selected except for the entity
on which I have clicked.
I click on an entity that is already I deselect the entity on which I have
selected (that is part of a multiple clicked.
selection)
I click on an entity that is not If the entity on which I have clicked
selected when one or more is a starting level (Parent entity)
selected entities are present on the without selections, the entire entity
work area
will be added to those already
selected.
Instead, if the entity on which I have
clicked is a starting level (Parent
entity) and has active selections,
the entity on which I have clicked
with the level equal to the lowest
amongst those selected will be
added to those already selected.
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Snapping of important points
Activating a work mode (Drawing mode, Automatic, Column, Satin, tatami,
Background), will display a toolbar called “Snap point” that, when an entity
is being described, makes it possible to snap the part of the entity being
described to the important points of that entity that have already been
described:

Free hand

With this button pressed, there is no snapping

Nearest

With this button pressed, it is possible to snap the part
of the entity being described to the nearest point of
an entity already described
With this button pressed, it is possible to snap the part
of the entity being described to the nearest node of
an entity already described
With this button pressed, it is possible to snap the part
of the entity being described to an intersection point
of a single entity or of several entities already
described

Node
Intersection

The part of the entity being described may be snapped to an important
point only if that important point is located at the distance that you have set
in the Video card of the Configuration window.
The value of the snapping distance (expressed in pixel) may be varied from
a minimum of 5 to a maximum of 50.
In practical terms, when you set the snapping distance at a low value you
will need to move the pointer very close to the described entity to be able to
snap to it, whereas, when you set a high value you may keep the pointer
farther away:
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Snapping distance = 50 pixel

Snapping distance = 5 pixel

Graphic representation of the pointer:
Pointer
Nearest

Pointer
Node

Pointer
Intersection

Note: When describing an entity it is possible to vary the type of snapping
to the important points at any time simply by accessing the Snap point
toolbar and selecting a different button.
Note: If you decide to vary the snapping distance when using a description
tool (by accessing the Configuration window), after you have closed the
Configuration window you must deselect the description tool and then
reselect it for the variations to take effect.
Note :When one of the three buttons
on the Snap point
toolbar is pressed for the first time, the program calculates the position of
all the important points of the entities already described. During this
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calculation, that may take several seconds depending on the complexity of
the entity, the program may appear to be blocked. Please wait until the
cursor assumes the shape of one of the snapping symbols illustrated
earlier.

Example of snapping to the nearest point of an entity
already described
When describing a new entity, select

…
...the pointer is located (with respect
to the entity already described) at the
set X-Y distance...
…when this occurs, pressing the left
button of the mouse (or, depending
on the type of entity that is being
described, the right button of the
mouse or the space bar), will
automatically snap the new entity to
the entity already described.

Example of snapping to a node of an entity already
described
When describing a new entity, select

…
...the pointer is located (with respect
to the node of an entity already
described), at the set X-Y distance.
The node will be identified by the
symbol …
… when this occurs, pressing the left
button of the mouse (or, depending
on the type of entity that is being
described, the right button of the
mouse or the space bar), will
automatically snap the new entity to
the node of the entity already
described.
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Example of snapping onto an intersection point of one or
more entities already described
When describing a new entity, select

…
...the pointer is located (with respect
to an intersection point of an entity
already described), at the set X-Y
distance. The intersection point is
identified by the symbol …

… when this occurs, pressing the left
button of the mouse (or, depending
on the type of entity that is being
described, the right button of the
mouse or the space bar), will
automatically snap the new entity to
the intersection point of the entity
already described.

Moving the selected items using the arrow keys
The arrow keys on the keyboard allow the selected items to be
moved/rotated. If the arrow key is held down, the movement/rotation speed
increases progressively.
Movement or rotation of the selected entity is determined by the type of
selection handle that is active when the arrow keys are being used;
- when the entity has been selected with one click of the mouse, the
arrow keys allow you to move the entity in four directions;
- when the entity has been selected with two clicks of the mouse, the
arrow keys allow you to rotate the entity in a clockwise or
counterclockwise direction.
Stitch calculation is only carried out about a second after the arrow key has
been released.

C6-42

Millennium III

Aligning the selected items
When you select two or more entities, you will see a toolbar called
Alignment appear, that will allow you to position the selected entities.

aligns to the left
aligns to the right
aligns along the bottom
aligns along the top
centers horizontally
centers vertically
distances horizontally
distances vertically
same width
same height
The most frequent use of the Alignment toolbar is to position texts and
therefore the following examples refer to this use.
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Symmetrical re-sizing of objects
By using the Simple selection tool it is possible to move, re-size, rotate and
deform the selected object (consult the "Simple Selection" chapter in
manual 1.21).
By selecting an object (embroidery entity, drawing or image) with a single
click of the left button of the mouse it is possible to modify the X and Y
sizes by acting on the hooking handles identified by the symbol . The resizing is performed by using as a reference point the handle opposite to the
one being acted upon. Example:
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In version 1.27, it is possible to symmetrically re-size, with respect to the
center identified by the symbol , the selected object. To do this, it is
necessary to keep the Ctrl key pressed during re-sizing. Example:

Ctrl+

Mirror
This version of Millennium III makes it possible to produce the mirror image
of any object (embroidery entity, drawing or image), or of a selection of
objects, with respect to its center identified by the symbol .
To obtain the mirror image of an object it is necessary, using the simple
selection tool, to select this object using the right button of the mouse and
then select either the Horizontal Flip or the Vertical Flip command from
the contextual menu that appears.
Suppose that we want to obtain the mirror image of the following image:
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Horizontal flip: select this command to obtain the mirror image of the
selected object, with respect to its vertical axis. In other words, the object is
overturned horizontally:
Before mirroring

After mirroring

Vertical flip: select this command to obtain a mirror image of the selected
object, with respect to its horizontal axis. In other words, the object has
been overturned vertically:
Before mirroring

After mirroring

Use of the size measurement tool
Pressing the F7 key on the keyboard or selecting the measure command
from the display menu gives access to the size measurement tool.
• Position the mouse cursor on the starting point A of the measurement
to be taken.
•
•

Press the
button. A reference
will be deposited that will be
followed by a dotted line that follows the movements of the mouse.
The movement values will appear on the status bar.
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•

Place yourself on the final point B of the measurement and click the
button again.

•

The distance expressed in millimeters may be read on the status bar at
the bottom of the work area.

Length of the line
along the X axis
(horizontal)

Length of the line
Length of the line along
the Y axis (vertical)
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How to work with “draw shapes”
This method makes it possible to punch the drawing by subdividing it into
curves and to fill it at a later date.
The curves created may be saved and reused for other embroideries.
To obtain this it is sufficient to:
• Select the draw shapes work mode
• Create the desired curve
• Save the file with a name
In this way it is possible to create a library of “objects” that may be reused
and modified at any time and for any embroidery.
To associate the created curves to a type of stitch (automatic, column, fill,
tatami) it is necessary to:
•
•
•

Select the curve
Select the type of stitch desired
Select the enable shape (Alt+Shift+A)command from the Draw menu

Example:

in the image, we want to fill the cloud on the
left with tatami inside and a column outline:
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below are the different phases needed to obtain this effect.

•
•

Create the first curve
Select it (refer to the chapter “How to select and modify created

•

curves”)
Duplicate

•
•

At this point fill the first curve with a fill and the second with a column
Select the first curve, set the type of fill (tatami in the example) and

it

(ctrl

+C

to

copy

press the enter key on the keyboard
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•

Select the second shape, set the type of column and press the enter

key on the keyboard

•

Superimpose the two shapes

As may be seen from the images, in this way it is possible to obtain a fill
surrounded by a column without punching the basic image twice.

C6-55

Millennium III

CHAPTER 7

Working with images

C7-1

Millennium III

Program with hardware protection key
INDEX

How to use the images.......................................................................3
How to insert an image to be punched..................................................3
How to set the image display scale........................................................4
How to determine the size of the image numerically and modify its
properties................................................................................................5
How to position the image manually on the work area........................7

Reducing the number of colors in an image.....................................8
Modifying images using a program that is independent of
Millennium III ................................................................................10
How to alter the graphic application started up to modify a file. ....12

Image acquisition via a scanner......................................................12
Configuration .......................................................................................12
Acquisition............................................................................................13

C7-2

Millennium III

How to use the images
Millennium III works with images memorized in many formats (.BMP, .TIFF
etc.) and allows the use of any type of photo retouching software (e.g.,
Corel Draw™, Paintbrush™, etc.) to create or retouch images acquired via
a scanner.
The default directory where the sample images are filed on the hard disk
is:C:\Programs\Millennium III\samples\images.

How to insert an image to be punched
Selecting the menu Edit>Insert>Image, a list with the thumbnails of the
images is displayed (alternative Ctrl+I).

See “Embroidery Explorer” to know how to use this list.
• Select the desired image and
The image appears on the work area.
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Before starting punching, it is necessary to:
• Set the image display scale.
• Determine the size of the image.
• Position the image on the work area at the point desired.

How to set the image display scale
To set the image display scale it is sufficient to insert the desired value in
the box

inside the toolbar placed to the right of the work area.
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How to determine the size of the image numerically and
modify its properties
To set the size of the image numerically, perform rotations,
vertical/horizontal mirror, positioning on the work area, contrast and
brightness, it is necessary to:
•
•
•
•

Press the
button on the toolbar to the right of the screen.
Select the image
Click once with the right button of the mouse
Select the Properties command from the men that appears
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Position of the
image
along
the X axis of
the work area

Position of the image
along the X axis of the
work area

Modify the width of the image in mm

Check the box to
maintain
the
aspect
ratio
when modifying
the size

Rotation of the image
in degrees

Modify
the
height of the
image in mm

Modify
the
brightness of
the image

Modify
the
contrast of the
image
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How to position the image manually on the work area
•
•

Press the
button on the toolbar to the right of the screen.
Select the image

With a single click
inside the image the system makes it possible to:
• move the image by moving its center identified by the symbol .
• modify the x and y dimensions by acting on the movement handles
identified by the symbol .
Handles for manual modification
of the size of the image

Center of the image. Moving this
point moves the entire image
without
modifying
its
dimensions.

With a double click
inside the image the system makes it possible to:
• rotate the image by acting on the rotation points identified by the
symbol
Hooking handles for manual rotation
of the image

Center of rotation of the image.
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Reducing the number of colors in an image
Often, the images imported into Millennium III contain too many colors to
give good results when used with Millennium’s automatic tools such as
Outline and Autopunch.
A typical example of this situation is a scanned image.
• Import the image into the Millennium work area by selecting
Edit>Insert>Image (or by pressing the Ctrl+I keys, or by selecting the
Insert Image command from the contextual menu that is opened by
clicking with the right button on the work area)
• Using the simple selector, select the image, click on it with the right
button of the mouse and then select the Reduce Colors command
from the contextual menu.
• A window with a cursor opens, that allows you to set the number of
colors in the image from a minimum of 2 to a maximum of 15. Set the
number of colors desired and then press the Apply button for
immediate feedback regarding the change made to the image imported
into the work area. Make several tries and when you have obtained the
desired result, press the OK button to confirm.

The cursor allows reduction to a maximum of 15 colors for images that
have more than 15; for images with less than 15 colors the cursor will reach
a maximum value that is the number of colors in the image less 1. For
example, if an image has 45 colors the cursor will work within a range of
values comprised between 2 and 15; if an image has 8 colors the cursor
will work within a range of values comprised between 2 and 7; finally, if an
image has less than 3 colors, the Apply button and the OK button are
disabled and only the Cancel button remains active.
Below is a practical example of color reduction carried out on an image
containing 43120 colors.
As may be noted, the image reduced to 9 colors is very similar to the
original except that it may be easily used with Autopunch and with Outline.
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43120 colors

9 colors

8 colors

7 colors

6 colors

5 colors
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Modifying images using a program that is
independent of Millennium III
From version 1.39 onwards it is possible to modify an image inserted in the
Millennium work area, by using the graphic application that was recorded in
Windows to open files that have a specific extension.
Select the image that you have inserted in the work area;
Click on it with the right button of the mouse and select the Edit Image
command from the contextual menu;

Millennium III is temporarily reduced to an icon and the image is opened
(with the name tmp.bmp) using the graphic application recorded in
Windows;
Make the modifications desired:
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Close the graphic application, confirming the save modifications request
(the new file called tmp.bmp will be saved in ... \Millennium3\exe\tmp). The
original file imported at the start will not be modified.

Millennium III will be restored and the work area will contain the image with
the modifications that were made using the graphic application.

Note: If you wish to save the new image created, you may access the
folder …\Millennium3\exe\tmp, copy and paste the tmp.bmp file in the
Images folder of Millennium III, or wherever you prefer. Warning however,
this operation must be carried out before modifying another image because
only the last modified image will be saved in the …\Millennium3\exe\tmp
folder.
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How to alter the graphic application started up to modify a
file.
To alter the graphic application that is used to open the images inserted in
the Millennium III work area, it is necessary to access the Windows
settings:
1. In My Computer or in Explore resources, select the Option
folder from the Display menu.
2. Click on the List Files of Type card.
3. From the type of files list, select the one that you wish to modify.
4. Select the Edit button.
5. Select Open from the Operations box.
6. Edit. Select the Edit button.
7. In the Application used to carry out the operation box, select
the program that you wish to use to open the files with the
extension indicated, then select OK.

Image acquisition via a scanner
Millennium III allows you to import an image directly onto the work area by
using a scanner compatible with the TWAIN standard.
Obviously, the following considerations are valid for any other type of
acquisition device such as a digital camera for example.

Configuration
After having installed the software supplied together with the acquisition
device, select Tools>Scanner Setup from Millennium, and then from the
list of acquisition devices, select the scanner (or the acquisition device) that
you intend to use:
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The configuration need only be carried out once. Configuration must be
carried out again only if you change the acquisition device that you intend
to use.

Acquisition
To acquire an image via the scanner (or via any acquisition device) select
Edit>Insert>Image from Scanner or press the
button on the
Standard toolbar. This will start the scanner program.
After the image has been scanned, the scanner program will close
automatically and the acquired image will be displayed on the Millennium
work area.
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Selection of stitches
This mode makes it possible to act on embroidery stitches singly or in
groups, making it possible to move, delete, rotate, lengthen, shorten and
add stitches.
Once the

button has been pressed the mouse cursor assumes the

following graphic symbol

.

Positioning the mouse cursor on any point of the embroidery will

automatically select that point.

Navigation among embroidery stitches by means of the
navigation bar and the keyboard:
Pressing the stitch extended selection button
displays the navigator
that makes it possible to move freely among the embroidery stitches.
move the cursor to the start of the embroidery (equivalent to pressing
the home key on the keyboard)
move the cursor to the end of the embroidery (equivalent to pressing
the end key on the keyboard)
move the cursor to the start of the entity selected (page up)
move the cursor to the end of the entity selected (page down)
move the cursor backward by 100 stitches
move the cursor forward by 100 stitches
move the cursor backward by 10 stitches
move the cursor forward by 10 stitches
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move the cursor backward by 1 stitch (equivalent to pressing the left
and up arrow key on the keyboard)
move the cursor forward by 1 stitch (equivalent to pressing the right
and down arrow key on the keyboard)
move the cursor to the preceding short stitch (equivalent to pressing
the shift+F key on the keyboard)
move the cursor to the next short stitch (equivalent to pressing the S
key on the keyboard)
move the cursor to the preceding long stitch (equivalent to pressing
the shift+L key on the keyboard)
move the cursor to the next long stitch (equivalent to pressing the L
key on the keyboard)
inserts the selected stitches in the shopping cart
deletes the contents of the shopping cart
moves the caret to the opposite side of the selection
is an alternative to the shift lock key on the keyboard
selects the stitches in an irregular area
moves the caret to the point specified by the user in the window that
follows (alternative: key G)
splits the entity
clean short stitches
makes it possible to specify the length in mm of: long stitch, short stitch
and the stitch hooking distance.
During navigation:
•
•

Pressing the Del key on the keyboard deletes the stitch on which you
are positioned
Pressing the Ins key on the keyboard enables the stitch insertion
mode.
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How to select adjacent groups of stitches on the embroidery
To select the entire group of stitches comprised between point A and point
B of the example it is necessary to:

Position the mouse
cursor on point A

Selection
hooking
handles

Press the Shift key on the
keyboard and keeping it
pressed, select point B

At this point, by acting on the selection hooking handles it is possible to
modify the selected group of stitches at will.

How to select groups of stitches that are NOT adjacent to
modify ONE SIDE only of the embroidery
The selection encloses all the points inside
the square described by the mouse

When the mouse
button is released all
the stitches inside
the
square
are
highlighted
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At this point, by acting on the selection hooking handles it is possible to
modify the selected group of stitches at will (in the example the selected
stitches have been rotated).

How to select groups of stitches in the embroidery that are NOT
adjacent
Keeping the Ctrl key on the keyboard
pressed, select the desired stitches with
one click of the mouse

At this point, by acting on the selection hooking handles it is possible to
modify the selected group of stitches at will (in the example the selected
stitches have been lengthened).

Selection of non-contiguous groups of stitches, other methods.
 Select one or more stitches using any of possible methods available:
 Selecting a rectangular area with the mouse


Selecting an area with the button
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Selecting not contiguous stitches clicking on the stitches with the
CTRL button pressed.
Selecting contiguous stitches, click with the mouse on the first
stitch to select and with the Shift button hold down click with the
mouse on the other side of the stitch group to be selected or
moving with:
 Keyboard area
 Next Page, Previous Page buttons
 ….
During the selection of a group of stitches, with the SHIFT key hold
down (or with the button
pressed), the button
moves the
caret from one side to the opposite of the selected stitches,
allowing the extension or the reduction of the selection.

 Press

, and the selected group is loaded into the shopping cart and

the stitches are marked with black color
.
 Select other groups and put them into the shopping cart.
 When all desired groups are loaded into the shopping cart, press the
button

: the program displays the handles to manipulate the

selected stitches

.

To empty the shopping cart press the button
.
Instead of using the button SHIFT to select contiguous stitches, you can
press

(and press it again to release).

How to add stitches to the embroidery
Stitches may be added one at a time; to enable insertion it is sufficient to
press the Ins key on the keyboard.
Each click of the mouse adds a new stitch after the stitch where the cursor
is positioned, and the created stitch automatically becomes the new
position of the cursor.
To end the insertion procedure, press the Ins key on the keyboard again.
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Selecting stitches describing an area with the mouse.
Press Stitch select..
Press the button
Region Selection.
With the left button of mouse describe the desired area, end the description
pressing the SPACE bar.

All stitches inside the area will be selected.
Dividing a stitch block into two parts
Press the Stitch Selection button.
Move the caret to the point you wish to break the stitch block.
Press the button

Split Entity.

The entity, if created with an automatic feature like satin or Tatami, will be
converted into Manual stitches and therefore all the information like the
shape curves description are lost.
The program generates a warning before to split the stitches:
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Summary of the use of keyboard and mouse for stitch selection
mouse - click on one stitch
click
Ctrl + click
Shift + click
Ctrl + Shift + click

selects the nearest stitch
adds/removes stitches from the current selection
selects all the stitches comprised between the
stitch selected and the stitch where the cursor is
positioned
adds the stitches comprised between the stitch
selected and the stitch where the cursor is
positioned, to the current selection

mouse – selection area
square
Shift
Ctrl, Ctrl + Shift

selects all the stitches inside the area
adds stitches inside the current selection area
inverts the selection mode of the stitches in the
area.

Note: the mouse always moves the stitch where the cursor is positioned
onto the last stitch clicked.
keyboard
Home, End

moves the stitch where the cursor is positioned to
the start/end of the embroidery
Pg-up, Pg-down moves the stitch where the cursor is positioned to
the start/end of the current entity
Right, Down
moves the stitch where the cursor is positioned
forward by one stitch
Left, Up
moves the stitch where the cursor is positioned
backward by one stitch,
Ctrl + ...
moves the stitch where the cursor is positioned,
leaving the current selection unchanged
Shift + ...
moves the stitch where the cursor is positioned
and adds the stitches comprised between the old
stitch where the cursor was positioned and the
new one of the current selection
Ctrl + Shift
deselects the selected stitches
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Calculating the number of actual stitches
The Info card of the Properties window contains all the information relating
to the open embroidery.
The gray boxes are filled and updated automatically by the program,
instead the Applications, Chenille, Borers and Kordel boxes must be
checked by the user as this information cannot be determined by the
program itself.

The Stitches box indicates the number of needle drops calculated by
Millennium but the number of stitches actually stitched by the embroidery
Machine depends on the length of the stitch that the Machine is able to
make.
Setting this stitch length value in the relative box in the bottom right hand
corner (40, 60, 80, 121 and 127 are the pre-set values but it is possible to
insert any other number), the number of stitches actually stitched by the
embroidery Machine will be displayed in the Number of Stitches box. This
value may be used to calculate machining times and production costs.
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Clean short stitches
Version 1.27 of Millennium III has introduced automatic cleaning, in other
words, the removal from the embroidery of all the short stitches that could
damage the fabric, break the thread and in some cases, even break the
needle.
To clean the short stitches it is necessary to activate the Stitch selection
tool and select the
button from the Navigator tool bar that appears
(for further details refer to the chapter "Navigation among the stitches of the
embroidery: the navigation bar”):
Instead of the
button of the Navigator tool bar, it is possible to select
Embroidery>Clean Short Stitches to clean the short stitches.
The following window appears:
In the section "Short stitches (mm)" it is possible to select which stitches

are to be removed from the embroidery. More precisely, it is possible to
select a range of values, comprised between a minimum value (Greater
than) and a maximum value (Less than) where the stitches whose length is
within this range are removed. If the Greater than and Less than
commands have the same value, all the stitches with a length equal to this
value will be removed.
The "Jump the stitches near to" section makes it possible to prevent the
removal of specific short stitches, even if the length of these stitches is
between the minimum and maximum values set in the preceding section.
C8-11

Millennium III

This makes it possible to prevent the short stitches of the thread tie (refer to
the chapter "How to set thread tie and thread trim") from being removed
and thus compromising the final result of the embroidery.
Check the Functions command to prevent the program from removing the
short stitches located in proximity to a function (Stop, Thread trim, Color
change, etc.).
Check the Long stitch command to prevent the program from removing
the short stitches located in proximity to stitches that have a length greater
than the maximum length set in the Greater than box.
In fact, close to the long stitches and to the color changes, some thread tie
short stitches are foreseen that, obviously, must not be removed.
When the OK button of the Clean Short Stitches window is pressed, the
program removes all the short stitches that correspond to the requirements
set earlier and then displays the following window:
that tells the User how many short stitches have been removed from the
embroidery.

Note: the program has been developed in such a way that the removal of
short stitches from any embroidery, will not alter the appearance of the
embroidery.
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Slow draw/Find
Select the menu View>Slow Draw or pressing the key F8.
Appears the toolbox here down and the embroidery is showed up to the
point were was positioned the caret when the Slow Draw was started.
Drawing does not start automatically.
Exit this operation pressing the ESC key
that causes the complete
redraw of the embroidery.
When the operation ends, the caret is on the stitch (Stitch Selector
selected) or at the end of the block (Simple or Extended Selection selected)
on which it was when Esc key

was pressed.

moves the caret at the embroidery start (or Home key)
moves the caret at the embroidery end (or End key)
moves the caret at the begin of the selected object (or Page Up key)
moves the caret to the end of the selected object (or Page Down key)
moves the caret backward by 100 stitches (or Left Arrow + Shift keys)
moves the caret forward by 100 stitches (or Right Arrow + Shift keys)
moves the caret backward by 10 stitches (or Left Arrow + CTRL keys)
moves the caret forward by 10 stitches (or Right Arrow + CTRL keys)
moves the caret backward by 1 stitch (or Left Arrow key)
moves the caret forward by 1 stitch (or Right Arrow key)
draws up to the previous short stitch (or press the key Shift+S on the
keyboard)
draws up to the previous following short stitch (or press the key S on
the keyboard)
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draws up to the previous long stitch (or press the key Shift+L on the
keyboard)
draws up to the following long stitch (or press the key L on the
keyboard)
moves the cursor to stitch specified by the user in the following dialog
draws in front at the selected speed until a command is pressed on the
toolbar or on the keyboard (equivalent to pressing the N key on the
keyboard).
draws behind at the selected speed until a command is pressed on the
toolbar or on the keyboard (equivalent to pressing the B key on the
keyboard).
select the drawing speed to be used with

following dialog window

and

. Displays the

.

allows specifying the length in millimeters of a: Short Stitch, Long
Stitch, and Hooking Distance.
draws up to the next special function (equivalent to pressing the F key
on the keyboard).
draws up to the preceding special function (equivalent to pressing the
D key on the keyboard).
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Stitch processing
With the Stitch Selection button down:
•
•

Select an entity made by stitches (i.e. files imported from embroidery
with machine code like: Tajima, Barudan ZSK, Melco, … or from Proel
PMU files that contain only stitch information).
Select a group of stitches (using any of the available methods).

Click with the right button on the screen to display the context sensitive
menu:

NOTE: If you need to process the whole embroidery, use the Simple
Selection tool instead of the Stitch Selection tool and select all
the embroidery from menu: Edit>Select all (Ctrl+F)
Recalculate
All selected stitches will be recalculated under the configuration shown
here down:

Density
Stitch Length

Percentage variation of density.
Percentage variation of stitch length.
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Underlay Length
Shortening Density
Recognition Priority

Percentage variation of underlay stitch
length.
Density value under which the stitches must
be shortened.
If checked, when it is difficult to recognize if
a group of stitches is Tatami or not, priority is
given to Tatami, otherwise priority is given to
random stitches.

Change column width
Percentage:
Millimeters:

Changes the width of all selected stitches that are
recognized as columns by the selected percentage.
The width of all selected stitches that are recognized
as columns will be increased (positive values) or
reduced (negative values) by the amount specified in
millimeters.

Transform
All selected stitches of the embroidery will be transformed in the
following way:
The stitches recognized as:
Jump
Tatami
Random
Can be transformed into the as here down indicated, with the
density, stitch length and effects selected:
Tatami
Double Tatami
Jump
Double Tatami
Random
Tatami
Random
Jump
Double Tatami
If the selected effect is unchanged (Tatami  Tatami, …), all
modified parameters will be applied (density, stitch length,…).
Jump
Tatami
Random
Density (%)
Percentage of density variation.
Stitch Length (mm) Stitch length in millimeters
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Stitch subdivision
Random (%)

Effect of Tatami. Activated only if Tatami stitch
is selected.
Percentage of irregularity. Activated only if
Random stitch is selected.

Preserve density
This item of the context sensitive menu, is always
checked when the program starts, that means that when stitch objects are
manipulated
the
program
preserves
the
stitch
density.
If this item is unchecked, when stitch objects are manipulated the stitches
are not processed, i.e. the stitch count does not change, allowing small size
modifications without the risk of modify the embroidery effects
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Embroidery Explorer (Icon list)
Select from menu File>Open when you want to open embroideries with
CXM format or files with different formats from Hard disk, from CD or from
Floppy Disk (provided that the files have been converted into PC format).
The formats that can be imported are:
Barudan FDR
Barudan FMC
Barudan
Barudan Tajima
Barudan ZSK
Happy
Juky B
Melco Expanded
Mitsubishi
Pfaff
Prowin LMU

Prowin PMU
Tajima Barudan
Tajima
Tajima Zsk
Toyota
Wilcom Tajima
Wilcom Eltac
Wilcom Barudan
Wilcom Zsk
Wilcom Pfaff

Select File>Open, the window of the graphic list appears.

The meaning of the buttons is:
Opens the selected files.
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Deletes the selected files.
Makes the refresh of the content of the list.
Shows information about the files of the list.
If this button is NOT pressed, the icons show only the name of the
file.
If this button IS pressed, the icons shows the information you select
with

.

Icon with all the information selected

Icon with only the name (without the name extension).
Details configuration.
When the button
is pressed are displayed, together with the
icons, the information selected in this window.

Details Configuration: asks to the program of draw information from
the NOT PROEL embroideries (Tajima, Barudan, …), like the stitch
count or the embroidery size.
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The calculation of this information is time consuming. If you don’t
need these information, don't select this item.
Show icons.
When embroideries with formats other then Proel, that don't contain

the icon, a default icon is displayed
because the
generation of the true icons would require too much time.
Wanting to see the icons of the embroideries press this button
.
To see the icon of an individual embroidery, click with the right button
of the mouse on the default icon and select the voice "Show Icon"
Sort the list by name.
Sort the list by size.
Sort the list by date.
Sort the list by file type.
Sort the list by stitch count.
Filter for the type of file format

Displaying the embroidery with Realistic Effect
The
button on the Work toolbar displays the embroidery with a
Realistic Effect. With this type of display, the thread is represented with a
three dimensional graphic effect in order to make it appear very similar to
the actual thread. For very complex embroideries, going from normal
display to Realistic Effect may require some time due to the redrawing
operations. However, the redrawing process may be stopped at any time
by pressing the ESC key.

C9-8

Millennium III

How to save the embroidery
To save the embroidery, select the Save or Save as…command from the
File menu
Directory where the embroidery file will
be memorized

Millennium III makes it possible to save
the current embroidery in its proprietary
format only in CXM. To be able to
transform the embroidery into a machine
code (Happy, Zsk, etc.) it is necessary to
EXPORT the embroidery (refer to the
chapter how to export an embroidery)

List of files present inside the selected
directory

Check the box to obtain
the preview of the files
already saved.
Insert the name
under which the file
will be saved

Note: it is also possible to save the embroidery on floppy disk.
Attention: in this way, a machine diskette is NOT created, but only a
Millennium III file (with CXM extension) that be used by the system only. To
create a machine diskette it is necessary to EXPORT the created file (refer
to the chapter how to export an embroidery)
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How to modify the general properties of the
selected entity
Pressing the
button on the selected entity gives access to the
Properties window from which, in the General box, it is possible to set
numerically the parameters relative to the entity.
NB: if the entity contains stitches deposited inside it, obviously the
Properties window offers the possibility to modify even all the parameters
relative to the type of stitch used.
position in mm of the entity
on the X axis (horizontal)

position in mm of the entity
on the Y axis (vertical)
Width of the entity in mm
Height of the entity in mm
Rotation in degrees with
respect to the position of
the center of rotation
Check the box to maintain the
aspect ratio unchanged when
modifying the dimensions
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Properties of a multiple selection
The Properties window relating to a multiple selection (in other words a
selection of several entities) will display all the folders regarding the
selected entities and not only those that have parameters in common.
Example:

Selection of 1 entity
(Satin)

Selection of 3 entities
(Satin – Tatami – Background)
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How to set inclinations
The inclinations determine how the stitches will be deposited inside an
outline. Generally, using inclinations makes it easier to obtain a better
effect on the stitches inside curves.
After having described an outline that will be developed as Column, Satin
or Tatami, it is possible to set the inclinations manually at will.
The examples show how, for the same fill, the orientation of the stitches
changes if the inclinations are modified.

NB: by default, the
program sets a vertical
inclination
for
each
closed outline
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Example of fill without using inclinations

As may be seen from the figure, the
stitches in the curves follow a nonoptimal pattern.

Example of fill using inclinations

As may be seen from the figure, the
stitches in the curves now follow a
decidedly better pattern.

NB: over use of inclinations does not improve the effect obtained, it is
important not to exaggerate and in any case to keep trying until the desired
result is obtained.
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How to add inclinations to an outline
NB: in this first version of the program it is possible to add inclinations only
before depositing the stitches in the outline created.
•

Create the outline

•
•

Press the

button on the status bar

Inclinations key placed on
the status bar placed at the
bottom of the screen

•
•

Press the left button of the mouse on point A, and keeping it pressed,
arrive as far as point B
Release the button of the mouse.

NB: once the inclinations have been deposited, it is possible to delete and
move them, and to modify their shape and position.
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How to delete inclinations from the outline
•

Select the desired inclination and press the Del key on the keyboard
(attention: if the outline described is closed, the program does not
allow all the inclinations to be eliminated, it is necessary to leave at
least one).

How to modify the inclinations on an outline before having
deposited the stitches
•

Create the outline

•

Press the simple selection button
on the work toolbar placed by
default to the right of the work area.
With a single click of the mouse, select the inclination to be modified, at
this point the system makes it possible to:

•

move the inclination by
moving
the
centre
identified by symbol .
modify the x and y
dimensions
of
the
inclination by acting on the
movement
handles
identified by symbol .

•

With a further click of the mouse, the system makes it possible to:
rotate
the
selected
inclination by acting on the
rotation points identified by
symbol
deform the inclination along
the x and y axes by acting
on the deformation points
identified by symbol .
centre of rotation of the
inclination.
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•

By pressing the extended selection button
on the work toolbar
placed by default to the right of the work area, the system makes it
possible to:
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Move
the
hooking
handles
of
the
inclination, thus further
modifying
size
and
position

How to modify the inclinations on the outline after having
deposited the stitches.
•

Create the outline and deposit the stitches

•

Press the extended selection button
on the work toolbar placed by
default to the right of the work area.
With a single click of the mouse, select the inclination to be modified, at
this point the system makes it possible to:

•

move the inclination by
moving the point indicated
in the figure

•

By pressing the combination of keys Ctrl+
inclination, the system makes it possible to:
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Modify the orientation of the
inclination by acting on the
handles

How to set automatic inclinations for columns, fills, and
tatamis
By enabling suitable commands, the program suggests inclinations for
columns, fills and tatamis. In any case, the user may modify them at will.
• Select the configuration > punching command from the tools menu
• Check the relative boxes to enable the desired inclination.
Enables
automatic
inclinations in columns

Enables automatic inclinations
in fills

At this point after creation of a shape, closed (for fills and tatamis), open
(for columns), the inclinations proposed appear automatically.
NB: in fills and tatamis, if the number of
is the same on both curves, the
program automatically proposes the inclinations in correspondence with
each

.
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How to set and modify needle color
After having described a curve (regardless of the mode that will be used to
stitch it) it is necessary to select the needle that will be used to represent it
on screen:
3 –Select the needle to
be associated to the
described curve

1 – Select the
working mode (a
column in the
example)

4 –Press the enter key on
the keyboard to deposit
the stitches.
2 –Describe
the curve

At this point, if you wish to modify the
needle colour it is necessary to:

1 –Select the entity and click once
only with the right button of the
mouse. Select the Properties
command from the menu that
appears.
2 –Select the Needles command from
the properties window

3 –Select the new needle from
those proposed and press the
Apply key.

Note: as regards the type of thread associated to the needles present in the
Needles box, refer to chapter “Setting the parameters to start work”> “Setting
the needles at the start of work”.
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How to set thread tie and thread trim
Each of the entities (a group of stitches associated to the same outline) that
compose an embroidery may begin and end, depending on the tie settings,
with a thread tie.
Thread tie consists of beginning and/or ending the stitching of the entity
with short stitches, repassing over the initial point A (see figure) several
times
The embroidery machine begins
stitching from point A to point C
It goes backward, stitching from
point C to point A.
It proceeds stitching from point A to
point B.

Thread trim consists of cutting the thread and is normally used after a
thread tie. The setting parameters are the following:
Tie IN
Setting of thread tie at
Never
entry
Always
Greater
of maximum
Setting of
thread tie length
at
After
exit thread tacking

Tie OFF
Never
Always
Greater of maximum length
Before thread tacking

Setting of the type of
thread tie
Length of the tie stitch
Setting of thread trim
Maximum stitch length,
beyond which the system
automatically inserts (if
set) a thread trim and a
thread tie

Set the thread entry/exit points
After describing an outline, the system makes it possible to set the entry
and exit points of the thread.
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Thread entry point

Thread exit point

To modify these points it is sufficient to:
• Position the mouse cursor on the thread entry/exit point
• Press the left button of the mouse and keeping it pressed, move the
point to the desired position
• Release the mouse button
If the outline has been filled:
•
•
•

Press the
button to activate the extended selection mode
Select the entity
Modify the entry and exit point (NB: the system recalculates the
stitches after each modification)

How to set underlay
In columns and fills, it is possible to set an automatic underlay.
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Each underlay button of the Status bar corresponds to the relative
underlay.
No underlay
Central underlay

Zig–zag underlay
Indent
underlay
along a curve
Indent underlay
Zig-zag
underlay

Double zig–zag
underlay

Double
zig–zag
indent underlay

Status bar

Example of central underlay
To select central underlay press the
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Example of zig–zag underlay
To select zig - zag underlay press the

button.

Example of indent underlay along a curve
To select indent underlay along a curve press the

Example of indent underlay
To select indent underlay, press the
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Example of zig–zag indent underlay
To select zig - zag indent underlay press the

button.

Example of double zig–zag underlay
To select double zig-zag underlay press the

button.

Example of double zig–zag indent underlay
To select double zig-zag indent, underlay press the
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Underlay parameters
To set the parameters relative to the underlay press the
status bar

button on the

Access button to the general parameters
Status bar

Select the type of
underlay

Check the box to
activate display of
stitch preview in the
box below

Set the display scale
of the preview (max 2)

Set the indent
of the underlay

Set the
outdent

Set zig-zag stitch length

Set underlay
density

And select the underlay command.
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Meaning of the configurable parameters for the underlay
Stitch length
Stitch length of the underlay is the distance L in millimeters indicated in the
figure.

Density
Stitch density of the underlay is the distance D in millimeters indicated in
the figure.

Indent
Underlay stitch indent is the distance R in millimeters indicated in the
figure.
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Outdent
Lateral outdent in millimeters of the underlay stitches in the embroidery.
Utility needed for connection between two sections of the embroidery.
• Setting a negative value gives a lateral outdent of the underlay outside
the embroidery, setting a positive value gives a lateral indent of the
underlay inside the embroidery.
• Lateral indent of the underlay stitches is the distance F indicated in the
figure.

Zig-zag stitch length
Length of the underlay stitches in millimeters of those sections of the
underlay stitched as zig-zag.
Zig-zag stitch length is the distance Z indicated in the figure.
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How to set the corner parameters
To set the parameters relative to the column and fill corners press the
button on the status bar

Access button to the general parameters
Status bar

Select the type of
corner

Check the box to activate stitch
preview display in the box below.

Set width
percentage
Set stitch length on
the corner

Set corner
correction

And select the corners command.
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• Begin at % of width
Indicates the distance where rotation of the stitches begins before the
corner and the distance where rotation stops after the corner

• Stitch length
Indicates the stitch length on the corner (in a special type corner). The
corner is stitched in two separate sections where the effect of the stitch
may be changed by varying the parameter.

• Correction
Indicates by how much the most external stitch of the corner must indented
(in a special type corner). It serves to prevent the corner from appearing
too pointy on the fabric.
Example without correction

Example with correction

NB: it is not possible to use a regular corner in the fill mode
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How to set pull compensation of the thread
The setting of this parameter (available in columns and in fills) makes it
possible for the stitches to cover a larger area than that described by the
description curves, thus compensating the pull that the fabric will undergo.
To set the parameter, press the
button on the status bar or click once
with the right button of the mouse on the column or fill to be modified.
Access buttons to the general parameters
Status bar

•

Select the Pull compensation command.
Select the type of pull compensation desired:
No compensation, Absolute or Percentage

Set the value in
millimeters
(see
examples)

Value calculated as
a percentage of the
width of the filled
area (see examples)
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Example of development without pull compensation
The fill stitches do not go beyond the traced outline.

Example of development with
compensation of 3 millimeters

an

absolute

pull

The fill stitches go beyond the description lines of the outline by 1.5
millimeters on each side.

Example of development with a pull compensation of 20%
The fill stitches go beyond the description lines of the outline by 10% on
each side, with respect to the width of the filled area.
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How to set the “shortenings”
The shortenings are present within the column mode and the fill mode.
Some work states allow automatic stitch shortening if necessary.
The system analyzes the stitch density calculated on the shortest curve: if
this latter value is greater than the Minimum density parameter,
shortenings will not be introduced.
In the opposite case, the system calculates the shortening percentage and
the number of shortenings needed to respect the Minimum density
parameter set by the operator.
If the shortening percentage or the number of shortenings calculated by the
system are greater than the values set by the operator, these latter values
will be used.
By clicking the right button of the mouse on the selected entity, access is
gained to the properties window, from where it is possible to modify its
parameters.

The parameters for managing the shortenings are:
Enabled:

Enables or disables the use of shortenings
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Number of shortenings:Maximum number of shortened stitches, after
which a non-shortened point must appear.
% Shortening:
Maximum shortening percentage of the stitch.
Minimum density (mm): corresponds to the minimum density that may be
set in the working modes. It also indicates the
density below which automatic shortening must
occur.
Density of the stitches is the distance D between
two stitches.

Other tabs of the property window:
Needles refer to the chapter "How to set and modify needle color"
Comment  refer to the chapter "How to add a comment"
Pull compensation  refer to the “How to set pull compensation of the
thread"
Column  refer to the chapter "How to use the column"
Effect  refer to the chapter "How to use the effects"
Tie  refer to the chapter "How to set the thread tie"
General  refer to the chapter “How to modify the general properties of
the selected entity”
Underlay  refer to the chapter "How to set the underlay"
Corner  refer to the chapter "How to set the corners"
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Example of the arc of a circle developed without
shortenings

Example of the arc of a circle developed with shortenings
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How to use the effects
The effects are numeric codes that define the way in which a stitching is
done
Generates stitchings in a
random way

Generates jumpstitch stitchings
Generates stitchings in a
regular way

Regular alternated

Stitch subdivision

Number of stitches
alternated

The effects are present within the following working modes:
• automatic mode
• column mode
• fill mode
Depending on the mode selected, the effects associated to it are activated.
To select the desired effect it is sufficient to press the corresponding button
on the effects bar.

Sets the type of
effect desired

Sets the parameters
relative to the effect
selected
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Jumpstitch
The Jumpstitch effect performs stitchings without generating stitches inside
the filled area and does not need the parameters associated to it to be set.
To set the jumpstitch effect, press the

button the Status bar.

Example of a fill with a jumpstitch effect
Jumpstitch is a command that makes it possible to move without dropping
the needle, in other words without depositing stitches. This command is
normally used to move the frame of the embroidery machine as, for
example, in the case where it is necessary to manually position an applique
on the fabric and then proceed to stitch it.
The program makes it possible to insert/remove a jumpstitch by selecting,
with the stitch selector
activated, the point where the jumpstitch is to
be inserted, and by selecting the Insert Jump stitch or Remove Jump
stitch commands from the contextual menu that appears:

In the Stitch View window, the jump stitches inserted are identified by the
letter “J” in the Description column:
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Random
Random effect generates stitches of a random length that varies between
maximum stitch length (L) – random percentage (%).
To set random effect, press the
button on the Status bar.
Random effect provides for the setting of two parameters:
•
•

Random stitch length (mm), sets the maximum length of the stitch in
millimeters.
Random percentage: represents the maximum percentage of
shortening on the stitch length set in the previous parameter.

For example, setting a stitch length of 10 mm and a shortening percentage
of 50%, stitches with a variable random length between 5 – 10 mm will be
obtained.
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Examples of random effect:
random percentage = 30

random percentage = 70

All the stitches entering, exiting and inside the figure that are shorter than
the Minimum length are incorporated into the previous or next stitch.
If the maximum shortening percentage is set at zero, random segmentation
functions in a different way by shortening the stitches at the ends, whereas
the central stitches remain the same as the set Random stitch length
parameter.

Regular
Regular effect generates a number of stitches of equal length by rounding
off stitch length (L).
To select Regular effect, press the
button on the effects bar.
Regular effect provides for the setting of one parameter: Regular stitch
length (mm)
Example:
The distance AB between two corresponding points of an area is 24mm
and the Stitch length (L) is 6 mm.
The program divides the AB segment by the set Stitch length parameter L
24 mm ÷ 6 mm = 4 stitches
The value found corresponds to the number of stitches to be stitched along
segment AB.
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To calculate the length of the four stitches that will be stitched along
segment AB, the program divides this segment AB by the number of
stitches found.
24 mm ÷ 4 stitches = 6 mm stitches
Therefore along segment AB, 4 stitches each 6 mm long will be stitched.

Alternate regular
Alternate regular effect functions in the same way as the regular effect
with the difference that at each turn, a whole stitch and a half stitch will be
generated alternately.

As opposed to the regular, the result obtained with this effect is less
marked. The filled area contains a larger number of stitches and the visual
effect is matte.
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Stitch subdivision
Stitch count effect makes it possible to setting of the number of stitches into
which the area will be subdivided and as a consequence generates the
number of stitches requested by the user, in the area to be stitched.
To select Stitch count effect press the

button on the effects bar.

Alternate stitch subdivision
Alternate stitch subdivision effect functions in the same way as stitch
count with the difference that at each turn, a whole stitch and a half stitch
will be generated alternately.
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How to set the borers
By clicking with the right button of the mouse on any created entity using
the Automatic mode it is possible to enable the use of and to set the depth
of the borers.

Check this box to
enable the use of
the borers

Set borer depth
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Managing Borers
From version 1.38 onwards, Millennium is able to import embroideries in
any other format where Borers are used (for example Tajima, Barudan,
Happy, etc.). Let us assume that we have imported a Tajima format
embroidery:

Select all the borer entities, using the Tree View for convenience, and then
recall the properties of these entities (using the F2 key or by clicking on one
of the entities with the right button of the mouse and then selecting
Properties from the contextual menu).
In the Borers folder of the Properties window, check the Enable command
and set the Borer Depth:
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Keeping the borer entities selected, click on one of them with the right
button of the mouse and then select the command Correct offset borers
from the contextual menu. In the window that appears, insert the value of
the movement (in other words the distance between the needle axis and
the borer axis) and press OK to confirm:

Now the embroidery is ready to be made.
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How to use the special functions
The special functions are commands given to the embroidery machine to
perform certain operations, such as:
Insert a Stop. The stop is used to stop the embroidery machine. There
are special commands for chenille stitch and chain stitch, for color
change,
for
appliques,
for
borers.
Over-use of the Stop makes it more difficult to pass from one code to
another.
Generates a Speed + command.
Generates a Speed – command.
Generates a Thread trim command.(Use before a passage without a
color change).
Generates a Frame out command. This command is translated as
frame out only for PFAFF embroidery machines, for all the others if
generates a Stop
Generates a Start chenille command.
Generates and End chenille command.
Generates a Start sequin command.
Generates an End sequin command.
Generates a Deposit sequin command. (The Start sequin command
is generated automatically when a sequin is deposited and the sequin
device is not activated. When there are long passages that require a
jumpstitch, and a Tajima embroidery is being produced, the sequins
are deactivated before the first passage and reactivated after it).
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Chenille stitch and chain with Tajima embroidery
machines
chenille
stitch
Change mode from chenille stitch to chain stitch and
vice versa.
•

From chenille stitch to chain stitch, the command to be inserted

•

during punching is
(star chain).
From chain stitch to chenille stitch, the command to be inserted
during punching is

(start chenille).

Regulation of stitch height

• From chain stitch to chain stitch, the command to be inserted during
punching is
(*)(start chain).
• From chenille stitch to chenille stitch, the command to be inserted
during punching is
(*)(start chenille).
• From chain stitch to chenille stitch, the command to be inserted during
punching is
(*)(start chenille).
• From chenille stitch to chain stitch, the command to be inserted during
punching is

(*)(start chain).

NB: (*) even inverted.

How to insert special functions

• Position the embroidery cursor on the point of the embroidery where the
special function is to be inserted.
• Press the button on the special functions bar that corresponds to the
special function desired.

How to display the special functions on the embroidery
•
•

Select the Functions command from the Display menu or press
on Work toolbar.
The symbols corresponding to the special functions will appear on the
embroidery.
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How to delete special functions
•

Display the special functions by selecting the Functions command

•
•

from the Display menu or press
on Work toolbar.
Position yourself on the special function to be deleted.
Press the Del key on the keyboard.

The Sequins (Paillettes)
From version 1.35 on, Millennium III is able to manage the following types
of sequins:
CIRCLE
DIAMOND
CROSS
FLOWER
To define the type of sequin that you wish to use in an embroidery, select
Tools>Configuration and then select the Functions card:

From this card, select Sequin Type, Sequin size (in millimeters) and
Sequin color.
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The table below contains the references that indicate, for each type of
Sequin, the measurement that must be used to set the Sequin size
parameter:

Sequin size = Diameter of the circle
CIRCLE
Sequin size = Diagonal of the diamond
DIAMOND
Sequin size = Distance between two opposite
ends
CROSS
Sequin size = Distance between the ends of two
opposite petals
FLOWER

Using Sequins
To create an embroidery with Sequins, use the Functions window
(View>Toolbars>Functions) that contains the three buttons dedicated to
this purpose:

= Start Sequin function (to activate the device that deposits the
Sequins)
= End Sequin function (to deactivate the device that deposits the
Sequins)
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= (Sequin Drop) Deposits a single sequin

Depositing a series of Sequins
To deposit a series of Sequins it is necessary to prepare a single motif
(with one Sequin) and then deposit the series by using the Motif on curve
work mode. For information about using this work mode, we advise you to
consult the relative paragraph.
Obviously, at the start and at the end of the motif on curve that you have
described, you must insert a Start Sequin
Sequin

function respectively, using the

function and an End
and

buttons.

Here is a simple example:
single motif (MOT_S_3.cxm):

motif on curve:

In the motifs with Sequin, even the size of the Sequin is shown during the
precalculation phase, thus making it easier to position the sequins.
The …\Millennium3\Samples\Motif folder contains some ready prepared
motifs that you may use to deposit a circular Sequin:
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Depositing a single Sequin
By using the Automatic work mode and depositing stitches manually
(using Shift+right button of the mouse as explained in a specific chapter of
this manual) it is possible to deposit one Sequin per stitch by using the
button. Even in this case it is necessary to use the
set the Start Sequin
and End Sequin
end of the series of Sequins.

and

buttons to

functions at the start and

Displaying the Sequins
The

button on the Work toolbar allows you to enable/disable the

display of the special functions (and therefore also the Start Sequin
and End Sequin
) functions) but does not allow you to display the
deposited Sequins. To do this, select View>Sequin or press the F6 key.
Remember that the color used to display the Sequins may be modified in
the Functions card of the window that opens when Tools>Configuration
is selected.
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Reordering the needles of an embroidery
In version 1.26, the Embroidery menu includes a new command, Needles
reorder, that makes it possible to reorder (in a progressive ascending
order) the needles used in an embroidery, setting the number of the initial
needle.

C9-57

Millennium III

C9-58

Millennium III

C9-59

Millennium III

C9-60

Millennium III

C9-61

Millennium III

C9-62

Millennium III

C9-63

Millennium III

C9-64

Millennium III

C9-65

Millennium III

C9-66

Millennium III

C9-67

Millennium III

Example: The needles of the following embroidery have to be reordered:

Select Embroidery>Needles reorder… the following windows appears,
that asks you to insert the number of the initial needle:

After having set the Needle Number (1 in this case, but it could be any
other number), press OK.
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In the Tree View Window, it may be seen that the needles have been
renumbered (in this case from n°1 to n°6) and that in the Properties
window (that may be displayed by selecting Embroidery>Properties or by
pressing the right button of the mouse on the embroidery window and
selecting the Properties command), these needles are indicated by an
asterisk:
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Function transformation
In version 1.26, it is possible to transform the Stop

functions into Color

Change (Needle)
functions and vice versa, by selecting respectively
Embroidery>Stop/needles and Embroidery>Needles/stop.
For further information consult the chapter “How to use the special
functions”.
Example: Four Stop functions and six color change (Needle) functions are
present in the embroidery shown below.
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Transformation of the Stop functions into Color Change
(Needles) functions
Select Embroidery>Stop/needles, the following window appears that asks
you to insert the number of the initial needle:

Pressing the OK button transforms the Stop functions into Color Change
(Needles) functions. As well as the color changes already present before
the transformation, the embroidery presents another four Color Changes
(Needles) that replace the four Stop functions of the original embroidery.
This embroidery is produced starting from the initial needle that was set
and therefore the colors are different to those in the original embroidery.

Warning: the Stop functions inserted using the stitch selector will not be
transformed into Color Changes.
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Transformation of the Color Change (Needles) functions
into Stop functions
Select Embroidery>Needles/stop, the Color Change (Needles) functions
are transformed instantly into Stop functions. The embroidery obtained is a
monochromatic embroidery produced with the initial needle of the
embroidery (in other words the first needle in the list displayed in the Tree
View window).
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Deletion and modification of *.aup files
The *.aup files are saved in the …\Millennium3\Application Data directory
(the same directory used to save the needle file *.ndl). If you wish to
remove or add an *.aup file, for example one that may have been supplied
on a diskette, or even to rename a file, it is necessary to open this directory
and delete, copy or rename the desired files using the known Windows
procedures.
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Stitch Outline (Detector)
Introduction
Stitch Outline is a function of Millennium III that makes it possible to detect,
in an entire embroidery, the individual embroidery entities that define it.
In practical terms, Stitch Outline carries out a series of statistical
evaluations on the embroidery that will provide the parameters that make it
possible to determine the work mode (Tatami, Satin or Column) and the
effect (Random or Regular).
The threshold values of these parameters (in other words the values that
allow Stitch Outline to determine the type of work mode and the effect)
must be set by the user during the Stitch Outline configuration phase.

Stitch Outline configuration
Select Tools>Configuration>Stitch Outline to configure Stitch Outline,
the Configuration window opens in which Stitch Outline must be selected:

In practical terms, configuring Stitch Outline means suggesting to
Millennium III how we would prefer an embroidery to be detected.
The window contains two cursors that make it possible to set the threshold
parameters that allow Millennium III to determine the work mode and the
type of effect of an embroidery entity.
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Preferred effect

Move the cursor towards Tatami if
you want Millennium to detect the embroidery entity as a Tatami entity
rather than as a Satin entity.

Move the cursor towards Satin if
you want Millennium to detect the embroidery entity as a Satin entity rather
than as a Tatami entity.

Favorite Mode
Move the cursor towards
Random if you want Millennium to detect the stitching as random stitches
rather than as regular stitches.

Move the cursor towards
Regular if you want Millennium to detect the stitching as regular stitches
rather than as random stitches.

Detection of Columns
Check the Use Columns box if you want Millennium to
detect the embroidery entities that have a regular aspect, in other words
those entities that are developed maintaining a constant width, such as the
Column entity.
If this box is not checked, the embroidery entities with the
above characteristics will be detected as Satin entities.
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Note: When deciding whether or not it is worthwhile to make Millennium
detect some embroidery entities as Column, it is important to remember
that when re-dimensioning the embroidery using the simple selection tool,
the entities detected as Column will maintain a constant width whereas
entities detected as Satin or Tatami will vary even this parameter.
Example:
I have a Column and a Satin with the same width and height:
Column

Column
…I select them

Satin

Satin

…I re-dimension them:

Column

Satin

…whereas for Satin both length and width have changed, for Column only
the length has changed but the width has remained constant (*):

(*) Note: To vary the width of a Column it is necessary to access its
Properties.
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Use of Stitch Outline
After having opened an embroidery and having configured the Stitch
Outline, select Embroidery> Stitch Outline: the detection process over
the entire embroidery begins.
Warning, the detection process may not be canceled.
Assume that we wish to detect the following embroidery:

Tree view before detection:

Tree view after detection:

If we wish to detect only one part of the embroidery, select the embroidery
entities desired and then select the Stitch Outline command from the
contextual menu that appears by clicking with the right button of the mouse
on these entities.
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Activate/deactivate Embroidery-objects
An embroidery-object, after having selected it with the Simple Selector, can
be disarmed clicking on it with the right key of the mouse and activating the
contextual menu that the item Deactivate.
Click on this item to deactivate the selected object or objects.
Selecting from menu:
Embroidery  Active All
Embroidery  Reverse Activation
versa.

All objects are activated.
Disable the active objects and vice

Duplication of the description curve of an
embroidery entity
The program makes it possible to duplicate the description curve of an
embroidery entity and at the same time activate it for punching with one of
the work modes selected earlier.
In the previous versions, to duplicate a description curve it was necessary
to select it, copy it, paste it, and finally activate it by selecting Activate
Shape from the Draw menu
Now, instead, to duplicate a description curve it is sufficient to choose a
work mode, with the right button of the mouse select the curve to be
duplicated and then select the Duplicate and Activate Shape commands
from the contextual menu that appears:
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Example: you wish to duplicate the description curve of a circle that was
punched using the Satin work mode in order to punch it using the Column
work mode.
After:

Before:

Procedure:
For convenience, disable the display of embroidery stitches by deactivating
the

button on the work tool bar:

Select a work mode and a needle:

Select the description curve using the right button of the mouse and select
the Duplicate and Activate Shapes commands from the contextual menu
that appears:
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Note: At this point it is possible also to move the new description curve to
any point within the embroidery window
Press Enter to deposit the Column
Re-activate the display of the embroidery stitches by activating the
button on the work tool bar.

Entity Transformation
Version 1.27 of the Millennium III program makes it possible to transform a
Satin entity into a Tatami entity and vice versa, or a Satin or Tatami entity
into a Background.
Using the simple selection tool, use the right button of the mouse to select
the entity to be transformed and then select the command Transform
into ... (Tatami, ...Satin, ....Background) from the contextual menu that
appears. Examples of the six types of transformation possible are shown
below.

Transformation of a Satin entity into a Tatami entity
Select the Transform in Tatami command:

As soon as the button of the mouse has been released, the Properties
window appears, where it is possible to set the Tatami parameters:
Press the OK button to transform Satin into Tatami.

Transformation of a Tatami entity into a Satin entity
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Select the Transform in Satin command:
As soon as the button of the mouse has been released, the Properties

window appears, where it is possible to set the Satin parameters:

Press the OK button to transform Tatami into Satin

Transformation of a Tatami or Satin entity into a Background entity

C9-81

Millennium III

Select the Transform in Background command:

As soon as the button of the mouse has been released, the Properties
window appears, where it is possible to set the Background parameters:

Press the OK button to transform Satin, or Tatami, into Background.

Transformation of a Background entity into a Tatami or
Satin entity
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Select either the Transform in Tatami or Transform in Satin command:

As soon as the button of the mouse has been released, the Properties
window appears, where it is possible to set the Tatami or Satin
parameters:

Press the OK button to transform Background into Satin, or into Tatami.

Modification of the embroidery entities
Millennium III now offers the possibility to modify, at any time, an
embroidery entity created with the Column, Satin or Filling modes.
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With the extended selection tool activated
, select the embroidery entity
to be modified and then click on it using the right button of the mouse. The
following menu appears:

By selecting the Insert Shapes/Inclinations command, the following
window appears:
that makes it possible to modify the shape of the entity by using a drawing
tool:
• curve
• ellipse
• polygon
• rectangle
• outline
• or to insert new inclinations.
Example 1: Inside a Satin entity that has already been described (using the
Rectangle drawing tool), a circular area free of stitches is to be created:
Before:

After:

Select Insert Shapes/Inclinations; the entity is highlighted and the relative
window appears:
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Select the Ellipse drawing tool and describe a circle in the desired position:

Once description has been completed, press Enter to confirm the
modifications that have been made.
Example 2: If the Inclination of a Column that has already been described
is to be changed:
Before:

After:

Select Insert Shapes/Inclinations; the entity is highlighted and a window
appears from which, in this case, it is possible to select only the tool for
adding the inclinations:
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Insert the desired inclinations on the embroidery entity:

and then press Return to confirm the modifications that have made.

Find entity
It is possible to carry out a search amongst the different elements that
make up an embroidery in order to find those that correspond to the
predetermined requisites.
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Thanks to this function, it will be very easy to find a particular type of work,
stitching, effect or underlay mode, or pull compensations and stitches of a
given length or density.
The find function is activated by selecting Embroidery>Find or by pressing
the shortcut key F3.
A window will open in which you must check the boxes that correspond to
the embroidery element that you wish to find.
Selecting the “Stitch Length” and “Stitch Density” commands always
requires two limit values (minimum and maximum) to be entered in a
specific window that will open when one of these commands is selected.
Obviously, for each search, you may check several boxes in order to carry
out a more detailed search.
For example, it is possible to search for all the fillings and all the satins with
a density of 0.5mm, by checking the Tatami box, the Satin box and then
the Stitch Density box and setting the minimum and maximum limits
requested in the latter at a 0.50/0.50.

After having selected the search elements, press the Find button to start
the search.
The results of the search will be shown in the
View window.
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In this folder, as in all the other folders of the Tree View window, it is
possible to select the single entities listed, or all the entities, simply by
using the right button of the mouse and selecting the Select All command
from the contextual menu.
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CHAPTER 10

Using Millennium III modes
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Using Millennium III modes
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Automatic
The automatic mode generates stitchings (single or triple) along an
outline.
• Select Automatic from Punch toolbar (menu View>Toolbars>Punch)
or opening Embroidery menu.

From the Status Bar, select the type of automatic desired
Automatic Left slanted

Automatic Right slanted

Automatic normal

• If desired, modify the parameters of the type of automatic stitch selected
(width, stitch length, segmentation):
• Describe the desired path.

• To develop the stitches, press the enter key on the keyboard.
A different effect will be obtained depending on the type of automatic
stitch selected from the style bar:
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Automatic stitch

Right slanted

Left slanted

Automatic stitch parameters
To modify the parameters relative to the type of automatic stitch selected
with respect to those set in the style table selected, press the
the status bar
Button to setting the effects.
See chapter "How to use the effects"

button on

Access button to the general parameters

Note: the changes made to these parameters will be applied to all the
automatic modes of the type selected (right slanted, etc.) developed from
this moment on.
•

Select the desired command.

Refer to the chapter
“How to use the
effects”

Refer to the chapter “How to set
thread tie”

Setting of the
general
parameters
of the
automatic
Check the box to
enable triple stitch
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Slanted stitch width
•

The Width of the slanted stitch is the distance L indicated in the figure.

• Set the desired value.
• Press OK to confirm and Cancel to cancel.

Automatic stitch properties
Millennium III, by clicking with the right button of the mouse on the
selected object, makes it possible to modify the properties or in other
words to act on all the parameters relative to the object itself.
In the case of automatic stitch, the parameters that may be modified are:
Modify the needles, refer to the
chapter “How to set and modify Add a comment
needle colour”

For
the
general
parameters, refer to the
chapter
“How
to
modify the general
properties
of
the
selected entity”

Modify the parameters illustrated
preceding paragraphs of the chapter

Modify the borers, refer to the
chapter “How to set the
borers”

Modify thread tie, refer to
chapter “How to set thread tie”

in

the
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Column
The mode generates four types of column: zigzag, satin, square and Estitch. To use them proceed as follows:
•
Select Column from Punch toolbar (menu View>Toolbars>Punch) or
opening Embroidery menu.

•

From the Status Bar, select the type of column desired.
Satin column
Zig-zag column
Square column
E-stitch column

• If necessary, modify the parameters of the type of column selected
(width, stitch length, segmentation, density, direction of development,
type of corner, underlay, inclinations).
• Describe the desired path.

• To develop the stitches press the Enter key on the keyboard.
A different effect will be obtained depending on the type of column
selected from the status bar.
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Zig–Zag column

Satin column

Square column

E-stitch column
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How to set corners in the column
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No corner

Regular corner
status bar
Miter corner

For the same tracing, a different stitch development is generated
depending on the type of corner selected.

Tracing
Examples of corner development with zig-zag column

Development without corner

Development with a regular corner

Development with a miter corner
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Examples of corner development with satin column

Development without corner

Development with a regular corner

Development with a miter corner of the type
Examples of corner development with square column

Development without corner

Development with a regular corner
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Development with a miter corner
Examples of corner development with E-stitch column

Development without corner

Development with a regular corner

Development with a miter corner

Column parameters
To modify the parameters relative to the type of column selected with
respect to those set in the style table selected, press the
status bar
C10-15
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Note: the changes made to these parameters will be applied to all the
columns of the selected type (zigzag, satin, etc.) developed from this
moment on.
•

Select the desired command.

Refer to the chapter
“How to set pull
Refer to the
compensation of the
paragraph
direction of stitch thread”
development

Refer to the chapter
“How to set thread tie”

Refer to the chapter
“How to set the
borers”

Set the general
parameters of the
column
Check the box to
enable triple stitch

Refer
to
the
chapter “How to
use the effects”

Refer to the
chapter “How to
set corner
parameters”

Refer to the chapter
“How to set the
underlay”

Refer to chapter “How
to set shortenings”

•

Width
indicates the width H (see figure for the different cases) of the column.

•

Density
indicates the density D (see figure for the different cases) of the
column.
The density D will be applied to the longest edge of each section of
column.
If the density on the shorter side is below the Minimum density set in
the Shortenings table, the automatic stitch shortening system will be
activated, if enabled (refer to the chapter Shortenings).

•

Overlapping
Indicates the number of densities to be overlapped.
The figure represents the tracing of a zigzag column in jumpstitch. The
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points A and C indicate respectively the thread entry and exit points.
The column is developed in the following way:
• From the entry point A, the needle stitches along the central line until
it reaches point D.
• From point D the needle stitches the zigzag column until it reaches
point B, in other words two densities beyond the exit point C.
• From point B the needle stitches along the central line until it
reaches point E.
• From point E the needle stitches the zigzag column until it reaches
point C.
• From point B to the exit point C the needle passes over the stitches
stitched earlier in the D B section.

This overlapping serves to prevent possible fabric pull due to nonsequential column development.
Note: for an explanation of the Pull compensation command parameters,
refer to the chapter Pull compensation.

Width/density of the zig-zag column
The width of the Zig-Zag column is given by the distance H indicated in the
figure, the density is the distance D indicated in the figure.
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Width / density of the satin column
The width of the satin column is given by the distance H indicated in the
figure, the density is the distance D indicated in the figure.

Width / density of the square column
The width of the square column is given by the distance H indicated in the
figure, the density is the distance D indicated in the figure.

Width / density of the E-stitch column
The width of the E-stitch column is given by the distance H indicated in the
figure, the density is the distance D indicated in the figure.
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Direction of development of the column stitches
This utility makes it possible to set the direction of development of the
column stitches with respect to the traced outline.
The symbols indicated on the buttons indicate where the column must be
developed with respect to the traced outline:
Set central development of the stitches with respect
to the traced outline
Set left development of the
stitches with respect to the
traced outline

Set right development of the
stitches with respect to the
traced outline

status bar

In the following examples, the horizontal black line

represents the outline
tracing to which a different type of column has been subsequently
associated.
Example of central development
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Example of right development

Example of left development

Column properties
Millennium III, with a click of the right button of the mouse on the selected
object, makes it possible to modify its properties, or in other words to act
on all the parameters relative to the object itself.
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In the case of the column, the parameters that may be modified are:
Refer to the chapter
“How to set pull
compensation
of
the thread”

to
the
Refer to the chapter Refer
“How to set thread chapter “How to
set and modify
tie”
needle colour”

Refer to the chapter
“How to set the
underlay”

Add a comment
Refer to the chapter
“How to set the
corners”

Refer to the chapter
“How to modify the
general properties of
the selected entity”

Refer to the chapter “How
to set corner parameters

Modify
the
parameters
illustrated in the preceding
paragraphs of the chapter
Refer to the chapter
“How to use the
effects”
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Satin (Fill)
The mode generates zig-zag, satin, square and E-stitch fills with
stitchings (single or triple)
• Select Satin from Punch toolbar (menu View>Toolbars>Punch) or
opening Embroidery menu.

•

From the Status bar select the type of fill desired
Satin fill
zig zag fill
barra degli stati di lavoro

Square fill
E-stitch fill

• If necessary, modify the parameters of the type of fill selected (density,
stitch length, effect, underlay, type of corner, inclinations).
From the Status bar:
• Describe the desired path.
General parameters
setting key

Underlay setting key

Effects setting key

Inclinations setting
key
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• To develop the stitches, press the Enter key on the keyboard.
A different effect will be obtained depending on the type of fill selected
from the style bar:

Zig-zag fill

Satin fill

Square fill

E-stitch fill
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Fill parameters
To modify the parameters relative to the type of fill selected with respect to
those set in the style table selected, press the

button on the status bar

Access button to the general parameters
Status bar

NB: the changes made to these parameters will be applied to all the fills of
the selected type (zig-zag, satin, etc) developed from this moment on.
•

Select the command desired.
Refer to the chapter
Refer to the chapter Refer to the chapter “How to set the
“How to set pull
“How to set the ties” borers”
compensation of the
thread”

Refer to the chapter
“How to use the
jagged”

Setting of the fill general
parameters
Selection of the type of
fill
Refer to the chapter “How
to use the effects”

Refer to the chapter “How to
Refer to the chapter
Refer to the chapter
set the corner parameters”
“How
to
set
the
“How to set
underlay”
shortenings”

•

Density
indicates the density D (refer to the figures for the different cases) of
the fill. The density D is calculated between thread and thread along
the most external edge of the fill. If the density on the shorter edge is
below the minimum density set in the Shortenings table, the
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automatic stitch shortening system will become activated, if enabled
(refer to the chapter Shortenings).
•

Overlapping
indicates the number of densities to be overlapped (see example).
example: The figure represents the tracing of an outline that will be
filled with jumpstitch zig-zag. The points A and C indicate respectively
the thread entry and exit points. The system develops the fill in the
following way:
• From entry point A, it moves stitching in jumpstitch until it reaches
point D.
• From point D, it stitches zig-zag fill until it reaches point B, or in
other words two densities beyond exit point C.
• From point B it moves stitching in jumpstitch until it reaches point E.
• From point E it stitches zig-zag fill until it reaches point C.
• From point B to the exit point C, it passes over the stitches stitched
earlier
along
the
D
B
section.

This overlapping serves to prevent possible fabric pull (with subsequent
opening of the embroidery) due to non-sequential development of the fill.

Zig–Zag fill density
The Zig-Zag fill density is the distance D indicated in the figure.
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Satin fill density
The satin fill density is the distance D indicated in the figure.

Square fill density
The square fill density is the distance D indicated in the figure.

E-stitch fill density
The E-stitch fill density is the distance D indicated in the figure.

Compensation density
Automatic density compensation, if enabled, makes it possible to fill a
figure by varying the density of the stitches as a function of stitch length.
The density is automatically compensated by the system.
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How to use jagged fill
To activate Jagged fill it is necessary to:
• Select the fill mode
• Press the
button on the status bar
• Select the Jagged command from the Parameters window.
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Access button to the general parameters
Status bar

Note: the changes made to these parameters will be applied to all the fills
of the selected type (zig-zag, satin, etc.) developed from this moment on.

Select the type of
jagged

Setting of the
outdent or indent %
of the stitches with
respect to the edge
of the first curve

Preview of the applied
jagged effect

Setting of the outdent or indent %
of the stitches with respect to the
edge of the second curve
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Example of a jagged fill on two curves – 30% with respect to
the description curve

Example of jagged fill with +50% on the first curve described
and 0% on the second

Example of jagged fill with 0% on the first curve described and
-45% on the second
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Fill properties
Millennium III, with a click of the right button of the mouse on the selected
object, makes it possible to modify its properties or in other words to act on
all the parameters relative to the object itself.
In the case of fill, the parameters that may be modified are:
Refer to the chapter
“How
to
set
pull
compensation of the
thread”

Refer to the chapter Refer to the
“How to set thread chapter “How to
tie “
set and modify
needle colour”

Add a comment

Refer to Jagged
paragraph
Refer to the chapter
“How to modify the
general properties
of
the
selected
entity”

Refer to the chapter “How
to set the underlay”

Refer to the chapter
“How to set the corner
parameters”

Modify
the
parameters
illustrated in the
preceding
Refer
to
the
paragraphs

Refer to the chapter
“How
to
set
shortenings”

chapter “How to
use the effects”
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Tatami
The mode generates a tatami.
Select Tatami from Punch toolbar (menu View>Toolbars>Punch) or
opening Embroidery menu.

•

From the Status bar select the type of tatami desired.

• If necessary, modify the parameters of the type of tatami selected
(density, stitch length, angle, underlay, inclinations, direction, repeated
stitches, stitch subdivision, etc.).
• Describe the desired area.
• To develop the stitches, press the Enter key on the keyboard.
A different effect will be obtained depending on the parameter settings.
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Tatami parameters
To modify the parameters relative to the type of tatami that has been set
with respect to those set in the table of the selected style, press the
button on the status bar.

Access button to the general parameters
Status bar

NB: the changes made to these parameters will be applied to all the tatami
developed from this moment on.
•

Select the desired command.
Refer to the chapter
Refer to the chapter
Refer to the chapter “How to set pull
“How to set thread
“How to set
compensation of the tie”
shortenings”
thread”

Refer to the
chapter “How
to set the
borers”

Refer the the chapter
“How to set the
underlay”

- Quadrant: sets the direction of the tatami (North East, South East, North
West, South West). Note that, when the work is finished, the optical
effect obtained with the North East direction is the same as that obtained
with the South West direction and the optical effect obtained with the
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South East direction is the same as that obtained with the North West
direction.
- Stitch subdivision: indicates the fraction of the length (from 1/1 to 1/9)
with which the stitching points are staggered over each round. By setting
a stitch subdivision number equal to 1, there is no staggering whereas
setting a 9 gives maximum staggering.
- Overlap (mm): Set overlapping.
- Stitch subdivision: indicates the fraction of the length (from 1/1 to 1/9)
with which the stitching points are staggered over each round. By setting
a stitch subdivision number equal to 1, there is no staggering whereas
setting a 9 gives maximum staggering.
- Stitch repetition: Indicates the number of stitches that will be repeated.
- Slope: Indicates the inclination of the stitches with respect to the
horizontal (from 0° to 45°).
- Stitch length (mm): Set stitch length (L)

- Density (mm): Set the density (D)

- Double stitching: check the box to enable double stitching
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•

Overlapping
Indicates the number of densities to be overlapped (see example).
example: The figure represents the tracing of an outline that will be
filled with jumpstitch zig-zag. Points A and C indicate respectively the
thread entry and exit points. The system develops the tatami in the
following way:
• From entry point A, it moves stitching jumpstitch until it reaches
point D.
• From point D it stitches zig-zag fill until it reaches point B, in other
words two densities beyond the exit point C.
• From point B it moves stitching jumpstitch until point E.
• From point E it stitches zig-zag fill until point C
• From point B to exit point C it repasses over the stitches stitched
previously
in
the
D
B
section.

This overlapping serves to prevent possible fabric pull due non-sequential
tatami development.
Below are some explanatory examples of the use of the various
parameters.

Example of tatami with direction NE, stitch subdivision 1, effect
30°
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Example of tatami with direction SE, stitch subdivision 1, effect
30°

Example of tatami with stitch subdivision equal to 1
If Stitch subdivision is equal to one the stitches in the examples below are
not staggered.
Effect 0 degrees

10 degrees

30 degrees

Example of tatami with stitch subdivision equal to 2
If Stitch subdivision equals 2 the stitches in the examples below are
staggered by half their length.
Effect 0 degrees
10 degrees
30 degrees
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Example of tatami with stitch subdivision equal to 3
If Stitch subdivision equals 3 the stitches in the examples below are
staggered by a third of their length.
Effect 0 degrees
10 degrees
30 degrees

Example of tatami with repeated stitches (effect 30°)
If Stitch subdivision equals 3 the stitches in the examples below are
staggered by a third of their length.
Repeated stitches 1
2
3
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Example of matching two tatamis
To match two tatamis made at different times it is necessary to use the
mouse to position the symbol
(it appears automatically at the end of
outline description) on one of the stitches of the tatami developed
previously.
•

Fill an outline with a tatami. •

Continue outline description and
using the mouse, position the
symbol on one of the stitches of the
previous tatami.

The tatami effect obtained corresponds
perfectly to that developed in the first
section.

To obtain the direction opposite to that of the previous tatami, it is sufficient
to reverse the direction of the new tatami.
Note: if the
symbol does not appear at the end of outline description, it
may be recalled by pressing the combination of keys Ctrl+R.
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Tatami properties
Millennium III, with a click of the right button of the mouse on the selected
object, makes it possible to modify its properties or in other words to act on
all the parameters relative to the object itself.
In the case of tatami, the parameters that may be modified are:
Refer to the chapter
“How to set pull
compensation of
the thread”

Refer to the chapter
“How to set thread
tie”

Refer to the chapter “How to set
and modify needle colour”
Add a comment

Refer to the chapter
“How to modify the
general properties
of the selected
entity”

Refer to the chapter “How
to set the underlay”

Modify the parameters
illustrated
in
the
preceding paragraphs
of the chapter

Refer to the chapter
“How
to
set
shortenings”
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Background
In version 1.27 of Millennium III, as well as the Automatic, Column, Satin
and Tatami work modes, it is possible to use a new work mode:
Background.
Background is a decorative embroidery that makes it possible to identify a
basic motif (Effect) that is repeated, by following a matrix composition of
lines and columns, over the entire surface of the figure to be punched. The
optical effect obtained with this work mode is very pleasing and makes it
possible to obtain unique embroideries.
The folder ...\Millennium3\Samples\Backgrounds contains almost two
hundred types of Background in *.bkg format (but it is also possible to
import the *.stf format from the old Prowin program) that, as will be
explained later, may be imported easily into your work.
Some examples of the Backgrounds available in this version of Millennium
III are shown below:

file BKG0059.bkg

file BKG0182.bkg

file BKG0048.bkg

file BKG0173.bkg
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Using the Background
The procedure for using the Background work mode is basically the same
as the procedure used for the other work modes (Automatic, Column,
Satin, Tatami).
1)
Select
Background
from
the
Punch
bar
(menu
View>Toolbar>Punch) or by accessing the Embroidery menu:

2)

The parameters relative to the Background work mode will be
displayed on the Status bar:

Proceeding from left to right, select:
the Style (refer to the chapters "Style Table" and "How to create a
style" contained in manual 1.21);
and then set:
- Density (mm): the distance in mm between the stitches of the
Background; to obtain stitches that are close together it is necessary to
set a low value, whereas to obtain stitches that are widely spaced, it is
necessary to set a higher value.
- Width Effect (mm): is the width (X axis) in mm of the basic motif
(Effect) that defines the Background.
- Height Effect (mm): is the height (Y axis) in mm of the basic motif
(Effect) that defines the Background.
-

Button
(Keep X-Y ratio): by pressing this button, the variations
that are made on one of the two parameters, Height or Width, are
transferred proportionally even to the other parameter.
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-

Button

(Underlay): makes it possible to set the type of Underlay:

Button
(general parameters): opens the parameters window,
where it is possible to set the general parameters of the Background:
In this window, as well as the parameters described above, two other
-

parameters are present:
- Direction: makes it possible to set the direction in which the
Background stitches are stitched (North East, South East, North West,
South West). Note that, once the work has been completed, the effect
obtained with the North East direction is the same as that obtained with
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-

-

the South West direction and the effect obtained with the South East
direction is the same as that obtained with the North West direction.
Overlapping (mm): makes it possible to set overlapping of stitches to
prevent fabric pull or to avoid having areas without embroidery, a
situation that occurs generally when the Background is developed in a
non-sequential manner. The program, depending on the Overlapping
and Density values that have been set in mm, calculates and then
deposits a whole number density.
The
Button makes it possible to access the Insert
Background window (the formats that may be imported are bkg and
stf), where it is possible to select the desired Backgrounds from a
graphic list:

The meanings of the buttons present in this window are the same as those
of the graphic list of the Embroideries (refer to the relevant chapter).
3)

Using a drawing tool (Curve, Ellipse, Polygon, Rectangle or Outline),
describe the figure that is to be filled with the Background and choose
the desired needle from the Punching window.
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4)

Press the OK button; the Background stitches will be deposited.

Obviously, as for the other work modes, the parameters of a Background
entity that has already been deposited may be changed at any time by
selecting the entity with the right button of the mouse and selecting the
Properties command from the contextual menu; the following window
appears:
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Backgrounds Editor
As explained earlier, the …\Millennium3\Samples\Backgrounds folder
contains almost two hundred types of Background with a *.bkg extension.
As well as Backgrounds with a *.bkg extension, Millennium is able to use
also Backgrounds with a *.stf extension and, starting from version 1.35, to
allow you to create or modify Backgrounds with this extension thanks to a
Backgrounds Editor that is very easy to use.
To start this editor, select Tools>Backgrounds Editor and then select one
of the following menu commands:
- New if you wish to create a *.stf Background;
- Select Image if you wish to create a *.stf Background starting with a
reference image;
- Modify to modify an existing *.stf Background.

The Backgrounds Editor work window
In the Backgrounds Editor work window it is possible to identify:

① = Drawing area
② = Rulers
③ = Menu bar
④ = Work toolbar
⑤ = Display toolbar
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③

①

④

⑤
②

Drawing area
The drawing area is subdivided into four equal rectangles; a drawing made
in any one of these four rectangles will be repeated automatically in the
other three.
The rectangle in the lower left hand corner, outlined in red, is the one that
allows you to modify the dimensions of the work area, as will be explained
below. For this purpose, the drawing area is provided with rulers along the
left hand side and along the bottom.
These rulers give an indication that is in relation to the display scale of the
Background that is being created rather than to a unit of measure, as this is
not important during the creation phase.
In fact, as explained in the paragraph relative to the use of Backgrounds,
these measurements (Effect Width and Effect Height) are set when the
Background is being used:
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Menu bar
The menu bar contains the following commands:
File
New
Save (Ctrl+S)
Save as
Exit (Ctrl+F)
Display
Zoom all (F10)
Zoom (F9)
Scale Image – (F4)
Scale Image + (F11)
Zoom All Image (Shift+F10)
Draw
Point
Straight Line
Arc
Circle R
Circle T
Curve
Polyline
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Work tool bar
The Work toolbar contains the following buttons:
Save Background (equivalent to selecting File>Save)
Draw a point (equivalent to selecting Draw>Point)
Draw a straight line (equivalent to selecting Draw>Straight Line)
Draw an arc (equivalent to selecting Draw>Arc)
Draw a circle given the radius (equivalent to selecting Draw>Circle R)
Draw a circle passing through three points (equivalent to selecting
Draw>Circle T)
Draw a curved line (equivalent to selecting Draw>Curve)
Draw a polyline (equivalent to selecting Draw>Polyline)
Delete

Display tool bar
The Display toolbar contains the following buttons:
Display the entire Background
Display the entire image
Zoom + (equivalent to Display>Zoom)
Move the drawing area downward with respect to the work window
Move the drawing area upward with respect to the work window
Move the drawing area to the left with respect to the work window
Move the drawing area to the right with respect to the work window
Display/hide the grid.
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Activate/deactivate grid snapping.
Modify the size of the quadrants
Zoom Image
Hide Image
Move Image

Using the Backgrounds Editor
How to use the Backgrounds Editor will be explained in the following
paragraphs.

Dimensioning the drawing area
The first task that must be performed is to set the dimensions of the four
rectangles that define the drawing area.
Press the
button and position the mouse pointer on the vertex of the
lower left rectangle (the one delimited by dotted red lines) if you wish to
simultaneously modify both the height and the width of the rectangle, or on
one of the two sides of the rectangle if you wish to modify only the height or
only the width.
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Obviously, it is possible to change the dimensions of the four rectangles
even after having drawn the Background, but this will have an influence on
the final effect of the background itself.
Here is an example:

Height = 40
Width = 20

Height = 20
Width = 20

Using the drawing tools
The Backgrounds Editor drawing tools (similarly to the Millennium III
drawing tools) require the use of the left button of the mouse and, in the
case of curved lines or polylines, even the space bar on the keyboard. The
following paragraphs show some schematic representations that explain
the use of each of the drawing tools available in the Editor.
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Drawing a point
•

Press the

button or select Draw>Point.

Drawing a straight line
•

Press the

button or select Draw>Straight Line.

Drawing an arc
•

Press the

button or select Draw>Arc.

Drawing a circle given the radius
•

Press the

button or select Draw>Circle R.
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Drawing a circle passing through three points
•

Press the

button or select Draw>Circle P.

Drawing a curved line
•

Press the

button or select Draw>Curve.

Drawing a polyline
•

Press the

button or select Draw>Polyline.
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Deleting drawn objects
By pressing the
button on the work toolbar and then clicking with the
left button of the mouse on the object to be deleted, it is possible to delete,
one at a time, the objects that have been drawn on the drawing area. The
object, that is normally shown in green, is displayed in black and the
following message appears:

Press the Yes button to confirm.

Using the grid
When using the drawing tools, it may be useful to activate the grid by
pressing the

button, and even to enable snapping the mouse pointer

to the grid by pressing the button
.
Example of using snapping to the grid:

Creation of a new Background
To create a new Background, select Tools>Backgrounds Editor>New
and then draw the Effect of the Background in any part of the drawing area
because, as explained earlier, anything drawn in one of the four rectangles
will be repeated automatically in the remaining rectangles:
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When the drawing has been completed, it is necessary to save the created
Background by pressing the
button (or by selecting File>Save). The
following box appears, where you can insert a name that has a maximum
of eight character:

The Background will be saved in the …\Millennium3\Samples\Backgrounds
folder.

Backgrounds with empty areas
If the created Background contains areas that are empty, in other words,
areas that are empty for the entire height of the drawing area, the following
warning message will be displayed before the Save as window appears:
C10-56

Millennium III

and, at the same time, these empty areas will be outlined with gray dotted
lines on the drawing area.
The presence of empty areas indicates a lack of continuity in the final effect
of the background, which it is preferable to avoid as shown in the following
example.

In the Background used in this example, the lack of continuity of the
Background due to the empty areas (indicated by the arrows), in practical
terms causes the deposition of Jumpstitches of a length equal to the entire
height of the embroidery and therefore a lack of continuity in the
Background Effect.
Instead, a Background without empty areas, as shown below, makes it
possible to produce embroideries that have a very pleasing effect as there
are no discontinuous patches:
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Modifying a Background
To modify a
Background with a *.stf extension, select
Tools>Backgrounds Editor>Modify. The Insert Background window will
open from which it is possible to select the icon of the Background that you
wish to modify and then press the
button or click twice on the icon
itself to open it in the Editor drawing area:

The Backgrounds Editor work window opens and it is then possible to
modify the open Background by using the drawing tools as explained
earlier.
When the modifications are completed, press the
button (or select
File>Save) if you wish to replace the old Background with the newly
modified one or select File>Save as to assign a new name to the modified
file and also retain the old file.
In both cases, the Background is saved in the same folder as the original
file, generally …\Millennium3\Samples\Backgrounds.
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Creating a Background starting with a reference image
To create a Background starting with a reference image, select
Tools>Backgrounds Editor>Select Image. The Insert Image window
opens from which it is possible to select the icon of the image that you wish
to open in the drawing area of the Editor either by pressing the
or by clicking twice on the icon itself:

The selected image will open in the Backgrounds Editor work area:

The following operations may be performed on the open image:
Re-dimension the image
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Select Display>Scale Image – (or press the F4 key) to make the image
smaller.
Select Display>Scale Image + (or press the F11 key) to enlarge the image
Zoom
Select Display>Zoom or press the
button on the display toolbar and,
using the left button of the mouse, on the work area describe a rectangle
that contains the section of the image that you wish to enlarge.
To redisplay the entire image press the

button (or press Shift+F10).

Hide/display image
When using the drawing tools, it may be useful to temporarily hide the
image; to do this, press the
button on the display toolbar.
To redisplay the hidden image, press the same button again.
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Moving the image
To move the image that has been opened on the drawing area, press the
button on the display toolbar and then click on it with the left button of
the mouse, and keeping it pressed, drag it to the new position.
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Drawing a background using the image
Place the image in the desired position and then, using the drawing tools,
trace over those parts of the image that you wish to reproduce in the
Background effect:

When the drawing is completed, press the
button (or select
File>Save), to assign a name to the created Background:

When Backgrounds Editor is closed, the image that is open on the work
area will be deleted automatically.

Now the Background has been saved and the relative icon will be displayed
in the graphic list of the Insert Background window, ready to be used as
explained in the relative paragraph:
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Note regarding displaying the icons.
Some graphic cards allow you to set a number of colors up to 32 bit,
however, if you wish to save the Backgrounds icons correctly, it is not
possible to set colors above 24 bit.

24 bit
32 bit
For further information about setting the number of colors, refer to the
Microsoft Windows™ guide.
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Motifs
In general, the motifs are small, simple embroideries that are used in
repetition to obtain more complex designs. Millennium III allows you to
repeat the motifs along a curve (Motif on curve) or to use them to fill a
closed geometric figure (Fill Motifs).
You may yourself create the motifs to be used in your jobs or you may use
those provided together with the program (they are contained in the …
Millennium3\Samples\Motifs folder).

Motif on curve
Introduction
This work mode makes it possible to deposit a series of Motifs, in other
words simple embroideries in cxm format, along any curve (line, polygon,
circle, ellipse) in order to obtain pleasing decorations in a short space of
time.
With Millennium it is possible to deposit different types of Motif of the same
or a different color, along the one curve. As will be explained in more detail
later, each Motif will be deposited on the curve in relation to its size and,
during the description phase (in other words before depositing the stitches),
each single Motif that is deposited may be modified. The description curve
may be edited both before and after deposition of the Motif stitches and the
“Motif on curve” embroidery entity that is obtained may be edited in the
same way as any embroidery entity obtained with the other Millennium
work modes.
Some examples of Motifs are supplied together with the program and are
contained in the folder… Millennium3\Samples\Motifs.
Example of a Motif on curve:

CURVE
MOTIF

MOTIF ON CURVE
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Setting the parameters
The procedure for using the Motif on curve work mode is basically the
same as that used for the other Millennium work modes (Automatic,
Column, Satin, Tatami, Background):

•
•

Select Motif on curve from the Punch bar (View>Toolbar>Punch
menu) or select the Motif on curve command from the Embroidery
menu or, alternatively, press the Alt+6 keys:
The parameters relative to the Motif on curve work mode will be
displayed on the Status Bar:

Going from left to right, this bar contains five boxes that display
respectively:
- the Style (refer to the chapters “Style table” and “How to create a style”
discussed in manual 1.21);
- The List of the Motifs that may be deposited on a curve (this list must
contain at least one Motif). The Motifs are placed on the curve in the
same order in which they appear on the list;
- The Width in mm of the Motif displayed in the List box;
- The Height in mm of the Motif displayed in the List box;
- The Distance in mm between each Motif of the same type (the one
displayed in the List box).
Furthermore, there are six buttons on the status bar:
-

Button (X-Y proportional): by pressing this button, the variations
made to one of the two parameters, either Height or Width, are
transferred proportionally to the other parameter.
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-

Button (Use current needle): by pressing this button, before
starting Motif description, the Motifs will be deposited using the needle
selected from the punch bar:

-

Button (Flip Vertical): by pressing this button, during the
description phase (in other words before depositing the stitches), the
Motifs will be flipped vertically.


-



Button (Flip horizontal): by pressing this button during the
description phase (in other words before depositing the stitches), the
Motifs will be flipped horizontally.





Note: The Flip Horizontal flips the Motifs with respect to the description
curve, and along with the Motifs it also flips the thread entry and exit points
for each Motif. In other words, if a Motif had left to right stitch development
before it was mirrored, it will have a right to left development after Flip
Horizontal. Therefore, before applying a flip, we advise you to check that
the Motif entry and exit points allow for a sequential development of the
entire Motif.
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-

Button (Reverse Disposing) by pressing this button, during the
description phase (in other words before stitch deposition), the
disposition, in other words the direction of development of the Motifs
with respect to the curve, will be reversed.




It is important to remember that the
button completely reverses the
disposition of the Motifs with respect to the curve. Therefore, if you wish to
reverse the direction of development of the Motif but wish to maintain the
same “orientation” it is necessary to use the
and
the previous page for the note about these buttons).

buttons (refer to

During the description phase, the symbols
and
that indicate the
direction of development of the motifs themselves with respect to the curve,
are shown on one of the Motifs:

from right to left

from left to right
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If more than one Motif is deposited on the same curve, each series of
Motifs of the same type is deposited in a sequential manner from one end
of the curve to the other, in the same order as they appear in the list in the
Properties window (refer to the description of the
button).
Let’s explain this concept more clearly by using a practical example.
Assume that we wish to deposit these three Motifs on one line:
Motif1.cxm:
Motif2.cxm:
Motif3.cxm:
in order to obtain the following decoration:

The development of the Motifs, and therefore stitch deposition, with respect
to the description curve (in this case a straight line) will be carried out as
follows:
First Motif: from left to right



Second Motif: from right to left

Third Motif: from left to right
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Two folders may be selected from this window:
- The Motif on curve card makes it possible to Add, Remove or Change
the Motifs and to select a Needle, change the dimensions (width,
Height) or the reciprocal Distance for each Motif. Furthermore, this
window contains the following four boxes, Ratio., Flip. Hor., Flip.Vert.,

-

Reverse.Disp that correspond to the
,
,
and
buttons
of the status bar.
The Tie card makes it possible to set the parameters relative to thread
tie and thread cut, similarly to the other work modes.

Using the Motif on curve
1) Select Motif on curve from the Punch bar (View>Toolbars>Punch
menu) or select the Motif on Curve command from the Embroidery
menu, or alternatively press the Alt+6 keys.
2) Press the
button on the status bar: the Parameters window will be
displayed from which it is possible to select the Motif (or Motifs) that are
to be used:
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-The Add button makes it possible to add a Motif to the list, pressing it
opens the embroidery graphic list (Insert Motif window) from which it is
possible, by specifying a path (*), to select a Motif:

(*) The Motifs on curve that are provided with the program are contained in
the Millennium3\Samples\Motifs folder.
- The Remove button makes it possible to delete the selected Motif from
the list.
- The Change button makes it possible to replace the selected Motif with
another Motif chosen from the embroidery graphic list (Insert Motif window)
that opens when the button is pressed
Once the Motif (or Motifs) to be used have been selected, it is possible to
select a respective Needle (Color) for each one:

and if necessary, set the Height, Width and Distance parameters and/or
activate the desired functions (Flip Horizontal, Flip Vertical, Reverse
Disposing).
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The
buttons located to the right of the List of Motifs make it possible
to move the selected Motif up or down. This is very important as the Motifs
are deposited on the curve in the same order as they appear on the list.
The disposition of the Motifs on the description curve depends on the
number of different Motifs employed as well as on the number of colors
used. We shall use a practical example to explain this concept more
clearly.
Assume that we wish to deposit the following Motifs on a curve:

The various possible cases are:
1st case
Use of one type of Motif only (and The distance between each Motif is
therefore one color only)
set at zero (however this value may
be changed during the description
phase, in other words before stitch
deposition).

2nd case
Use of several Motifs of a different The distance (*) between two Motifs
type but of the same color:
of the same type is equal to the sum
of the width of the other Motifs.
In this way, an alternating sequence
is obtained that prevents overlapping
of the Motifs.
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3rd case
Use of several Motifs of different Each series of Motifs of the same
type and color.
type is deposited starting from the
same end of the description curve
and the distance between each
single Motif of the same type is zero.
In this case a sequence with the
Motifs overlapping is obtained.

(*) Note: The program will force the Distance parameter only if the default
style
is selected and not for any of the styles
defined by the User.
In fact, as for all the other Millennium work modes, even for the Motifs on
Curve it is possible to create styles defined by the User, as explained in the
paragraph “How to create a style” in Manual 1.21.
3) Select a description tool (Curve, Ellipse, Polygon, Rectangle) and
describe the curve where the Motifs will be deposited.
4) Once the curve has been described, the outline of the first Motifs is
displayed on it whereas the remaining Motifs will be indicated by
rectangles that represent the surface area occupied. The hooking
handles (or modifiers) that make it possible to edit the Motif will appear
on the outline of the first Motifs.
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= hooking handle to modify the Height of the Motif
= hooking handle to modify the Width of the Motif
= hooking handle for proportional modification of the Height and Width
of the Motif.
= hooking handle to modify the Distance between the Motifs.
= hooking handle for Rotating the Motif around the center of rotation.
= center of rotation. It may be moved to any position in the embroidery
window by selecting it and dragging it with the left button of the mouse.
= hooking handle to Translate the Motifs with respect to the curve, yet
keeping them hooked to the curve.
= hooking handle to Move the Motifs with respect to the curve.
Remember that, as well as modifying the Motif using the hooking handles,
during the description phase it is possible to use the
,
and
buttons to flip (horizontally or vertically) or to reverse the position of the
Motifs with respect to the description curve.
When working with several Motifs, by using the TAB
key it is
possible to cyclically select one Motif at a time in order to modify it
independently of the other Motifs:
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press TAB

press TAB

press TAB

During the description phase of the Motifs, by using Simple Selection

or

Extended Selection
, it is possible to modify the description curve as
described in the chapter “How to select and modify the entity created” in
Manual 1.21

Simple Selection of the curve:
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Note: Remember that during the description phase it is possible to use the
Undo
and Redo
commands to cancel or restore the modifications
made to the Motifs or to the description curve.
5) Once the modifications and adjustments to the Motifs and/or the
description curve have been finished, press Enter to deposit the
stitches. During stitch calculation, the status bar of the embroidery
window
will
display
a
progress
bar
Extended selection of the curve:

.
The
calculation times depend on the number of Motifs deposited, their
complexity, the type of description curve, etc.. In some cases,
calculation times may be quite long (remember that, as for other
Millennium functions, it is possible to interrupt or cancel the calculation
process at any time simply by pressing the Esc key). If the result
obtained is unsatisfactory, it is possible to return to the Motif description
phase by using the Undo
command immediately after stitch
deposition, and then make the adjustments required.
6) Once the Enter key has been pressed, a Motif on curve embroidery
entity has been created that, as for any other embroidery entity, may
be selected and modified as described in the chapter “How to select
and modify the entities created” in Manual 1.21.
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The Motif on curve entity on Tree View:

Furthermore, by selecting the Motif on curve entity with the right button of
the mouse, it is possible to access the Properties window:

from which it is possible to change the parameters of each of the Motifs
used, the type of Motif, the needle used, etc., as previously described.

List of the Motifs supplied with the program
The Motifs supplied with the program are contained in the …
Millennium3\Samples\Motifs folder. The table that follows shows the
individual Motifs and some Motif combinations.
MOTIF

FILE NAME
MOT_001
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MOT_002
MOT_003

MOT- 003A + MOT- 003B

MOT_004

MOT_005

MOT_006

MOT_006A + MOT_006B

MOT_007
MOT_008

MOT- 009

MOT_009A + MOT_009B

MOT_010
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MOT_010A + MOT_010B

MOT_011

MOT_011A + MOT_011B

MOT_12A

MOT_12A + MOT_12B

MOT_13

MOT_14

MOT_15A
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MOT_15A + MOT_15B

MOT_16

MOT_17

MOT_18

MOT_19A + MOT_19B

MOT_20
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MOT_21

MOT_22

MOT_23

MOT_24

MOT_25

MOT_26

MOT_27

MOT_28A + MOT_28B
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MOT_29A + MOT_29B

MOT_30A + MOT_30B

MOT_31A + MOT_31B

MOT_32A + MOT_32B
MOT_33A + MOT_33B

MOT_34

MOT_035A + MOT_035B

MOT_036A + MOT_036B

MOT_037A + MOT_037B
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MOT_038A + MOT_038B

MOT_039

MOT_040

MOT_041

MOT_042

Rotation of Motifs
Starting with version 1.36, a control box (No Rotation) has been installed in
the Parameters window of the Motifs on curve. This control box allows you
to choose whether the axis of each motif follows the direction of the curve,
or whether the motif remains horizontal or vertical regardless of the
direction of the curve.
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Example:

Suppose that you want to use the following motif:
If we check the

box, we obtain the following result:

whereas, if we do not check the
result:

box, we obtain the following
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Motifs in area
Introduction
Fill motifs is a work mode that allows you to fill a closed geometric figure
with one or two motifs of the same or of a different color. The motif (or
motifs) that you decide to use will repeat automatically inside the area that
you have described according to a composition consisting of columns that
will be alternated if two motifs are used.

one motif in an area

two motifs in an area

Each motif is deposited in the described area in relation to its size and
during the description phase (in other words before the stitches are
deposited) the motifs are represented inside a grid that contains several
handles that allow you to modify the dimensional parameters of the motifs.

When using two motifs of a different height, the height of the first motif
(Motif 1) will be used as a reference and the second motif (Motif 2) will be
re-dimensioned automatically. The curve that encloses the area that is to
be filled with the motif(s) may be edited either before or after stitch
deposition and the “Fill Motifs” embroidery entity thus obtained may be
modified in the same way as any other embroidery entity obtained using
the other Millennium work modes.

Setting the parameters for the Motifs in area
The procedure for using the Fill Motifs work mode is substantially the
same as that used for the other Millennium work modes (Automatic,
Column, Satin, Tatami, Background, Motif on curve):
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Select Fill Motifs from the Punch bar (View>Toolbars>Punch menu) or
select the Fill Motifs command from the Embroidery menu, or press the
Alt+7 keys.

•

In the Fill Motifs window, normally located in the lower section of the
work window (above the Status bar), the parameters relating to the Fill
Motifs work mode will be displayed:

In this window you will find:
- the Style (refer to the chapter “Style Tables” and “How to create a
Style” dealt with in manual 1.21);
- the Cell Width (in mm) of the grid containing the motif (referred to the
motif displayed in the List box shown on the right hand side of the
same box);
- Cell Height (in mm) of the grid containing the motif (referred to the
motif displayed in the List box shown on the right hand side of the
same box);
-

-

the
button (proportional X-Y): by pressing this button, the
changes that you have made to one of the preceding parameters
(Height or Width) are transferred proportionally to the other parameter.
the Copies. This parameter allows you to determine the staggering
between the columns of motifs in area.
the Subdivision. This parameter (to be used together with the
preceding one) allows you to specify the number of columns that must
be completed before staggering takes place.
the
button, that allows you to select from three possible methods
for filling the area: Internal, Full, Partial.
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-

the List box of the motifs that you wish to deposit in the area
(maximum of two motifs). After having selected one of the two motifs
from the list, it is possible to set the relative parameters.
the Motif Width in mm of the individual motif (referred to the motif
displayed in the List box).

-

the
button (Horizontal Flip). Pressing this button during the
description phase (in other words before stitch deposition) will flip the
motif horizontally.
Note: The Horizontal Mirror also flips the thread entry and exit points.
This means that if stitch development for a given motif went from left to
right before flipping, then stitch development will go from right to left
after flipping. Before using the flip, we recommend that you ensure
that the thread entry and exit points allow the motifs in area to be
developed sequentially.

-

The
button that allows you to open the Parameters window, where
it is possible to set the general parameters of the Fill Motifs (some of
which are those shown in the Fill Motifs window).
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The Parameters window of the Motifs in Area
To open the Parameters window of the Motifs in area, press the
in the Fill Motifs window:

button

In this window it is possible to select from three cards: Fill Motifs,
Parameters and Tie.

The Fill Motifs card
This card allows you to select the motif (or motifs) to be used to fill an area
and to set the relative parameters.
• First of all, you must decide whether you want to fill the area with one
or with two motifs. If you wish to fill it with two motifs, check the
box, this will enable both sections (Motif 1 and Motif
2) of the Motifs in Area card.
•

Once this has been done, use the
button to select from
the embroidery graphic list the motif (or motifs) that you wish to use.
The width of the selected motif will be displayed in the Width box.
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Width of the first
motif

Width of the second
motif

If you are using two motifs that have different heights, the height of the
first motif (Motif 1) will be used as the reference height and the second
motif (Motif 2) will be re-dimensioned automatically.
•

Check the
box if you want the motif to be flipped horizontally
(alternatively – after closing the Properties window – you may press the
button in the Fill Motifs window).

Before flipping
•

After flipping

If using only one motif, check the
box if you want the
motif to remain either horizontal or vertical even if the composition
columns (in other words the grid) are sloping. Otherwise, the axis of the
motifs will follow the slope of the columns.
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Rotation

No rotation

If using two motifs, use the two
option boxes to display the two
motifs alternately (Motif 1 or Motif 2) in the preview box.

The Parameters card
After having selected the motif (or motifs) to be used, this card will allow
you to set the grid dimensional parameters and the passage point
parameters.

You may alter the height and width of the grid cells if you wish.
By
default, the Cell Height value corresponds to the height of Motif 1 and the
Cell Width value corresponds to the width of Motif 1, or, if using two motifs,
to the sum of the widths of Motif 1 and 2.
If using two motifs
that have different heights, the reference height will be that of the first motif
(Motif 1) and the second motif (Motif 2) will be re-dimensioned
automatically. If you want the changes that you have made to one of the
two parameters (Height or Width) to be transferred proportionally to the
other parameter, check the
button in the Fill Motifs window.

box or press the
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Cell width

Cell height

•

Set the Dist. X and Dist. Y values between the cells of the grid.
Dist. X

Dist. Y

Set the vertical stagger value between the cells of the grid. This stagger
value is expressed in Subdivisions into which the height of the cell is
subdivided. If this value is set at 2, it means that the adjacent columns will
be lowered by a value equal to half the height of a single cell (as illustrated
in the example shown below). If this value is set at 3, it means that the
adjacent columns will be lowered by a value equal to one third of the height
of a single cell, and so on.
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Set the number of Copies, intended as the number of columns that must
be completed before staggering occurs. In this example this value has
been set at 2 (in other words, staggering occurs every second column)
whereas the Subdivision has been set at 3.

Select the type of filling: Internal, Full or Partial. Instead of using this pulldown menu, you may use the

button in the Fill Motifs window.
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Internal filling

With this type of filling, only those motifs that
are contained completely within the
geometric figure will be stitched.

Full filling

With this type of filling, even those motifs that
are only partially contained within the
geometric figure will be stitched.

Partial filling

With this type of filling, those motifs that
extend beyond the geometric figure will be
cut.

Note: If using motifs with Sequins, the Precise filling will not be enabled.
Check the Descending deposit box if you want the motifs in each column
to be deposited starting from the top. Otherwise the motifs will be deposited
sequentially from top to bottom to top again in a zigzag fashion.
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Sequential deposition

Deposition starting from the top

Note: This parameter is particularly useful for depositing Sequins as the
deposition devices usually work in this way.

•

Set the stitch Length (in mm) of the stitches used to pass from one
column to the next.

•

Set the Indent (in mm) with respect to the description curve. If this
value is set at zero, it means that the passages are carried out on the
description curve itself.

The Tie card
Similarly to the other work modes, the Tie card allows you to set the
parameters for thread tie and thread trim.
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Using Fill Motifs
Select Fill Motifs from the Punch bar (View>Toolbars>Punch menu) or
select the Fill Motifs command from the Embroidery menu, or press the
Alt+7 keys.
Press the
button on the status bar: the Parameters window will be
displayed from which it is possible to select the motif (or motifs) that you
wish to use. Set the parameters as explained earlier.

Select a description tool (Curve, Ellipse, Polygon, Rectangle) and describe
the closed geometric figure inside which the motifs are to be deposited.

After the geometric figure has been described, a grid will be displayed
whose cells represent the area that will be occupied by a single motif or by
the two motifs that are to be deposited. Handles for making a variety of
modifications will appear on the grid.
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In this phase, called the motif description phase, you may:
alter the dimensional parameters of the motifs and their placement by using
the handles on the grid (as explained in the next paragraph);
1. Alter the dimensional parameters of the motifs by using the Fill Motifs
window located above the status bar. If using two motifs, select them
from the List box one at a time.

2. edit the described geometric figure by using the simple selector
(re-dimensioning, rotation, deformation) or the extended selector
(node editing);
3. move the thread entry
and exit
points.
Press Enter to deposit the motifs in area:

The embroidery entity thus obtained may be modified in the same way as
any other embroidery entity by using the simple selector

, the extended

selector
and the stitch selector
(for further details consult the
chapter “How to Select and Modify the Entities created” in manual 1.21)
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In particular, remember that by using the simple selector
it is possible,
after having selected Fill Motifs entity with the right button of the mouse, to
display the Properties window:

Instead, by using the extended selector, after having selected the Fill Motifs
entity with the right button of the mouse, it is possible to select the Edit
Motifs command from the contextual menu and carry out the modifications
described in the following paragraph.
We also remind you that if the result obtained is not satisfactory, you may
select Edit>Undo Create Entity (or press the
button or the Ctrl+Z
keys). This will allow you to return to the situation shown in point 4 and to
carry out the modifications indicated in point 5.

Modifying Fill Motifs using the handles on the grid
As mentioned, during the Fill Motifs description phase, in other words
before stitch deposition, it is possible to alter the dimensional parameters of
the motifs and their placement by using the handles on the grid.
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By using the TAB
key it is possible to display different types of
handles (in a cyclical fashion) on the grid.

(modifies the dimensions and slope of the cells ) press the TAB
key
(modifies the distance between the cells)
press the TAB key
(modifies the position and dimensions of Motif 1)
press the TAB key
(modifies the position and dimensions of Motif 2)
press the TAB key
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Modifying the dimensions and slope of the cells
This is the default situation, the motifs are shown in gray and the following
handles appear on the grid:

Handles for Moving the motifs with respect to the geometric figure to
be filled.
Handle for proportionally modifying the Height and Width of the
motifs.
Handle for Rotating the motifs around the upper left vertex of the grid
(the center of rotation may not be modified).
Obviously, any modifications made to the dimensions and slope of the cells
will be transferred to the motifs that they contain.

Modifying the distance between the cells
This situation occurs, starting from the default situation described in the
preceding paragraph, by pressing the TAB key once. In this case, Motif 1
is shown in blue and Motif 2 in red.
(2)

(1)

(1)
(2)
(3)

(3)

handle for modifying the Distance Y between the cells
handle for modifying the Distance X between the cells
handle for proportionally modifying the Distance X and the
Distance Y between the cells
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Modifying the dimensions and the position of Motif 1
This situation occurs by pressing the TAB key starting from the situation
described in the preceding paragraph. In this case, Motif 1 is shown in blue
and Motif 2 in gray.

Handle for Moving the motif with respect to the cell.
Handle for proportionally modifying the Height and the Width of the
motif.

Modifying the dimensions and the position of Motif 2
This situation occurs by pressing the TAB key starting from the situation
described in the preceding paragraph. In this case Motif 1 is shown in gray
and Motif 2 in red.

Handle for Moving the motif with respect to the cell
Handle for proportionally modifying the Height and the Width of the
motif.
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Filling an area with two motifs of different color
1. Deposit the first entity by using the Fill Motifs work mode and selecting
a first color.

Change the needle color and ensure that the fill Motifs work mode is still
active:

2. Press the
button and select the motif that you want to use together
with the only already deposited.
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3. Select the curve of the first entity (stitch display may be deactivated
temporarily by using the
button) and use the right button of the
mouse to select the Duplicate and Activate Form command from the
contextual menu.
4. The grid will be displayed based on the parameters of the active Fill
Motifs mode. If these parameters do not correspond to those of the
motif that you have already deposited, select the first entity and use the
right button of the mouse to select the Recover parameters command
from the contextual menu.
5. Position the second entity in relation to the entity deposited already and
make any adjustments that may be needed.

Press the Enter key to deposit the second entity:
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How to deposit stitches manually
During punching it is possible (except when the “draw shapes” work mode
has been selected) to manually deposit jumpstitch stitches, in other words
without any automation.
These are useful mainly to create manually:
•
•
•

Thread tie
Small movements on the embroidery
Particular underlays

To create stitches manually, move the mouse, pressing the combination of
buttons Shift+ , a stitch will be deposited at each click.

How to modify stitch properties “manually”
With one click of the right button of the mouse on the selected object,
access is gained to the properties window where it is possible to modify all
the parameters relative to the object itself.
For “manual”, the parameters that may be modified are:

Modify thread tacking,
refer to the chapter “How
to set thread tie”

Modify the needles, refer to the
chapter “How to set and
modify needle colour”

Add a comment

Modify the general
parameters, refer to
the chapter “How
to
modify
the
general properties
of the selected
entity”

Modify the borers,
refer to the chapter
“How to set the
borers”
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How to insert a comment
By clicking the right button of the mouse on the selected object, access is
gained to the properties window where it is possible to modify all the
parameters relative to the object itself and even insert a 42 character text
comment.

Manual punching
From version 1.38 onward the stitches generated in manual mode, using
the combination Shift+ , constitute a Stitches Entity (in the earlier
versions they constituted a Manual Entity) that is displayed as such on the
tree view. Each stitch that constitutes an entity of this type may be deleted,
obviously during the description phase, by selecting Modify>Cancel Create
Subdivision or by pressing the
button or even by using the
combination of keys Ctrl+Z. The Stitches Entities created in manual mode
may be modified using the simple selector or the stitch selector as for
any other Millennium III entity.
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Outline
Into the Drawing Instruments have been added the item Outline:

Insert an image, in the example a dog shout, in the
document.
Select the item Outline and
click to the inside of the dog
shout
In the case the area to Outline is composed from
many tonality of color, instead of clicking on a point,
click and holding pressed the button move the mouse to create a rectangle
that includes most of the color shade.
Before to click to the inside of the image is important to select the correct
working tool.
It is possible to generate:
• A drawing if Drawing Mode is selected.
• A sewed line Automatic is selected.
• A column if Column is selected
• Etc.
It is possible to have holes to the inside of the figures also, like in the
example here under:

Tatami fill with one inclination
Naturally it is necessary introduce the inclinations of the stitches where
necessary.
It is possible to fill figures with Complex Fill with holes and with more than
one inclination (it depends on the options activated in the program).

Will be generated the contour of the selected color.
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Introduce, if necessary, one or more inclinations and press
Enter.
The outline description tool (Outline), already present in version 1.21, has
been expanded to allow automatic creation of the outline of an area that
contains several colors or different shades of the same color. Now, in fact,
by keeping the Ctrl key pressed when using the mouse, it is possible to
select several stitches or areas of the one image. Keeping the Ctrl key
pressed, it is possible to describe several selection rectangles in sequence,
one for each color or for each shade of a color present in the area for which
an outline is to be traced.
When all the selection rectangles have been described, the Ctrl key may
be released and, by clicking inside any one of these rectangles (or inside
the area whose outline is to be described), the outline will be generated
automatically.
During description of the selection rectangles it is necessary to bear in
mind that the outline search and description process starts from the starting
angle (in other words the top left angle) of the first selection rectangle that
will be described.

Starting from this angle, the program searches in the four directions for
pixels of a different color (compared to the pixels contained within the
selection rectangle) and then traces the outline of the homogeneous areas
defined by them. It is evident, therefore, that the position of the first
selection rectangle is very important for the final result that you wish to
obtain.
The same considerations are also valid for the case in which, instead of
selection rectangles, singles stitches of an image are selected (by keeping
the Ctrl key always pressed).
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To better explain the use of the selection rectangles, a simple explanation
follows, that uses the satin mode to describe the outlines of an image
consisting of a square containing a circle. Obviously, to describe the
outlines of such a simple image, it would be sufficient to select the Outline
tool and then click on the square and on the circle.
To draw the perimeter of the square it is necessary to trace a selection
rectangle in such a way that its starting angle is closer to the perimeter of
the square than to the circumference of the circle.

To describe the circumference of the circle it is necessary to trace a
selection rectangle whose starting angle is closer to the circle than to the
perimeter of the square:
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CHAPTER 11

Working with alphabets
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Embroideries with more than one text.........................................................25
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How to work with alphabets
Millennium III has a very large and easy to use set of alphabets available
and ready for use.
To use the alphabets, select the text command from the toolbar
Select Text from Punch toolbar (menu View>Toolbars>Punch) or
opening Embroidery menu.

How to deposit a text
•

Perform the operations described in the image in the following order
From those proposed, select the
type of text arrangement desired or
select User to create a customized
one

Select the type of
font to be used
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Select the size of the
character that will be
deposited
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The number set in the box used
for setting the character size
represents
the
height
in
millimetres of the block letter of
the selected font

•

Position the mouse cursor on the desired position in the work area and

press the combination of keys alt + .
The mouse cursor begins flashing and it is possible to write the text
using the keyboard.
• Write the text and confirm stitch deposit by pressing the enter key on
the keyboard.
At this point, as for the other entities created (fill, column, etc.) it is possible
to perform all the modification operations described previously.
•

Example of arranging the text along a line

Example of arranging the text along a section

Example of arranging the text along a curve
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Example of arranging the text above an arc

Example of arranging the text above a circle

Example of arranging the text below a circle
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Example of arranging the text between two straight lines

Example of arranging the text between two sectioned lines

Example of arranging the text between two curves

Example of arranging the text between two arcs
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How to use the USER mode to arrange the text
“User” mode makes it possible to create customized curves and arrange
the text above them.
The procedure is the following:
Select User in the selection box for the type of
arrangement

Describe
the
outline
and
select it (simple
selection)

Press the the
combination
of
keys
Alt+left
button of the
mouse and write
the text.

Press
the
enter button
on
the
keyboard
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How to select the deposited text
To select the deposited text the descriptions in the chapter “How to select
and modify created curves” are generally valid.

As described earlier with simple selection, it is possible to move, modify,
rotate and deform the selected text by using the modification handles.

with extended selection, it is possible to move single characters of the
selected text using the modification nodes

with extended selection – stitches, it is possible to modify the stitches of
the selected text.
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How to modify a deposited text
To modify a text, the same considerations apply as contained in the
chapter: "How to select and modify the entities created".

How to modify a single character of the deposited text
To select only the character desired it is necessary to press the
combination of keys Ctrl+

at this point all the modification operations described earlier are possible.
Furthermore, by pressing the right button of the mouse and selecting the
Needles command from the Properties window, it is possible to change
the needle.

How to modify a deposited text
As for all the other embroidery entities, clicking once with the right button of
the mouse gives access to the Properties, even for alphabets.
Box for modifying the
text (makes it possible
to delete and or add
characters)
Modify the type of font
selected initially.
Modify the size of the
deposited character

Modify text alignment

Note: to modify the other parameters, refer to the relative chapters.
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Thread tacking between characters
It is possible to thread tack
between the characters and at the
end of the text in various ways:
When entering the character:
•
•
•
•

Never
Always
Greater of maximum length
After thread tacking

When exiting the character:
•
•
•
•

Never
Always
Greater of maximum length
Before thread tacking

At the end of the entity
•
•
•

Never
Always
Greater of maximum length

How to modify the Effects property
It is possible to modify the stitching effect of the text.
Type of stitching effect
Effect parameters

At present it is not possible to use the Cancel command on the
modifications made using this property.
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Use of the Tree View
Each letter of a text consists of different entities. This may be checked
easily using the Tree view:

In the case shown above, for example, the letter A comprises three Fill
entities and an Automatic entity.
Each of these entities may be selected singly and modified in the same
way as any other Millennium III entity. However, unlike the latter, the single
entities that make up a text cannot be Deactivated and cannot be
Transformed (for example from fill to satin).
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Selecting and modifying a text
Simple selection of a text
Using the simple selector, click on the text with the left button of the
mouse:
: first click

the handles allow you to:
move
redimension
modify height
modify width
second click:

the handles allow you to:
rotate
deform

Simple selection of a single letter or of one of its entities
Using the simple selector, and the combination of keys Ctrl+left button
of mouse, click on the text letter that you wish to select. By continuing to
use the combination Ctrl+left button of mouse, further clicks of the mouse
will allow you to select the single entities that make up the text.
Obviously, by using Tree View you will also be able to select the single
letters, or the single entities that make them up.
first click on the letter A:

the entire letter is selected
second click on the letter A:
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a single entity of the letter will be selected
After having selected a letter or one of its entities, by using the left button of
the mouse (without the Ctrl key) you will be able to carry out all the
modifications indicated in the preceding paragraph.

Extended selection of a text
Using the extended selector, click on the text with the left button of the
mouse:

the handles allow you to move the entire
text or a single letter

Extended selection of a single letter or of one of its entities
Using the extended selector, and the combination Ctrl+left button of
mouse, click on the text letter that you wish to select. By continuing to use
the combination Ctrl+left button of mouse further clicks of the mouse will
allow you to select the single entities that make up the text
Obviously, by using Tree View you will also be able to select the single letters, or
the single entities that make them up; in this case the simple selector will be forced
and therefore you must click on the extended selector after having selected the
desired entity from Tree View.

first click on the letter A:

the entire letter is selected
second click on the letter A:

C11-14

Millennium III

a single entity of the letter is selected.
At this point it is possible to:
move the entire entity
move the thread entry point
move the thread exit point
modify the inclinations

Use of aup files
On the tool bar that appears when the Text command is selected from the
Punch tool bar (or by selecting Embroidery>Text) the first Favorites list
makes it possible to select the way the text will be set out, the second the
type of font (a preview is displayed and therefore the choice is made
easier), the third the size of the text (that may also be typed directly into the
relative box) and the fourth makes it possible to select a *.aup file that
contains Alphabet Parameters.

The *.aup files contain all the information relative to the parameters that
have been set up to that moment and, therefore, make it possible to save
time if the same parameters are to be used for subsequent works.
To save an *.aup file, press the button
following window appears:
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in which the Name of the file must be inserted and the Save button pressed
(by default, the *.aup files are saved in the ...\Millennium3\Application Data
directory, in other words the same directory as the needles *.ndl files).
The button
on the Text tool bar, makes it possible to set further
parameters for the Alphabets and, in particular, the length of the automatic
stitch:

The “Name Drop”
Introduction
The Name Drop function makes it possible to stitch automatically several
times an embroidery containing one or more texts, replacing these texts
with other texts chosen by the operator each time that the embroidery is
completed or after a definite number of times.
In other words, an embroidery created with the Name Drop function may be
considered to consist of several embroideries each one of which, called
Name Drop Instance, comprises one section that remains fixed and one
section, that is the text, that is replaced from time to time.
For example, the Name Drop function may be used if it is necessary to
embroider the logo of a company and the name of each employee, or the
shield of a sporting association and the name of each athlete, or a drawing
with the names of different people, and in many other cases.
At the end of each single Name Drop embroidery, a Stop is inserted
automatically that allows the operator to unload the embroidery support –
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fabric, cap, T-shirt – from the embroidery machine and to load a new
support to be embroidered.

Use
Obviously, the Name Drop function may be used only if the embroidery
contains a text or if the text, as will be explained later, is enabled to take
part in the Name Drop operations.
To use Name Drop it is necessary to access the Embroidery menu that
contains the following commands:
>Enable Name Drop that allows the Name Drop function to be activated,
enabling the Tree View and automatically creating the first Instance of the
Name Drop function;
>Remove Name Drop that allows the Name Drop function to be
deactivated;
>Read Names that allows texts (generally, even if not exclusively, names)
to be imported from a list created by the operator. This list must be
contained in a text file (*.txt) created by using a text editor such as, for
example, the Windows notepad
(notepad.exe).
The only prerogative of this text file is to present the <NAMEDROP> label
on the first line, and the text objects that are to be used on the following
lines (each line is to be considered a different text whereas the empty lines
are ignored).
The Read Names command is not essential to be able to use the name
Drop function because, as described below, it is possible to add new
Instances even by acting directly on the Tree View via the contextual menu
commands. Naturally, using a text file to create the Name Drop Instances
considerably simplifies preparation of the embroidery.

Example of how to use the Name Drop function
Open or create an embroidery containing a text:

Fixed part of the
embroidery: for example a
logo

“Variable” part of the
embroidery:
the text:
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Enable the text to use the Name Drop operations; using the simple
selection tool, click on the text with the right button of the mouse and select
the Properties command from the contextual menu that appears. The
following window is displayed in which it is necessary to check the “Use in
Name Drop Operations” box in the Text folder.

Activate the Name Drop function by selecting Embroidery>Enable Name
Drop. This will activate the
folder in the Tree View and the
creation of the first Instance of the embroidery called “Template Istance”:

Create the new Instances using one of the two methods described in the
following paragraphs:
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a) via the contextual menu of the Tree View (that is, the one that appears
by clicking with the right button of the mouse on the Tree View itself);
b) via importation of text objects contained in the text file (*.txt).

Creation of new instances using a text file
This is the fastest method and therefore we suggest using this method in
preference to using the Tree View contextual menu
Embroideries with a single text
Create a text file as in the example shown below, and save it with a name,
in the example

Label

List of names
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Note: Any empty lines will be ignored when reading the names described in
the next point. The format (upper case or lower case) of the character used
in the text file will be taken into consideration by the Name Drop function;
instead, the size of the character and the type of font are not taken into
consideration by this function.
2. Return to the Millennium III program and select Embroidery>Read
Names. The Name Drop window appears:
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3. Press the Browse button to search for the text file (name.txt) created
earlier and then press the Open button:

4. The text objects contained in the text file are imported into the Name
Drop window:

5. Press the OK button, the text objects will be imported, one at a time, into
the Tree View, each one defining a new Instance:
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At this point, by selecting the different Instances in the Tree View one at a
time, it is possible to check that in the embroidery, the “Name” text of the
“Template Instance” is replaced with the Instance text selected:







 etc.

To prevent execution of the Template Instance, it is sufficient to set a 0
number of repetitions.
Note: If a text file that has already been read is modified and then read
again by re-selecting Embroidery>Read names from the Name Drop
window, and then from the Tree View, the new modified list of text objects
will not replace the list read earlier but will be added to it (the same idea is
valid for a new list of text objects)
6. Clicking with the right button of the mouse on each Instance of the Tree
View will make the following contextual menu appear:

where:
Duplicate = makes it possible to duplicate the Instance;
Repetitions = makes it possible to set the number of times that the
embroidery machine must repeat the Instance. If this value is set at 0, the
Instance will not be executed;
Rename = makes it possible to change the name of the Instance. Naturally,
changing the name of the Instance does not imply that the text that it
contains will be modified;
Delete = makes it possible to delete the Instance selected (alternatively it is
possible to select the Instance to be eliminated and then press the Canc
key on the keyboard). The Template Instance cannot be eliminated.
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6a. If you wish, each Instance may be modified without altering the
remaining Instances, thus allowing some of these to be customized Thus,
for example, in one Instance the text may be moved or the size or type of
font may be modified.
7. Clicking on Tree View with the right button of the mouse, obviously after
having activated the Name Drop folder, will make the following contextual
menu appear:

where:
Sort by name = makes it possible, at first activation, to order the Instances
in increasing alphabetical order (AZ) and, at a subsequent activation, to
order the Instances in decreasing alphabetical order (ZA), and so on in a
cyclical manner;
Sort by repetitions = makes it possible, at first activation, to order the
Instances by the number of repetitions in decreasing order (maxmin) and,
at subsequent activation, to order the Instances by the number of
repetitions in increasing order (minmax), and so on in a cyclical manner;
8. Save the new embroidery created with the Name Drop function by
selecting File>Salve As. The embroideries created with this function may
be easily distinguished from conventional embroideries as the icon that
represents them contains the “Name Drop” label in the upper left-hand
corner.
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Embroideries with more than one text
The preceding paragraph showed how to use only one text in the Name
Drop operations but the function is able to manage an infinite number of
texts.
The example that follows shows how to produce the shield of a company,
that contains the name of the company (1st TEXT) the department (2nd
TEXT) the name (3rd TEXT) and the surname (4th TEXT) of the
employees. Obviously, the 1st TEXT must remain the same for all the
shields whereas the other three texts will be different for each shield:
Proceed as follows:
Create the shield
1st TEXT (fixed):
the name of the company
2nd TEXT (variable):
the department
3rd TEXT (variable):
the name of the employee
4th TEXT (variable):
the surname of the employee

One at a time, select the four texts for the shield using the right button of
the mouse and select Properties from the contextual menu The following
window appears:
Check this box only for the
2nd, 3rd e 4th texts that will
thus take part in the Name
Drop operations.
Do Not check this box for the
1st text, that must remain the
same for all the shields.
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Label

Department

Name

Surname

Create a text file and save it with a name, in the example
. As
may be seen, the different text groups (each consisting of department,
name and surname) are separated for simplicity by empty lines that, as has
already been mentioned, are not taken into consideration by the Name
Drop functions during reading.
4. Return to the Millennium III program and select Embroidery>Read
names. The Name Drop window appears:

Department

Name

Surname
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The texts of the factory.txt file are assigned to the respective texts of each
Instance in the same order as they were executed.
In case of doubt, before selecting Embroidery>Read Names, check the
order of execution of the modified texts in the Tree View Embroidery
folder, if necessary changing their position as explained in the paragraph
“Modification of the position of the entities in Tree View”.
At this point, by selecting the different Instances in Tree View one at a time,
it is possible to check that in the embroidery displayed in the work window,
the 2nd, 3rd and 4th texts of the “Template Instance” will be replaced by
the corresponding texts of the selected Instance:





 etc.

8. Save the new embroidery created with the Name Drop function by
selecting File>Save As.
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Creation of new instances using the contextual menu
This is a fairly time consuming method and therefore we suggest using it
only when you wish to modify or add new Instances.
Clicking with the right button of the mouse on each instance in Tree View
will make the following contextual menu appear:

Where:
Duplicate = makes it possible to duplicate the Instance;
Repetitions = makes it possible to set the number of times that the
embroidery machine must repeat the Instance. If this value is set at 0 the
Instance will not be executed;
Rename = makes it possible to change the name of the Instance
(obviously, if the name of the Instance is changed, the text that it contains
remains unchanged);
Delete = makes it possible to delete the Instance selected (alternatively it is
possible to select the Instance to be deleted and then press the Canc key
on the keyboard.
To add a new Instance, it is necessary to duplicate an existing Instance,
rename it to avoid confusing it with the original and then modify the text that
it contains by using the right button of the mouse to select Properties from
the contextual menu:
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and then select the Text folder:

Name Drop properties
By selecting the Properties of an embroidery created using the Name
Drop function, and then selecting the “Name Drop” folder it is possible, by
pressing the Update button, to acquire all the information relative to that
embroidery:

In this window:
Defined Instances Count = indicates the total number of Instances of the
Name Drop;
Used Instances Count = indicates the number of Instances used. The
total number of Instances may be different from the number of Instances
C11-30

Millennium III

used as those Instances whose number of repetitions is set at 0 will not be
executed.
Embroideries Count = indicates the total number of embroideries that will
be executed by the embroidery machine. In practice, this value is the sum
of the repetitions of all the Instances.
Aggregative Height (mm) = indicates the height of the area occupied by
all the Name Drop embroideries. In other words it may be said that the
Aggregative Height represents the maximum size, in a vertical direction, of
all the embroideries, taking into account the fact that the Instances, as
indicated in the preceding point 6a, may also be different from each other.
Aggregative Width (mm) = indicates the width of the area occupied by all
the Name Drop embroideries. In other words it may be said that the
Aggregative Width represents the maximum size, in a horizontal direction,
of all the embroideries, taking into consideration the fact that the Instances,
as indicated in the preceding point 6a, may differ one from the other. .
Note: The indications Aggregative Height (mm) and Aggregative Width
(mm) allow the operator to know the maximum size of the embroideries
that he will produce, and, therefore, to prevent the problems that could
arise if the embroidery machine were to be set up taking into consideration
the measurements of only one Name Drop embroidery (in the worst case,
the smallest embroidery).
Example:

+

Aggregative
Height

=
Aggregative
Width
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Printing an embroidery created using the Name Drop
function
The print of an embroidery created with the Name Drop function is
distinguishable from the print of a conventional embroidery as the words
“Name Drop” appear in the upper right hand corner. The other differences
consist in the fact that, although the “X Dimension”, the “Y Dimension” and
the “Stitch Count” indicated at the bottom of the print refer to the
embroidery illustrated, a quadrilateral area that indicates the area of
occupation common to all the Name Drop embroideries (the size of this
quadrilateral is Aggregative Height x Aggregative Width) appears on the
print and allows the operator to take note of the actual size of the
embroidery and thus prevent, for example, errors when setting up the
embroidery machine.
“Name Drop” label
Area given by the
overlapping of all the
areas of the
embroideries that
make up the Name
Drop

+
=
Data relating to the
printed embroidery
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Printing an embroidery
In the print of an embroidery, as well as the information relative to the
embroidery represented (File name, Stitch Count, X Dimension, Y
Dimension, Scale and possibly a “Name Drop” label), the start and end
points of the embroidery are also represented by the following graphic
symbols:
start embroidery

End embroidery
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Printing the work sheet
To print the work sheet, select File>Print or press the combination of keys
Ctrl+P, or press the
button on the toolbar. The Print Work Sheet
window will be displayed, wherein you must set the print parameters.
The lower part of this window contains three buttons:
. Press this button to save the parameters set in the
three cards (Selection, Advanced and Additional
Notes) thus making them available for use in
subsequent work sheets.
Allows you to close this window and to return to the
main window.
Allows you to display the print preview of the work
sheet.

Setting the Print Options

From version 1.40 onwards, it is even possible to print on the work sheet
the background color of the embroidery that you have set in the work area
(remember that to set a background color you must select
Embroidery>Properties and then click on the Modify Color button of the
Needles folder of the window that opens.
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Background = check this box (that is active only if you have checked the
Embroidery box) if you wish to print the embroidery with a background
color that is the same as that set in the Millennium work area. Obviously, to
avoid ink wastage, the background area shown on the work sheet is limited
to the size of the embroidery only (in other words, the area defined by the
modification handles) and does not cover the entire work sheet.
Embroidery = check this box if you would like the embroidery image to be
printed on the work sheet. By checking this box, you will enable the three
control boxes below.
Start/End Point = Check this box (that is active only if you have checked
the Print Embroidery box) if you want the reference points indicating the
start and finish of the embroidery to be printed on the embroidery image
Real View = Check this box (that is active only if you have checked the
Print Embroidery box) if you want the embroidery to be printed with a”3D
effect”.
Scale 1:1 = Check this box (that is active only if you have checked the Print
Embroidery box) if you want the embroidery to be printed on a 1:1 scale. If
the embroidery is very large, the work sheet will be printed on two or more
pages. If the size of the embroidery in 1:1 scale is greater than the size of
the sheet selected, the embroidery image will be subdivided into sections.
Each of these section will be printed on a separate sheet.
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Example of printing an embroidery whose size is greater than the sheet
(Scale 1:1 box checked)
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Example of printing an embroidery whose size is greater than the sheet
(Scale 1:1 box not checked)

Information = check this box if you would like information about the
embroidery to be printed on the work sheet. By checking this box, you will
enable the three control boxes below, that will allow you to specify which
information you wish to print:
Color Used = Check this box if you want the list of the colors used to be
printed on the work sheet
List = check this box if you want the Color Sequence or the Operation
List to be printed on the work sheet.
Notes = check this box if you want the Notes that you have entered in the
Print Work Sheet window to be printed on the work sheet.

C12-7

Millennium III

Draft Quality Print = Check this box if you want a Draft quality print. This
mode allows you to print more rapidly compared to the normal mode and to
use less ink; however the print will be paler.

Layout

Paper Selection = Select the format of the work sheet
Paper Orientation = Select the orientation of the paper. For some formats,
this option cannot be modified.
Header = In this box, type in the text that you want to have on the header
of the work sheet.
Header Size(*) = In this box, enter the size (comprised between 10 and 60)
of the font used for the header.
Font Size(*) =. In this box, type in the size (comprised between 6 and 12)
of the font used for the work sheet text.
(*) The size of the fonts affects the printing area of the work sheet. If you
select fonts that are too large, the work sheet may be printed on two or
more pages.
Margin (Left, Top, Right, Bottom) = Set the print margins of the work
sheet.
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Setting the Notes

Customer = in this box, type in the text that you would like to appear in the
upper section of the work sheet.
This windows allow you to add notes to the Work sheet. For convenience,
these notes have been divided into five boxes in each of which you may
insert a text. The control boxes, found on the left of each text box, allow
you to select which notes you would like to print on the Work sheet.
Clicking on the right part of the fifth box (last box at the bottom) will make a
Windows color palette appear, from which you may select a color to be
associated to the note that you will enter in the fifth box. This color will be
printed (as a graphic display) on the work sheet. The default setting for this
field is white and any color that you will set will not be saved.
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Print Preview
Press the Preview button in the Print Work Sheet window.
You will find the following buttons in the upper part of the print preview
windows.
allows you to center the page in the print
preview window
displays the page in 1:1 scale
increases zoom
decreases zoom
prints the work sheet (in other words, it
allows your printer’s dialog window to
open).
allows you to return to the main window
Navigation buttons (allows you to leaf
through the individual pages that are to be
printed).
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Summary of the information contained in the work sheet

A
B
C
D
E

F
G

H

I

A = Heading (may be set in the Layout folder of the Print Work sheet
window)
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B = File Name, Embroidery Name (may be set in the General folder of the
Properties window), Customer (may be set in the Layout folder of the Print
Work sheet window), Date of printing, and Printing Scale of the embroidery
image.
C = Summary of the information shown in the Properties window of the
embroidery.
D = a Notes field (may be set in the General folder of the Properties
window)
E = five Notes fields (may be set and selected in the Notes folder of the
Print Work Sheet window)
F = List of the colors used.
G = Color sequence or Operations list (you may choose which of the two
parameters to print from the Print Options folder of the Print Work Sheet
window)
H = Start embroidery
I = End embroidery
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Importation of HGPL files
The possibility of importing HPGL (Hewlett Packard Graphics Language)
*.plt files was introduced from version 1.31.
HPGL is a vector graphic language, in metafile format, developed by
Hewlett Packard and exported by the main CAD and graphic programs and
usually used as a standard language for pen plotters.
To import a HPGL file select File>Open (and then the “HPGL (*.plt)”
command from the filter for the type of file format or Edit>Insert>HPGL
File:

Some examples are supplied
together with the program and are
contained in the …
Millennium3\Samples\Hpgl folder.

Example
of a HGPL file:
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Importing Metafiles
Millennium III offers the possibility of importing (only in the Professional
Punch systems) the vectorial curves of metafiles with extension *.wmf
(Windows Meta File) and *.emf (Enhanced Meta File). The main graphic
programs, such as Corel Draw, Adobe Illustrator, Jasc Paint Shop Pro etc.,
are able to export this format.
There are two possible ways to import a metafile:
• by selecting File>Open and then selecting Windows Meta File (*.wmf)
or Enhanced Meta File (*.emf) in the graphic list filter box
• by selecting Modify>Insert>Metafile (or alternatively pressing the
combination of keys Ctrl+Shift+M) and then selecting Windows Meta
File (*.wmf) or Enhanced Meta File (*.emf) in the graphic list filter box
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Importing Frames and Machine frames
By selecting Edit>Insert it is possible to insert, as well as Embroideries
and Images, also Frames and Machine Frames.
The Borders are embroidery entities made using Column mode and may be
used, for example, to produce shields, pennants, coats of arms, etc.
To insert a border, select Edit>Insert>Frame. The following window
appears from which it is possible to select the desired border:

The Frames are items, created using the Draw Shapes method, that are of
the same size as the frames used in the embroidery machines. By inserting
a frame in the embroidery window, you will be certain to produce an
embroidery of a size suitable for the size of the frame employed in the
embroidery machine being used or to distribute the embroidery evenly over
the entire surface of the frame.
To insert a Frame, select Edit>Insert>Machine Frames. The following
window appears, from which it is possible to select the desired frame:
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Peripherals
Introduction
"IOConf" is to a tool used to configure:
• Input codes from disks and tapes.
• Output Codes to disks, tapes or embroidery machines.
• Tape Readers
• Tape Punchers
• Embroidery machines connected to the serial port
• Embroidery machines connected through the Embo network
The configured information are used by Millennium 3.

Overview
The image here down shows the main screen.

Menu
File
Exit

Exit from the Program

Restore
Restore
values

Original When this item is enabled it allows to
restore the original values of the active
Tab
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Output Codes
Select the Machine code you wish to see or edit (click on the corresponding
Tab).
Into the description list you can see the list of available configuration
supplied by Proel TSI or configured by yourself.
The following description is valid for all Output codes
ADD a New Output 1. Press the button New
code:
2. Enter the description of the Output code you are
inserting
3. Press OK to confirm the operation (you can
press Cancel to stop the operation)
4. Configure all parameters and then press Save if
you want to save permanently the modifications,
or press Cancel to to remove the new Output
code You are adding.
EDIT an existing
1. Move to the row of the Output code you
code
want to modify.
2. Modify what you want to modify
3. Press save to save the modifications
4. If you try to move to another row or another
Tab without saving the modifications, you
will be prompted with the question: "Save
modifications", if your answer is Yes the
program will not move away, if you answer
No the program goes away discarding all the
modifications.
DELETE an Output
1. Move to the row of the configuration you
Code
want to delete (click inside the grid)
2. Press the Delete button
Change
the
1. Move to the row and column where you
DESCRIPTION Field
want to change the Description (click inside
the grid)
2. Press F2
3. Edit the line
4. Press ESC to restore the original value or…
5. Press the arrows Up or Down to confirm the
editing

Output Barudan
The parameters are:
C14-6
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Length

Maximum stitch length before to insert a jump
stitch
Color change
If checked the output code will have color change
codes (provided that the embroidery contains the
needle numbers) otherwise will contain stops.
Needle count
This is used for control purposes. If you select for
example 7 needles and the embroidery contains
uses needles 8 and 9 they are converted into
needle 1 and 2 respectively
Starting needle
Used to select the starting needle (usually 1)
Back to starting needle Check if you want that the system inserts the
codes to select the starting needle at the end of
the embroidery.
Thread trimming
Check if you want to have trimming codes into the
generated code (provided that the embroidery
contains the trimming codes)
Use Stops for chenille
End Rewind Code
Borer Position

Use stop codes to change from Chenille to Chain
and vice versa.
Insert an "End of Rewind" code at the beginning of
the embroidery. Useful only with some old model.
Barudan can install the borer device anywhere so
you must specify. Normally is on needle 1.

Barudan FDR III diskettes
Some old Barudan machines cannot read the embroideries (from Barudan
FDR III diskettes) if the label is not in capital letters.
For this reason, when you export a file onto a diskette formatted for
Barudan FDR III, you must assign it a file Label (File Label, Etiquette,
Etiquette Archive) that contains only capital letters.
If you do not, the following error message will appear: “Invalid File Label”
(Invalid file label, Etiquette fichier non valable, Etiqueta del Archivo
incorrecta).

Output Eltac
The parameters are:
Length

Maximum stitch length before to insert a jump
stitch
Back to starting needle Check if you want that the system inserts the
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codes to select the starting needle at the end of
the embroidery.

Output Happy
The parameters are:
Length

Maximum stitch length before inserting a jump
stitch
Back to starting needle Check if you want that the system inserts the
codes to select the starting needle at the end of
the embroidery.
Thread trimming
Check if you want to have trimming codes into the
generated code (provided that the embroidery
contains the trimming codes) (*)

(*) If the Jumpstitch number is set at 0, thread trimming is compatible with
the old Happy machines.

Output Juki
The parameters are:
Length

Maximum stitch length before to insert a jump
stitch.

Output Marco
The parameters are:
Length

Maximum stitch length before to
insert a jump stitch

Color change

If checked the output code will have color change
codes (provided that the embroidery contains the
needle numbers) otherwise will contain stops.
Needle count
This is used for control purposes. If you select for
example 7 needles and the embroidery contains
uses needles 8 and 9 they are converted into
needle 1 and 2 respectively
Starting needle
Used to select the starting needle (usually 1)
Back to starting needle Check if you want that the system inserts the
codes to select the starting needle at the end of
the embroidery.
Thread trimming
Check if you want to have trimming codes into the
generated code (provided that the embroidery
C14-8
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contains the trimming codes)

Output Melco
The parameters are:
Length

Maximum stitch length before to insert a jump
stitch
Color change
If checked the output code will have color change
codes (provided that the embroidery contains the
needle numbers) otherwise will contain stops.
Needle count
This is used for control purposes. If you select for
example 7 needles and the embroidery contains
uses needles 8 and 9 they are converted into
needle 1 and 2 respectively
Starting needle
Used to select the starting needle (usually 1)
Back to starting needle Check if you want that the system inserts the
codes to select the starting needle at the end of
the embroidery.
Thread trimming
Check if you want to have trimming codes into the
generated code (provided that the embroidery
contains the trimming codes)
Jumps to Trim
Number of jumps necessary to activate trimming

Output Pfaff
The parameters are:
Length

Maximum stitch length before to insert a jump
stitch
Color change
If checked the output code will have color change
codes (provided that the embroidery contains the
needle numbers) otherwise will contain stops.
Needle count
This is used for control purposes. If you select for
example 7 needles and the embroidery contains
uses needles 8 and 9 they are converted into
needle 1 and 2 respectively
Starting needle
Used to select the starting needle (usually 1)
Back to starting needle Check if you want that the system inserts the
codes to select the starting needle at the end of
the embroidery.
Thread trimming
Check if you want to have trimming codes into the
generated code (provided that the embroidery
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contains the trimming codes)

Frame out at the End

If you want the frame out at the end of the
embroidery
Model with borer depth Select the machine model

Output Tajima
The parameters are:
Length

Maximum stitch length before to insert a jump
stitch
Back to starting needle Check if you want that the system inserts the
codes to select the starting needle at the end of
the embroidery.
Thread trimming
Check if you want to have trimming codes into the
generated code (provided that the embroidery
contains the trimming codes)
Jumps to Trim
Number of jumps necessary to activate trimming
Chenille

Specify if the target machine is a Chenille machine

Output Toyota
The parameters are:
Color change

If checked the output code will have color change
codes (provided that the embroidery contains the
needle numbers) otherwise will contain stops.

Use Stop to change The stops into the source
Color
converted into color changes

embroidery are

Output Zangs
The parameters are:
Length
Color change
Needle count

Maximum stitch length before to insert a jump
stitch
If checked the output code will have color change
codes (provided that the embroidery contains the
needle numbers) otherwise will contain stops.
This is used for control purposes. If you select for
example 7 needles and the embroidery contains
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uses needles 8 and 9 they are converted into
needle 1 and 2 respectively
Starting needle
Used to select the starting needle (usually 1)
Back to starting needle Check if you want that the system inserts the
codes to select the starting needle at the end of
the embroidery.
Thread trimming
Check if you want to have trimming codes into the
generated code (provided that the embroidery
contains the trimming codes)
Model 168/169

Used to convert correctly the borers sequence for
old Zangs machines

Output ZSK
The parameters are:
Length

Maximum stitch length before to insert a jump
stitch
Color change
If checked the output code will have color change
codes (provided that the embroidery contains the
needle numbers) otherwise will contain stops.
Needle count
This is used for control purposes. If you select for
example 7 needles and the embroidery contains
uses needles 8 and 9 they are converted into
needle 1 and 2 respectively
Starting needle
Used to select the starting needle (usually 1)
Back to starting needle Check if you want that the system inserts the
codes to select the starting needle at the end of
the embroidery.
Thread trimming
Check if you want to have trimming codes into the
generated code (provided that the embroidery
contains the trimming codes)
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Input Codes

Some embroidery code can be interpreted in a wrong way because some
codes are used with different meanings depending on the target
embroidery machine (for example: machines for Chenille, or with the
Sequin device installed).
The following description is valid for all Input codes
ADD a New Input code: 1. Press the button New
2. Enter the description of the Input code you are
inserting
3. Press OK to confirm the operation (you can
press Cancel to stop the operation)
4. Configure all parameters and then press Save
if you want to save permanently the
modifications, or press Cancel to to remove
the new Input code You are adding.
EDIT an existing code 1. Move to the row of the Input code you want to
modify.
2. Modify what you want to modify
3. Press save to save the modifications
4. If you try to move to another row or another
Tab without saving you will be prompted with
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DELETE an Input Code 1.
2.
Change
the 1.
DESCRIPTION Field
2.
3.
4.
5.

the question: "Save modifications", if your
answer is Yes the program will not move
away, if you answer No the program goes to
selected
position
discarding
all
the
modifications.
Move to the row of the configuration you want
to delete (click inside the grid)
Press the Delete button
Move to the row and column where you want
to change the Description (click inside the grid)
Press F2
Edit the line
Press ESC to restore the original value or
press
Press the arrows Up or Down to confirm the
editing

Input Barudan
The parameters are:
Jumps to trim:
Number of jumps that activate the trimmers. Example:
If you enter 3, every time that 3 jumps are
encountered they are converted into a trim code.

Input Happy
The parameters are:
Jumps to trim:
Number of jumps that activate the trimmers. Example:
If you enter 3, every time that 3 jumps are
encountered they are converted into a trim code.

Input Tajima
The parameters are:
Jumps to trim:
Number of jumps that activate the trimmers. Example:
If you enter 3, every time that 3 jumps are
encountered they are converted into a trim code.
Chenille:
Check the box if the code is for a chenille machine.

Input ZSK
The parameters are:
Chenille:
Check the box if the code is for a chenille machine.
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Tape Readers
Used to configure new Tape Readers or to modify an existing one (usually
the communication section).
Complement
It is necessary to complement the data coming
from the reader.
Reverse Direction
Some reader runs the tape from left to right
some other from right to left (reversed).
Rewind Available
Check if the reader has a rewind device.
Use Rewind
Usually checked if Rewind Available.
COM Port
Baud Rate
Parity
Flow Control
Data Bits
Stop Bits

ADD a New Reader:

The communication port.
Usually 600 if no Handshake and 9600 if
Handshake hardware (See the Reader
Manual).
Usually None (See the Reader Manual).
Usually None or Hardware (See the Reader
Manual).
Usually 8 (See the Reader Manual).
Usually 1 (See the Reader Manual).

1. Press the button New
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EDIT
an
Reader

existing

DELETE a
configuration

Reader

Change
the
DESCRIPTION Field

Change
Field

the

NOTES

2. Enter the description of the reader you are
inserting and enter something into the
Notes field
3. Press OK to confirm the operation (you
can press Cancel to stop the operation)
4. Configure all parameters and then press
Save if you want to save permanently the
modifications, or press Cancel to to
remove the new reader You are adding.
5. Move to the row of the reader you want to
modify.
6. Modify what you want to modify
7. Press save to save the modifications
8. If you try to move to another row or
another Tab without saving you will be
prompted with the question: "Save
modifications", if your answer is Yes the
program will not move away, if you answer
No the program goes to selected position
discarding all the modifications.
3. Move to the row of the configuration you
want to delete (click inside the grid)
4. Press the Delete button
6. Move to the row and column where you
want to change the Description (click
inside the grid)
7. Press F2
8. Edit the line
9. Press ESC to restore the original value or
press
10. Press the arrows Up or Down to confirm
the editing
1. Move to the row and column where you
want to change the Notes (click inside the
grid)
2. Press F2
3. Edit the line
4. Press ESC to restore the original value or
press
5. Press the arrows Up or Down to confirm
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the editing

Tape Punchers
Used to configure new Tape Puncher or to modify an existing one (usually
the communication section).
Complement Data
Some Puncher needs to receive complemented
data
Trailing Tape
How many centimeters of empty Trailing Tape
Leading Tape
How many centimeters of empty Leading Tape
Enable Heading
Enables the Punching of the Heading entered
into the Heading field
Heading
Enter here the information you want on the
head of the tape.
COM Port
Baud Rate
Parity
Flow Control
Data Bits
Stop Bits

The communication port
Usually 600 if no Handshake and 9600 if
Handshake hardware (See the Puncher
Manual)
Usually None (See the Puncher Manual)
Usually None or Hardware (See the Puncher
Manual)
Usually 8 (See the Puncher Manual)
Usually 1 (See the Puncher Manual)
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ADD a New Puncher:

EDIT an existing
Puncher

5. Press the button New
6. Enter the description of the Puncher you
are inserting and enter something into
the Notes field
7. Press OK to confirm the operation (you
can press Cancel to stop the operation)
8. Configure all parameters and then press
Save if you want to save permanently the
modifications, or press Cancel to to
remove the new Puncher You are
adding.
9. Move to the row of the Puncher you want
to modify.
10. Modify what you want to modify
11. Press save to save the modifications
12. If you try to move to another row or
another Tab without saving you will be
prompted with the question: "Save
modifications", if your answer is Yes the
program will not move away, if you
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DELETE a
configuration

Puncher

Change the
DESCRIPTION Field

5.
6.
11.
12.
13.
14.
15.

Change
Field

the

NOTES

6.
7.
8.
9.
10.

answer No the program goes to selected
position discarding all the modifications.
Move to the row of the configuration you
want to delete (click inside the grid)
Press the Delete button
Move to the row and column where you
want to change the Description (click
inside the grid)
Press F2
Edit the line
Press ESC to restore the original value or
press
Press the arrows Up or Down to confirm
the editing
Move to the row and column where you
want to change the Notes (click inside
the grid)
Press F2
Edit the line
Press ESC to restore the original value or
press
Press the arrows Up or Down to confirm
the editing

Embroidery Machines (Serial port)
Used to configure the Embroidery Machines connected to the PC or to
modify an existing one .
After installing the program this page is empty.
Machine Type
Select the machine type (Barudan, Happy,
Tajima, Toyota, ...)
Code
Shows the code used (cannot be edited)
Code Selection
Select the code more appropriate for the
machine (see. Output codes)
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COM Port

The communication port used.
Must be different for every Embroidery machine
used or you must have an external switch to
select more then one machine, in this case the
machines must have memory enough to store
the embroidery.
Baud Rate
See Note.
Parity
See Note.
Flow Control
See Note.
Data Bits
See Note.
Stop Bits
See Note.
Note: When the "Machine type" is selected the program displays the default
value for the machine (See the Machine Manual) or contact your supplier)

ADD
a
New
Embroidery Machine:

9. Press the button New
10. Enter the description of the Embroidery
Machine you are adding and enter
something into the Notes field if you like.
11. Press OK to confirm the operation (you
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EDIT
an
existing
Embroidery Machine

DELETE a Embroidery
Machine configuration
Change
the
DESCRIPTION Field

Change
Field

the

NOTES

can press Cancel to stop the operation)
12. Configure all parameters (Machine type,
Code selection and then press Save if you
want
to
save
permanently
the
modifications, or press Cancel to to
remove the new Embroidery Machine You
are adding.
13. Move to the row of the Embroidery
Machine you want to modify.
14. Modify what you want to modify
15. Press save to save the modifications
16. If you try to move to another row or
another Tab without saving you will be
prompted with the question: "Save
modifications", if your answer is Yes the
program will not move away, if you answer
No the program goes to selected position
discarding all the modifications.
7. Move to the row of the configuration you
want to delete (click inside the grid)
8. Press the Delete button
16. Move to the row and column where you
want to change the Description (click
inside the grid)
17. Press F2
18. Edit the line
19. Press ESC to restore the original value or
press
20. Press the arrows Up or Down to confirm
the editing
11. Move to the row and column where you
want to change the Notes (click inside the
grid)
12. Press F2
13. Edit the line
14. Press ESC to restore the original value or
press
15. Press the arrows Up or Down to confirm
the editing
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Embroidery Machines (Embo Network)
Used to configure the Embroidery Machines connected to the PC through
the Embo Network or to modify an existing one .
After installing the program this page is empty.
Machine Type
Select the machine type (Barudan, Happy,
Tajima, Toyota, ...)
Code
Shows the code used (cannot be edited)
Code Selection
Select the code more appropriate for the
machine (see. Output codes)
Embo Address
Select the Address of the Embo Box
COM Port
Baud Rate
Parity
Flow Control
Data Bits
Stop Bits

The communication port used
See Note.
See Note.
See Note.
See Note.
See Note.

Note: If you press the Default button the program selects the default
communication parameters. You can change only the Baud Rate (for
example if the environment is noisy and you decide to reduce the speed),
in this case you MUST change the configuration of every Embo Box in your
network using the DIP switches, see the "Embo user Manual".
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ADD
a
New 1. Press the button New
Embroidery Machine: 2. Enter the description of the Embroidery
Machine you are adding and enter something
into the Notes field if you like.
3. Press OK to confirm the operation (you can
press Cancel to stop the operation)
4. Configure all parameters (Machine type, Code
selection and then press Save if you want to
save permanently the modifications, or press
Cancel to to remove the new Embroidery
Machine You are adding.
EDIT
an
existing 1. Move to the row of the Embroidery Machine
Embroidery Machine:
you want to modify.
2. Modify what you want to modify
3. Press save to save the modifications
4. If you try to move to another row or another
Tab without saving you will be prompted with
the question: "Save modifications", if your
answer is Yes the program will not move
away, if you answer No the program goes to
selected
position
discarding
all
the
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modifications.
DELETE a Embroidery 1. Move to the row of the configuration you want
Machine configuration:
to delete (click inside the grid)
2. Press the Delete button
Change
the 1. Move to the row and column where you want
DESCRIPTION Field:
to change the Description (click inside the grid)
2. Press F2
3. Edit the line
4. Press ESC to restore the original value or
press
5. Press the arrows Up or Down to confirm the
editing
Change the NOTES 1. Move to the row and column where you want
Field:
to change the Notes (click inside the grid)
2. Press F2
3. Edit the line
4. Press ESC to restore the original value or
press
5. Press the arrows Up or Down to confirm the
editing
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How to configure the input/output devices
The entry/exit devices foreseen by the system may be configured by
selecting the control panel command from the devices menu

Tape reader configuration

Tape puncher
configuration

File format
configuration

Embroidery
machine
configuration
Floppy disk
configuration

•

Select the device to be configured.

Floppy disk configuration
Millennium III makes it possible to set a default format that will be used
Setting of the output
diskette format (logic)

Setting of the input
diskette format (logic)

Setting
of
recognition

format

Selection of the default
diskette
format
(physical)

automatically by the system to import and export embroidery files to and
from floppy disks. By checking the Always ask user box, the system will
always ask that a format be specified.
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How to format a floppy disk in machine format
•
•

Select the Control panel command from the Devices menu
With the right button of the mouse, click on the Floppy Disk command
and select “Format” (or select the Floppy Disk command and then the
format command from the Devices menu).

Select the
drive

Select the
label

Select the
desired format
from those
available
Select the capacity
of the floppy disk
used
Display bar for
formatting
progress

After having set the parameters described above, press the Format button
to format the floppy disk
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How to copy a floppy disk
To copy a floppy disk, select the Copy Floppy Disk command from the
Devices menu
Set the original drive of the floppy
disk
Set the destination drive of the floppy
disk

Bar displaying the progress of the
copying operation

How to set a default floppy disk
•
•

Select the icon relative to the floppy disks
Click with the right button of the mouse and select browse floppy disk

•
•

Select the desired format
Click once with the right button of the mouse and select the set as
default command from the menu that appears.
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Tape reader configuration
•

Select the icon relative to the tape readers, the window showing the
configured tape readers will appear.

Double click to add a
new tape reader

List of installed tape
readers

To add a new tape reader, click twice with the left button of the mouse on
the appropriate command in the window, to modify the configuration of the
parameters of an installed reader, select the reader, and then click once
with the right button of the mouse and select the properties command.

Tape reader - General
Insert the name of the tape
reader or modify the
preceding one

Insert a description or
modify the existing one
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Tape reader communication port
Select the
communication port
between the computer
and the tape reader
Set the default reading
speed at 9600 baud.

Set the data flow
Set data relative to the
transmission

Reading a tape reader

Check the box to reverse
reading direction of the
tape (for example reader
GNT 27)

Check the box to activate data inversion (for
example Ghielmetti readers)

Check this box if the reader
is able to rewind
Check this box to use the
rewind
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How to set the default tape reader
•
•
•

Select the desired tape reader
Click once with the right button of the mouse.
Select the set as default command from the menu that appears.

Or from the I/O Devices control panel window, select the tape reader icon
and select the General parameters command from the Devices menu

Embroidery machine configuration
•

From the I/O Devices control panel window, select the icon relative to
the embroidery machines, select the Browse machines command from
the Devices menu, the window showing the configured embroidery
machines will appear.

To add a new embroidery machine, click twice with the left button of the
mouse on "Add embroidery machine" inside the window, to modify the
configuration of the parameters of an installed embroidery machine, select
the machine and then click once with the right button of the mouse and
select the properties command.
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Embroidery machine - General
Insert the name to be
given
to
the
embroidery machine

Insert a description of
the machine

Embroidery machine model
Select the type of
embroidery machine
Display the machine
code used

Select the type of subcode to be used

Embroidery machine connection

I Set the type of
connection between
embroidery machine
and computer
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Embroidery machine communication port
Select the communication
port between the computer
and the embroidery machine
Set the data transfer speed

Set the data flow

Set the data relative to
the transmission

How to set the default embroidery machine
•
•
•

Select the desired embroidery machine
Click once with the right button of the mouse.
Select the Set as default command from the menu that appears.

Alternatively, from the peripherals control panel window select the
embroidery machine icon and select the general parameters command
from the devices menu

Set
the
EMBO net

Set the default
embroidery
machine
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Tape puncher configuration
•

Select the icon relative to the tape punchers, a window showing the
configured tape punchers will appear.
Double click here to
add a new tape
puncher

List of the installed tape
punchers

To add a new tape puncher, double-click with the left button of the mouse
on "Add Tape Puncher" inside the window. To modify the configuration of
the parameters of an installed tape puncher, select the tape puncher, click
once with the right button of the mouse and select the properties
command.

Tape puncher-General

Insert the name of the tape
puncher

Insert a description
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Tape puncher communication port

Select
the
communication
port
between the computer
and the tape puncher
Set the default reading
speed 9600 baud.

Impostazione
flusso dei dati

del
Set the data flow

Punching of tape puncher

Check this box to enable
punching of a heading

Check this box to activate data inversion

Type in the heading

Set head length and tail
length of the tape
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How to set the default tape puncher
•
•
•

Select the desired tape puncher
Click once with the right button of the mouse
Select the set as default command from the menu that appears.

Alternatively, from the peripherals control panel window, select the tape
puncher icon and select the general parameters command from the
devices menu
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File format configuration
Makes it possible to configure the import and export formats for each type
of machine format:
•

From the peripherals control panel window select the icon relative to
the file format, a window appears showing the formats managed by
system.
List of the formats managed by the system

With a single click of the right button of the
mouse, it is possible to set the entry and exit
formats for the selected code by selecting the
properties command

How to set the default file format
•
•
•

Select the desired file format
Click once with the right button of the mouse
Select the set as default command from the menu that appears.
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File Association
•
•
•

Select the file format desired
Click once with the right button of the mouse.
Select the File Association command from the menu that appears.

•

Check the formats that are to be associated to the selected file format.
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How to export an embroidery to file, floppy disk,
embroidery machine, tape
How to export an embroidery to file
•
•
•

Select the Export>File (ctrl + shift F) command from the File menu
Select the path (it is possible to select the floppy disk, the format and
finally the file desired)
Press the Save button to confirm
Select the destination of
the export

Insert the name of
the file to be
exported

Select
the
exportation format

The embroidery may be exported to any directory on the hard disk or onto
floppy disk in the following formats:
•
•
•

Melco Expanded (*.exp)
Tajima (*.dst)
Toyota (*.10o
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How to export an embroidery to floppy disk
•
•

Select the Export > Floppy disk (Ctrl+Shift+D) command from the File
menu
If automatic recognition of the floppy disk format has been set, the
system proceeds automatically. Otherwise it will ask that the floppy disk
format be specified.

Insert the label
of the file to be
exported.

•

Press the Save button to confirm

Note: pressing the configuration button gives access to the following dialog
box that makes it possible to modify the embroidery exit code, on the basis
of the floppy disk format (Toyota in the example),.

Set the embroidery machine that
will be used to produce the
embroidery

Select the machine code
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How to export an embroidery to an embroidery machine
•
•

Select the Export>Embroidery machine (Ctrl+Shift+E) command
from the File menu
If a default embroidery machine has been set then the system will
proceed automatically. Otherwise it will ask for specification of the
embroidery machine and the relative machine code.

List of the
installed
embroidery
machines

•

Press the OK button to confirm

How to export an embroidery to a tape
•
•

Select the Export>Tape puncher (ctrl + shift B) command from the
File menu
If a default tape puncher has been set then the system proceeds
automatically, otherwise it will ask for it to be specified.

List of the installed tape
punchers

•
•

Press OK to confirm
Select the type of embroidery machine, the relative code for the
machine that will be used to punch the tape and press OK again to
confirm.
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How to import an embroidery from file, floppy
disk, tape
How to import an embroidery from a file
Select from menu File>Open when you want to open embroideries with
CXM format or files with different formats.
The formats that can be imported are:
Barudan FDR
Barudan FMC
Barudan
Barudan Tajima
Barudan ZSK
Happy
Juki B
Melco Expanded
Mitsubishi
Pfaff
Prowin LMU

Prowin PMU
Tajima Barudan
Tajima
Tajima Zsk
Toyota
Wilcom Tajima
Wilcom Eltac
Wilcom Barudan
Wilcom Zsk
Wilcom Pfaff
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How to import an embroidery from a floppy disk
•
•

Select the import > floppy disk (Ctrl+D) command from the File menu
If automatic format recognition has been set then the system proceeds
automatically, otherwise it asks for specification of the format of the
floppy disk to be imported
Check the box to obtain a preview of the
selected embroidery

List of the
embroiderie
s present
on the
floppy disk

•
•

select the embroidery to be imported
Press the Open button to confirm

NB: by pressing the configuration button, it is possible to further modify
the codes of the embroideries that will be imported:
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How to import an embroidery from a tape
•
•

Select the Import>Tape reader (Ctrl+B) command from the File menu
Select the tape reader to be used

List of
readers

•

the

configured

tape

Select the machine code of the tape to be read

Confirm with the OK button.

•

Tape reading starts.
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Connection to the Archive
It is possible to pen the embroideries in Millennium III, using the Archive.

Open the Archive

using the Archive item or using an existing

link on Desktop.
Select the embroidery or the embroideries that you want to open and select
from menu: File > Open or click on the button
embroideries.
If Millennium is will be automatically started.

Open selected

If Millennium3 starts before the Archive, it is not possible close Millennium
without first have closed the Archive.
If you try to close Millennium3, you will get the following warning:

C15-4

Millennium III

Introduction
The Archive is a program independent from Millennium3 also if to this
connected because from Millennium3 it gets information on the
embroideries – that makes it possible to create Databases used to manage
the embroideries.
As will be explained in more detail later, the Archive may manage more
than one Database, whether the Database is present on the local PC
currently being used or on a remote PC that is part of a PC network.
It is important to remember that if the embroidery files are moved, renamed
or deleted from the folder, it will also be necessary to manually update the
Archive.
In fact, the Archive is able to notice and signal if the embroidery files are
moved, renamed or deleted in order to allow you to keep it always up to
date:

It is obvious that if a file has been moved, renamed or deleted, it will not be
possible to open it even if its icon still appears in the Archive, and an error
message will be displayed.
Thanks to the Archive, you will be able to organize your embroidery files by
subdividing them into different categories and ordering them according to
different criteria and, by setting filter parameters, to carry out searches in
the Database to display only those embroidery files that satisfy your
requests.
The embroidery files managed by the Archive may be opened using
Millennium or may be exported in machine format onto a file, disk or
embroidery machine.
Furthermore, the Archive is equipped with useful tools such as
Compression, that makes it possible to reduce the disk space occupied,
and Backup that makes it possible to avoid problems associated with
accidental loss of data.
The Archive also makes it possible to create Catalogues in VPR or pCA
format that may be printed and distributed to your customers, or
Catalogues in HTML format that may be published on your Internet site or
distributed on CD-Rom to your customers.
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User Interface
The Archive User Interface is the following dialogue window that contains:
• A menu
• A Tool Bar
• A pane with the tree of classification categories (on the Left).
• A pane that displays the icons of embroideries (on the Right).
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Menu
Menu Items:
File
Open
Move Selected embroideries
Delete Selected File(s)
Export
Export to File
Export to Floppy Disk
Export to Machine
Exit
Archive
Keys Configuration
Add Embroideries

Cut

Copy

Description
Starts Millennium and opens the
selected embroideries.
Allows
to
move
the
selected
embroideries. Must be selected a PC
local disk and not a disk in net.
The files selected if confirmed will be
deleted.
Allows
to
export
the
selected
embroideries to file in the machine
format specified.
Allows
to
export
the
selected
embroideries to Floppy Disk, specifying
a machine format.
Allows
to
export
the
selected
embroideries directly to the Embroidery
machine specified.
Exits the program.
Allow to assign a name to the free keys.
Opens the Millennium3 icons list. Select
the Icons of the embroidery that you
want to add to the Archive and press
.
The icon of the embroidery is removed
from the category where was classified
and inserted into the Clipboard (the
buttons CTRL + X can be used instead
of
this
menu
item).
Allow, using Paste, to move an Icon
from one category to a different one and
therefore to change the classification.
The classification of the embroidery is
inserted in the Clipboard (the buttons
CTRL + C can be used instead of this
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Paste

Select All
Remove (from category)

menu
item)..
Allows, using Paste, to insert the Icon in
a different category and therefore of
classify it also into an additional
category.
Paste the icon contained in the
Clipboard into the category currently
opened (could be used the key CTRL +
V)
Select all the embroideries whose icons
are in the list.
Removes the selected embroideries
from the classification and classifies
them under NOT CLASSIFIED.
Will NOT Delete the embroideries!

Remove (from Archive)

Removes the selected embroideries
from the Archive.
Will NOT Delete the embroideries!

Check Category Embroideries Verification if the filed embroideries
have been modified for which the data
of the Archive are updated.
Preferences
Order by
Name
Order the icons by name.
Stitches
Order the icons by Stitch count.
Colors
Order the icons by color count.
Size
Order the icons by size (Area)
Creation Date
Order the icons by creation date.
Filter Parameters
Set Parameters
Allow to filter the embroideries in the list
using different parameters.
Clear Parameters
Enables the display of all the
embroideries removing all filtering.
Tree
Expand Tree
All branches of the classification keys
opens.
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Collapse Tree
Update Tree

All branches of the classification keys
closes
Updates
the
tree,
placing
the
classification categories in alphabetical
order.

Database Configuration
Select Current Database

Allows to select the current Database
from those available.
Configure Local Database
Allows to specify which Database is
present on the local PC.
Configure Remote Databases Allows to configure the remote
Databases.

Details Configuration
Control Panel

Peripherals

Details Configuration
Tools
Open Catalogue

Allows to define which information will
be displayed together with the
embroidery icon.
Allows to open the Peripherals Control
Panel window (Floppy Disk, Embroidery
Machine, Band Reader, Band Puncher,
File Format) in order to configure the
peripherals listed in the File>Export
menu. For further details consult the
paragraph “How to configure the
Input/Output devices”.
Allows to open the Peripherals program
in order to configure:
- Disk and band input codes.
- Disk and band output codes.
- Embroidery machine
- Band readers
- Band punchers
- Embroidery machines connected to
the serial port.
- Embroidery machines connected via a
network – Embo (for further details
consult the chapter “Peripherals”).
Allow to specify which information will
be displayed together with the Icon..
Opens an existing catalogue.
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Create Catalogue

Creates a new catalogue using the
selected embroideries
Publish Catalogue on the Web Create a catalogue in HTML format that
may be published on your Internet site
or distributed on CD-Rom as an
electronic catalogue.
Archive Utilities
Compact Database
The archives tendency to increase their
size with the use so some time is
advisable to use this function.
Database Backup
Creates a copy of the database file:
Archive.mdb
with
the
name
ArchBckp.mdb (if ArchBckp.mdb
exists already it will be overwritten
without warnings)

Tools bar
Is equivalent to Menu File > Open
Is equivalent to Menu Preferences > Tree > Expand Tree
Is equivalent to Menu Preferences > Tree > Collapse Tree
Is equivalent to Menu Preferences > Details Configuration
Is equivalent to Menu Preferences > Filter Parameters
Is equivalent to Menu Preferences > Filter Parameters > Clear
Parameters (this button is active only if the filter parameters have
been set).
Is equivalent to Menu Preferences > Tree > Update Tree
Is equivalent to Menu Archive > Add embroideries
Is equivalent to Menu Tools > Create Catalogue
Is equivalent to Menu Tools > Publish Catalogue on the Web
Is equivalent to Menu Preferences > Order by > Nome
Is equivalent to Menu Preferences > Order by > Stitches
Is equivalent to Menu Preferences > Order by > Color
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Is equivalent to Menu Preferences > Order by > Dimension
Is equivalent to Menu Preferences > Order by > Creation date (or
date of Update)

List of Embroideries icon
In the list, together with the icon of an embroideries are shown only the
embroidery information selected by the customer through the menu item
Preferences > Details Configuration or with the button

.

If the name is too long, it is truncated: Name too long….cam adding dots
at the end of the name.
The Archive also manages not Proel formats so it necessary visualize the
extension of the file otherwise it would not be possible to understand the
type of classified files.

C15-11

Millennium III

Classification categories
The left part of the dialogue window of the program shows the different
embroidery classification categories, listed in a tree structure.
Two main commands may be identified: “All Categories” and “All
Embroideries”. The All Categories command contains the individual
classification categories (Alphabets, Animals, Baby…) whereas the All
Embroideries command makes it possible to display, in the right-hand
window, the icons of all the Embroideries contained in the Database. Each
category in turn contains several subcategories.
Amongst the categories proposed by the program is a NON CLASSIFIED
category, that may be used to store embroideries that it is not possible to
classify or embroideries awaiting classification.
The User may create new categories by clicking with the right button of the
mouse on the All Categories command and selecting Add Subcategory
from the contextual menu.

In the same way it is possible to add a subcategory to a category by
clicking with the right button of the mouse on the latter and then selecting
Add Subcategory from the contextual menu. Furthermore, the contextual
menu may be used to delete or rename any category:
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Functions and use of the Archive
Add embroideries
The Archive is supplied with about 150 embroideries (contained in the
\Millennium3\Database\Embroideries folder) already divided into the most
appropriate categories.
To add further embroideries to the Archive, select Archive>Add
Embroideries or press the

button.

When this menu item is selected or pressed
, if the opened
classification folder is All Categories or All Embroideries the program
opens automatically the folder NOT CLASSIFIED and therefore the added
embroideries don't have classification.
If is opened a classification category different from All Categories and
from All Embroideries or from NOT CLASSIFIED the embroideries added
will be classified in this category.
If the selected file is on a network disk, the program asks to specify a folder
on the local disk where to make a copy of the embroidery because Archive
doesn't accept the filing of embroideries not resident on the local PC.

Embroidery Classification
To classify one or more embroideries still NOT CLASSIFIED in a category
of the Archive:
1. Select the embroideries
2. Press CTRL+ X or select from menu: Archive > Cut.
3. Open the classification folder under which you want to classify the
embroidery and press CTRL+ V or select from menu: Archive > Paste.
4. Wanting to classify the same embroidery under more categories,
repeat the point 3) opening different classification folders.
Or
1. Click on the tree to open it so that the category under which you want
to be filed the embroideries is visible.
2. Return on the folder where are the embroideries to classify (could be
NOT CLASSIFIED folder) and select the embroideries.
3. Click with the mouse (the cursor
appears) and holding the mouse
button pressed move the mouse toward the classification where the
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embroidery have to be classified (the cursor
appears), release the
button of the mouse when you are on the correct position.
Wanting to classify the same embroidery under more categories, perform
the point 3) holding pressed the CTRL key (the cursor

appears).

ATTENTION: It is NOT possible classify the embroideries if All Categories
or All Embroideries folders are open

Modify classification
To modify the classification of one or more embroideries behave like for the
Classification of an embroidery with the difference that you have to move
the embroideries from a folder that is not the NOT CLASSIFIED folder, but
it could be Flowers or Animals or other.

Configuration of optional keys
The software provides 8 undefined keys for classification, the customer
could configure the use of these keys according to his necessity. These
keys make it possible to assign other parameters to the embroidery files,
that make it possible to refine the embroidery by using the filter parameters
.
From menu select: Archive > Keys Configuration, the window here under
appears.
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Press the button relative to the key you want to be personalized, for
instance the Key1.
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Click with the right button of the mouse on the key and when the contextual
menu appears select: Rename Key, type the new name of the key and
press Enter.
In the example here under the key Customers have been created and
therefore introduced two customers.
To INSERT customers press with the right button of the mouse on the key
and when the contextual menu appears select: Add Value, type the name
of the customer and press Enter.
TO DELETE A CUSTOMER, PRESS ON THE CUSTOMER NAME WITH
THE RIGHT BUTTON AND WHEN THE CONTEXTUAL MENU APPEARS
SELECT: DELETE VALUE
To MODIFY the name of a customer, press on the name with the right
button of the mouse and when the contextual menu appears select:
Change value.
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A suggested use of the additional keys, could be the following:
Key
Use of the key
Examples
Key 1
Customers
Brown John
White Eugene
…
Key 2
Copyright
Walt Disney®
MGM®
…
Key 3
Threads
Silk
Cotton
…
Key 4
Fabrics
Pile
Jeans
…
Key 5
Use
Sports
Summer
…
Key 6
----Key 7
----Key 8
-----

Classification with the additional keys
An embroidery can be classified by category, as seen in Embroidery
Classification, moreover like explained in List filtering, there are other
keys for filtering, some information is obtained automatically from the
embroidery when possible: Name, Stitch count, Size, Color count, Date of
creation, etc.
There are information that the program could not always obtain without the
operator help, like: Sequin, Color count, Applique, etc.
The embroideries can be classified using the 8 additional keys whose
meaning is definable by the user.
The keys for instance could be: Customers, Copyright, Spun, Fabric, Use,
etc.
Click with the right key of the mouse on the icon and choose Details,
opens the window of the embroidery information, select General
Information.
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In the example here under is supposed that the keys have been configured
following our suggestions.
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To archive the embroidery for a specific customer, open the drop-down list
of customers, look for the desired customer and click on his name (type the
initial letter of the name of the customer to move in the list quickly).
Wanting to remove the classification for Customer, click on the button

.

If the customer doesn't exist in the list, press
.
The list of configuration of the customers key appears, proceed as seen in
Configuration of optional keys.

List filtering
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Click on
or select from Menu Preferences > Filter Parameters > Set
Parameters.
Enter all the parameters you desire to get an accurate filtration of the
embroideries and press Exit.

The key Clear removes any filtering in order to list all embroideries.
The items of Technical Details are:
Embroidery Name
Select
by
embroidery
name.
Examples:
C
Filters all the names that start with C
*C*
Filters all the names that contains a letter C
???C Filters all the names were the 4th character is a C
File Name
Select
by
file
name.
Examples:
C
Filters all the names that start with C
*C*
Filters all the names that contains a letter C
???C Filters all the names were the 4th character is a C
File Type
Selects the files with a specific type of format, for example:
Barudan, Tajima, …
X Size Selects the embroideries with a height between the values Min and
Max:
Min
Max
Selection
All the embroideries
180
All the embroideries wider then 180
millimeters
220
All the embroideries NOT wider then 220
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180

220

millimeters.
All the embroideries with the width
between 180 and 220 millimeters.

Y Size Selects the embroideries with a height between the values Min and
Max
See X Size to have more information.
Stitch Count

Selects the embroideries with a Stitch count within the
limits
See
X
Size
to
have
more
information.

Colors Selects the embroideries with a Color count within the limits
See X Size to have more information.
Creation Date Selects the embroideries with the Creation date within the
range specified.
The program defaults are January 1st 1900 and the current
PC date.
Last Update

Selects the embroideries with the Last Update date within
the range specified.
The program defaults are January 1st 1900 and the current
PC date.

Has Applique
Allow the selection of embroideries with Applique.
This information is not available automatically for all
embroideries and sometime must be entered by the user
when archiving the embroidery.
---All embroideries
Yes
Only the embroideries with applique
No
Only the embroideries without applique
Has Chenille

Allow the selection of embroideries with Chenille.
See Has Applique to have more information.

Has Borers

Allow the
See Has

selection of embroideries with Borers.
Applique to have more information.
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Has Kordel

Allow the
See Has

selection of embroideries with Kordel.
Applique to have more information.

Has Sequins

Allow the selection of embroideries with Sequins.
See Has Applique to have more information.

The items in General Information are the optional keys that have a
meaning that is definable by the user

Embroidery Information
Click with the right key of the mouse on the icon and choose Details,
opens the window of the Embroidery information, the Technical Details
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and the General Information furnish all the information on the embroidery
and on its classification.

Limits of the information of not CXM embroideries
When embroideries not CXM are classified, not all the information are
always available:
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Availability

C15-24

Millennium III

Name
File Type
X Size
Y Size
Stitch Count
Colors
Creation Date
Last Update
Applique
Chenille
Borers
Kordel
Sequins

Always
Always
Always
Always
Always
NOT Always
Always available
Only CXM files
NOT Always (*)
NOT Always (*)
NOT Always (*)
NOT Always (*)
NOT Always (*)

(*) depends on the code

Check Category Embroideries
Press the button
Embroideries.

or select from Menu Archive > Check Category

Verify if the data of the embroideries filed in the open category, are
updated, and if necessary update them.
Verify also the existence of such embroideries and signal possible errors.
If the category folder open is All Embroideries, all the database will be
checked.

Security copy
It is Very important to effect safety copies of the database file as the loss of
this involves to the manual reconstruction of all the archiving.
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A first way to make a copy is: Tools> Archive Utilities> Database
Backup that creates a copy of the database file: Archive.mdb with the
name ArchBckp.mdb (if ArchBckp.mdb exists already it will be overwritten
without warnings)
It is however preferable also copies on a removable support, not only on
the local hard disc, the operation could be made using the Windows 9x:
Backup or copying the file on CD, or on magnetic tape.
The file to save is in the Exe folder of the Millenium3 folder (or other name
if modified during the setup) where has been installed the application and
has the name Archive.mdb.
Before save the database it is preferable to perform an operation of
Compact Database.

Database Configuration
As mentioned in the introduction to this chapter, the Archive may manage
both a Database present on the local PC (in other words the one you are
using) as well as the Databases present on the remote PCs of a PC
network.
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In this way, from your PC you may access the Databases present on
remote PCs and at the same time the users of the remote PCs may
access your database:

REMOTE PC

REMOTE PC

LOCAL PC
To make this possible, it is necessary to configure the various Databases
by selecting Preferences>Database Configuration and selecting one of
the following submenus:
- Select Current Database to specify which Database you wish to use;
- Configure Local Database to specify which Database is present on
the local PC;
- Configure Remote Databases To configure the remote Databases.

Configuration of the Local Databases
By Local Database we mean the one present on the local PC that you are
currently using. Configuring the Local Database means rendering this
Database accessible to other network users. Obviously, in order for you to
be able to access the Databases on the remote PCs, even the remote PCs
must be configured as described below.
First of all, it is necessary to share in Reading/writing
the folder that
contains the Database embroideries (for further details consult the
Microsoft Windows manual):
This done, select Preferences>Database Configuration>Configure
Local Database. The following window opens:
Press the button: Share in: Configuration>Configure Local Database.
Select the path of the shared folder containing the embroidery files and
then press OK.
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At this point, the Local Database Configuration window will display the
Absolute Path (in other words the one referred to the local PC) and the
Network Path (in other words the one referred to the PC network):

Press the Exit button to exit and confirm the configuration.
The No Share button makes it possible to cancel the sharing that was set
at that time.

Remote Database Configuration
Remember that as well as the Local Database, the Archive is also able to
manage the Databases present on remote PCs.
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To create a list of all the Databases that you intend to manage using the
Archive, select Preferences>Database Configuration > Configure
Remote Databases. The following window appears:

The Add button makes it possible to insert in the list the path of the remote
Databases. Pressing it opens the following window that makes it possible
to select the path of a Proel Database present on a remote PC:

Note: Obviously, to be usable, the remote Databases that you wish to
include in the list must be configured by the user of the remote PC as
described in the paragraph “Local Database Configuration”.
Once all the Databases have been inserted, the Database Configuration
window will appear as follows:
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The Remove button makes it possible to eliminate the selected Database.
The Current button makes it possible to set the selected Database as the
Database in use. The path of the Database that has been selected as the
current one is immediately distinguishable from the others as it is displayed
in red and the icon
that represents it has a check mark
on it.
The Exit button makes it possible to exit and to save the new configuration.

Selection of the Current Database
The Archive is able to work on only one Database at a time, that must be
specified each time by the user by selecting Preferences>Database
Configuration > Select Current Database. The following window opens:

From which it is necessary to select the Database that will become the
Database in use and then press the Current button.
Then press the Exit button to exit and confirm the selection of the current
Database.
Remember that the Database that has been selected as the current one is
immediately distinguishable from the others as it is displayed in red and the
icon
that represents it has a check mark
on it.
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Locking and Unlocking of the embroideries
When an embroidery file is opened by Millennium III via the Archive, it is
automatically locked in order to prevent other network users from opening it
until it has been closed.
: A padlock symbol is shown on the icon of the blocked embroidery files.
When the embroidery file is closed by Millennium III it is unlocked
automatically.

The embroidery files may also be blocked manually even when they are not
being used by Millennium III, by clicking with the right button of the mouse
on the icon that represents them and selecting the Lock command from the
contextual menu:

To unlock a locked embroidery file, click with the right button of the mouse
on the icon that represents it and select the Unlock command from the
contextual menu:
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Creation of a new Catalogue
Select the embroideries with which you wants to be built the catalogue and
therefore from menu choose: Tools > Create Catalogue.
The following window appears:

Where:
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Header Text to be printed on the top of the page.
Paper Selection
Sheet format to be used during the preview of the
catalogue.
It is possible to change the sheet format before
the printing but it is not advisable because in the
moment in which the print confirmation appears,
the page formatting is already done.
Paper Orientation
Real View
Print Category
Category
Button
Default button
Save Button

Button
Preview Button

Exit Button

Can be Portrait
or Landscape
.
If selected, the embroidery print is done with real
view effect.
If selected, on the right side of the sheet,
vertically, will be printed the text entered in the
Category field.
Text
of
category
description.
Will be printed if Print Category is selected.
Allows choosing the type of character, its size,
attributes and the color to use printing the
category.
Restore the values of default (those furnished
initially with the program.
Save the configuration values modified.
If the values are modified only for an individual
printing don't use this button.
Creates a preview of printing pages with empty
icons to allow to find quickly the correct
parameters to be used.
Starts the construction of the pages of the
catalogue.
ATTENTION: this operation requires a certain
time.
Exits the catalogue preparation and returns to the
Archive.
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Icon Height
Horizontal spacing
Vertical spacing
Left Margin
Right Margin
Top Margin
Bottom Margin
Print Information
Print Icon frame
Print Text frame
Print Page Numbers
Starting Page

Height of icons in millimeters
Minimum distance between an icon and another
on the horizontal. The program however creates
a Justified spacing.
Vertical distance between one row of icons and
the following.
The margin to be left on the left of the sheet.
The margin to be left on the right of the sheet
The margin to be left on the top of the sheet
The margin to be left on the bottom of the sheet
If checked prints after the name also the size,
the stitch count and the color count.
If checked prints a frame around the icon.
If checked prints a frame around the text.
If checked prints the page number.
Normally the page numbers starts from 1, if you
enter a number the page count starts from this
number.

To verify the configuration, press
with empty icons.

for create a preview of printing pages

When the configuration is that desired press the Preview button.
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The catalogue building can be interrupted pressing
The preview of printing appears

Displays the first page
Displays the previous page
Displays the following page
Displays the last page
Displays at full screen
Displays at scale 1:1
Zoom In
Zoom Out
Save Button
Allows saving the previewed catalogue.
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Is possible to save the catalogue in two ways:
•
•

As Catalogue Image files: VPR
As Catalogue List Files: PCA

The VPR format saves the image of the catalogue.
Advantages:

Immediate reprint of future copies without the necessary
time to rebuilt the same catalogue.
Disadvantages: If an embroidery has been modified or it doesn't exist
anymore, it will anyhow printed in the copy of the
catalogue like in the original.
The file size is very big.
PCA format saves all the necessary information for rebuilding the
catalogue.
If during the reconstruction of the catalogue the program don't find some
file, a list of the missing is displayed, you are allowed however to continue.
Advantages:
Files with a small size.
It is possible to reprint the catalogue with a modified appearance
changing the parameters of printing.
Disadvantages: It is necessary the reconstruction of the catalogue (that
takes a long time).
Print button
Shows the Windows standard print dialog with which it is possible establish
the number of copies, select the printer to use and what pages to print.
Exit button
Exits without printing

Printing of an existing catalogue
From the menu select: Tools > Open Catalogue
Opens the File Opening dialog.
It is possible to open files of VPR type or PCA (see "Creation of a New
Catalogue").
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Print Stitch count
The Print Stitch Count command has been added to the Advanced card
of the Catalogue (Archive: Tools>Create Catalogue) window.

Print Stitch Count
If checked, it prints the number of stitches in the
embroidery. If it is not checked, the number of stitches is replaced by the
characters “-----“.

The Archive and Millennium III
Up to version 1.25, to open the embroidery files contained in the Archive it
was necessary to access the Start Windows menu and then select
Programs>Millemmium3>Archive and then follow the procedure (still
valid) described in the "Archive" chapter of the version 1.21 manual.
Now it is possible to access the Archive directly from the Millennium III
program by selecting File>Open from Archive, or by pressing the
button present on the Standard tool bar.
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The Archive dialog window opens, that, as explained in the 1.21 manual, is
a program that is independent of Millennium III even if it interacts with it in
order to obtain information on the embroideries:

To use this window, consult the instructions contained in the "Archive"
chapter of the 1.21 manual.
In the recent files list in the File menu, the embroidery files belonging to
the Archive are identified by the symbol [@].
If a file identified by this symbol in the recent files list is re-opened, all the
modifications that will be made subsequently to this embroidery will be
saved correctly in the Archive.
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In the 1.27 version, it is possible to save the embroideries directly in the
Archive by selecting, in the "Save As" dialog window, the Save in Archives
command:

A list of all the databases available in your system or net will appear in this
window. For Millennium III select ...\Millennium3\Exe
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@Embroidery (creation of HTLM pages)
Introduction
@Embroidery is a function of the Archive program that makes it possible to
simply and quickly create HTML pages that may be published on your Web
site or saved on CD-Rom to create an electronic catalog that may be
consulted by anyone via any Internet Browser (Microsoft Internet Explorer,
Netscape Navigator, etc.).
The HTML Pages that are created have the following structure:














 = company logo
 = information about the company
 = heading
 = number of pages
 = table with the icons and the embroidery data
 = links to the different pages created
 = background
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Using @Embroidery
Using @Embroidery is very intuitive as the user interface is a Wizard
consisting of three dialog windows, where it is possible to move from one
window to the other using the

and

buttons.

An
button that makes it possible to start creating an HTML
page is present in the last window of the Wizard.
1)

First of all select the category of embroideries that you wish to publish
(or All the Embroideries) if you wish to display all the filed
embroideries). Then select the individual icons of the embroideries that
you wish to insert in the HTML pages (or select Archive>Select All) if
you wish to publish all the embroideries in the active category):

2) Press the
button on the tool bar or select Tools>Publish
Catalogue on the Web. The 1/3 window of the Wizard opens:
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In this window it is necessary to select the publication options that make it
possible to determine the characteristics of the Catalog:
Output directory = specify the folders where the *.htm and the relative
images
are
to
be
filed
(the
default
folder
is
…\MILLENNIUM3\Database\Publishing). To specify a new path, press the
button and select the desired folder from the window that opens:
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Page header
Company Information = insert a text in this box, such as, for
example, the company address, a slogan, etc..
Company Logo = check this box if you wish to insert the company
logo or an image (*) in the top left hand corner of each page.
Checking this box activates the
button that makes it possible
to select the *.jpg, *.gif or *.bmp files that you wish to use:
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The
open
file
is
copied
into
the
…\MILLENNIUM3\Database\Publishing folder and a preview of the
selected image is displayed:
(*) Note: The image may even be an animated cartoon (GIF
Animation). If you wish to insert a background in the pages created,
we recommend that you file the image as a transparent gif
(Transparent GIF).
Header Text = insert a text in this box, such as, for example, the
name of the catalog, of the collection, etc.
Show Page Number = check this box if you wish to display the
page number in the n/tot (1/6, 2/6, 3/6, 4/6...) format after the
“Header Text”.
First Page Link, previous Page Link, Next Page Link, Last Page Link =
In the corresponding boxes, insert the link texts that make it possible to go
from one page to another of the catalog.

Embroidery Informations
Embroidery Name = Check this box if you want the name
assigned to the embroidery (that is not the name of the file!) to be
shown for each icon of the embroidery. If you wish, insert in the box
the word that is to precede the name of the embroidery, for
example “Name:” (*)
Remember that to assign a name to an embroidery it is necessary
to
open
it
with
Millennium
and
select
Embroidery>Properties>General:
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Stitches = check this box if you want the number of stitches in the
embroidery to be shown for each embroidery icon. If you wish, in
the relative box, insert the word that is to precede the datum
relating to the number of stitches, for example “Number of
stitches:”(*)
Size = check this box if you want the size of the embroidery to be
shown for each embroidery icon. If you wish, in the relative box,
insert the word that is to precede the datum relating to the size of
the embroidery, for example “Size of the embroidery:” (*)
File Name = check this box if you want the name of the file to be
shown for each embroidery icon. If you wish, in the relative box,
insert the word that is to precede the name of the file, for example
“File:”(*)
Colors = check this box if you want the number of colors in the
embroidery to be shown for each embroidery icon. If you wish,
insert the word that is to precede the name of the datum relating to
the number of colors, for example “Colors:”(*)
(*) Note: If no word is inserted in the boxes, the data relative to Name of the
embroidery, Name of the file, Number of stitches, Number of colors, Size of
the Embroidery that are contained in the cells of the table will not be
preceded by any writing.
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Embroidery name
Icon
File name
Number of stitches
Number of colors
Size of the embroideries

Once the publication parameters have been inserted press the
button to go to window 2/3 of the Wizard:
In this window it is necessary to select the HTML parameters of the
catalog pages:
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Page properties
Page Background = check this box if you wish to insert a
background image on the pages (if the box is not checked the
background will remain white).
When this box is checked, the
button is activated that makes
it possible to select the *.jpg, *.gif or *.bmp files that you wish to use
to create the background:

The
open
file
is
copied
into
the
…\MILLENNIUM3\Database\Publishing folder and a preview of the
selected image is displayed:
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Note: The background is created by repeating the selected image
over several lines and columns until the whole page is filled.
Example:

Image that you want to use
(dimension 3x3 cm, size 1 Kb)

Background you will
obtain
If you wish to obtain a background with a uniform color, it is
sufficient to load an image that has only one color.
To obtain the maximum speed for page loading, the image used as
a background must not be bigger than 5 Kbytes (preferably less
than 2.5 Kbytes).
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Before going to the section relating to the properties of the tables and cells,
let us examine a table containing 1 row and 2 columns in order to
understand the meaning of each of the parameters discussed in these
sections:

A

B

E

G
F

D C I

H

A = Table border (cornice)
B = Table spacing
C = Table backcolor
D = Cell backcolor
E = Cell padding
F = Icon
G = X dimension of the icon
H = Y dimension of the icon
I = Grey background (this color may not be changed) of the table border.

Properties of the table
Rows = in this box insert the number of rows of the table that will
contain the embroidery icons and the relative data.
Columns = in this box insert the number of columns of the table
that will contain the embroidery icons and the relative data.
Table Border = in this box, insert the width of the table border.
Table Spacing = in this box, insert the width of the cell border.
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Table Backcolor = press the
background color in the table:

button if you wish to insert a

The selected color will be displayed in the box adjacent to the
button.

Cell Properties
Cell backcolor = press the
color in the cell:

if you wish to insert a background

The selected color will be displayed in the box adjacent to the
button.
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Cell Padding = in this box, insert the width of the cell border.
Above and below the embroidery icon, this width will be adapted to
the amount of data (Name of the embroidery, Name of the file,
Number of stitches, Number of colors, Size of the embroidery) that
we have chosen to insert in the cells.
Icon Dimensions = in this box, insert the width and height of the
embroidery icon.
JPEG Compression Quality = JPEG Compression Quality = in
this box, insert the value of the JPEG compression that you wish to
use for the JPEG images of the embroidery icons or, alternatively,

select it by using the
to the right of this box.

cursor located

Warning, this value indicates the quality of the image and not the
degree of JPEG compression. Setting the compression quality
value towards a value of 1 will give a lower JPEG compression and
therefore a more well defined but heavier image, whereas setting
the compression quality value towards a value of 100 will give a
greater JPEG compression and a less well defined but lighter
image. We recommend maintaining the compression quality at
values below 50 especially if the catalog is to be published on a
Web site.
Example:
Image with a compression quality = 1 (8 Kb in size)
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Image with a compression quality = 50 (41 Kb size)

Image with a compression quality = 100 (86 Kb size)
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Once the publication parameters have been inserted, press the
button to go to window 3/3 of the Wizard:

Press the

button to start creating the HTML Pages.
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This window will display a process progress bar. The length of the process
is proportional to the number of pages to be created and the embroideries
selected.

Once the creation process has finished, a preview of the HTML pages
created will be displayed:

If the result obtained is satisfactory press the

button or the

button to return to Wizard dialog windows to modify the
desired parameters.
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Once
creation
of
the
Catalog
in
the
…\MILLENNIUM3\Database\Publishing folder or in the folder specified in
window 1/3 of the Wizard is finished, it is possible to find the HTML files
(Catalogue0.htm, Catalogue1.htm, Catalogue2.htm…) and the *>jpg files
created by @Embroidery:

These files may be published on your Web site or copied onto a CD-Rom
to create an electronic Catalog.
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Restoring the file ArchBckp.mdb
1. Make sure that the Archive is closed.
2. Copy the ArchBckp.mdb file contained in the …\Millennium3\exe
folder and paste it into the …\Millennium3\Database folder.
3. Delete or rename the Archive.mdb file contained in the
\Millennium3\Database folder.
4. Rename the ArchBckp.mdb file as Archive.mdb
Note: the ArchBckp.mdb file and the old Archive.mdb file being replaced
may be of different sizes. Don’t worry, this is due to the fact that the
Database is zipped before saving the ArchBckp.mdb file.

Sending E-mail
By using the Millennium Archive it is possible to very simply and quickly
send embroidery files and/or work sheets as attachments to an electronic
mail message. To do this, Millennium III uses the mail customer (Outlook
Express, Netscape Messenger, Opera, etc. ) that you have set as default in
your system.
Open Archive and use the left button of the mouse to select the
embroidery (or embroideries) that you wish to send.
Then select File>Send E-mail, the following window will open that will list
all the embroidery files that you have selected (Embroidery Name
column).
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The control boxes present in the Embroidery File column allow you to
select from the list those embroideries that you wish to send as mail
attachments whereas the control boxes of the JPEG File column allow you
to select which work sheets you wish to send (each work sheet is sent as
an image in jpg format and may be displayed using any graphic editor).
In this way, for each job, you may decide whether to send only the
embroidery file or only the work sheet or both.
Once the embroidery files to be sent have been selected, it is possible to
select the type of conversion from the pull-down menu by clicking on the
corresponding cell of the Conversion To column:
• No Conversion = *.cxm
• Melco Expanded = *.exp
• Tajima = *.dst
• Toyota = *.10°

When a work sheet has been selected by checking the relative box in the
JPEG File column, the familiar Print Work Sheet window will be displayed
(the only difference being that the Preview button has been replaced by
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the Attachment button). To set the parameters shown in the different
folders of this window, refer to the specific paragraph in this manual:

Once the required parameters have been set, press the Attachment button
in this window. The work sheet preview window will open. After having
checked that the data shown are correct, press the OK button to confirm
the intention to attach the work sheet to the electronic mail message or Exit
to return to the Print Work Sheet window.
At this point you may select and alter the values shown in the cells of the
Compression Quality column, remembering that this value indicates the
quality of the image and not the degree of JPEG compression. Setting the
compression quality value towards a value of 1 will give a lower JPEG
compression and therefore a more well defined but heavier image, whereas
setting the compression quality value towards a value of 100 will give a
greater JPEG compression and a less well defined but lighter image. We
recommend maintaining the compression quality at values below 50
especially if the catalog is to be published on a Web site. The default value
of 75 is a good compromise between image quality and file size.
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Once all the desired settings have been carried out, click on the Send
button to open a new electronic mail message (using the default mail
customer) to which you need simply add the address, the subject and
finally insert the text of the message.
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CHAPTER 16

Autopunch
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AutoPunch
Introduction
A new function has been introduced to Millennium III from version 1.31:
AutoPunch. This function makes it possible to punch an image
automatically, showing only the areas (or regions) of the same color that
make it up and filling them in the most appropriate way by using algorithms.
To be able to be autopunched correctly, the images must be simple, have
well-defined areas and be of uniform color (characteristics of ClipArt type
bitmap images).
As will be described in more detail later, areas of the same color may be
filled by using Satin in Jumpstitch, Satin in Random, or Tatami (all three
work modes are used with a fixed inclination) chosen automatically by the
program depending on the length of the stitch generated.
The use of AutoPunch is immediate as the user interface consists of a
Wizard structured in several steps (a dialog window corresponds to each
step) in each of which are requested the parameters relative to a definite
stage of the autopunch process. During the AutoPunch configuration
phase, the user may select which dialog windows to display in the Wizard
or even to disable them all in order to immediately start the autopunch
process using the parameters set during the configuration phase.
AutoPunch is an optional function of Millennium and therefore if it is not
available in your version and installation is required, contact your dealer to
learn the conditions and methods for doing so.

 AutoPunch 
From the image…
…to the finished embroidery

ATTENTION: Autopunch functions correctly only if Windows has
been configured with 16.8 million colors at 24 bit or 32 bit (consult the
Microsoft Windows operating system manual).
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AutoPunch configuration
To
configure
the
AutoPunch
parameters
select
Tools>Configuration>Punch from the menu or use the right button of the
mouse to click on the embroidery window and select the
Configuration>Punch contextual menu:

Pressing the
button located in correspondence to the
AutoPunch command will display the AutoPunch window that consists of
four cards: Image, Background, Color-Threads and Autopunch:
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Each card in this window contains the command how these parameters
in AutoPunch:
if the box is checked, a
corresponding dialog window will be displayed in the AutoPunch
Wizard;
if the box is not checked, the
corresponding AutoPunch Wizard dialog window is excluded. By
deselecting this command in all the cards, (Image, Background, ColorThreads and AutoPunch), autopunching will be carried out immediately
without displaying the Wizard.
Therefore, this command allows the user to decide whether or not to
display the Wizard to start an AutoPunch process and, in the first case, to
select which dialog windows will make up the Wizard.
Let us now examine each card of the AutoPunch configuration window:
- the Image card makes it possible to set the parameters relating to the
inserted image:
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X dimension (mm) (*) = makes it possible to modify the width of the
image;
Y dimension (mm) (*) = makes it possible to modify the height of the
image;
Maintains aspect ratio (*) = when this command is selected, the changes
that are made to one of the two parameters, Dimension X or Dimension Y,
will be transferred proportionally to the other parameter.
(*) Note: These commands are not active in parameter configuration, but
only in the corresponding Wizard Image window.
Minimum object size (mm) = makes it possible to set the minimum size
(height-width) that an area of the same color must have in order for it to be
detected by AutoPunch (default = 1mm);
Include one pixel line = If this command is selected, AutoPunch detects
even one pixel lines, stitching them with an Automatic stitch (for information
consult Example 2 of the paragraph “Examples of Using AutoPunch).
- The Background card makes it possible to set the parameters relating to
the background of the image inserted:
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Use all regions of background color = Selecting this command (default
selection) enables the background of the image to be detected as though it
were any other area of color, and therefore even the background will be
embroidered (for information consult the 1st case of Example 1 in the
paragraph “Examples of Using AutoPunch).
Use internal regions of background color = selecting this command will
disable detection of the background of the image – that therefore will not be
embroidered – but will enable areas inside the image with the same color
as the background to be detected and these areas will then be
embroidered (for information consult the 2 nd case in Example 1 of the
paragraph “Examples of Using AutoPunch”).
Selecting this command enables the Background color section:

from which it is possible to select three different types of background
detection:
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Auto detect, in which the main color of the image will be considered to
be the background color;
- White, in which white will be considered to be the background color
(typical of ClipArt);
- Select color(*), in which the color selected by the user from the
adjacent list will be considered to be the background color. This list
includes the main colors contained in the inserted image). Selecting
this command forces activation of the “Display AutoPunch parameters”
command to allow the user to select the background color from the
corresponding Wizard window.
In this section, the Color(*) box will show the background color selected by
the user or autodetected.
-

(*) In parameter configuration the Color box and the list of colors are
inactive, they are active only in the corresponding Wizard Background
window.
Do not use regions of background color = selecting this commands
disables detection both of the background as well as of those areas of the
image that have the same color as the background. In general, this choice
is made when it is necessary to stitch an embroidery on a fabric of the
same color as the background of the image (for information consult the 3 rd
case of Example 1 of the paragraph “Examples of Using AutoPunch”).
Selecting this command enables the background color section and the
same considerations as those made in the preceding description of the
command “Use internal regions of background color” apply.
- the Colors-Threads card makes it possible to set the parameters relating
to the embroidery colors and to the matching of the threads to the colors in
the image.
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The Colors-Threads card has two main commands: Monochrome
AutoPunch that makes it possible to carry out autopunching using the
active thread of the document (it is not necessary to set any other
parameter) and Multicolor AutoPunch (default selection) that makes it
possible to carry out a multicolor embroidery using the thread table and the
type of color management selected by the user:

The commands of the Multicolor AutoPunch section are as follows:
- Default thread brand = makes it possible to select a thread table from
amongst those provided with Millennium or created by the user (default =
Proel RGB):

Reduced colors automatically = by selecting this command, the number
of colors contained in the image will be reduced automatically during image
analysis and each color will be matched to the thread from the selected
thread table that is closest to it in shade.
Number of colors = selecting this command sets the number of colors, in
the corresponding box, that the final embroidery will have.
Warning, when this value is set it is necessary to consider also the
background color of the image, even if the “Do not use regions of
background color” command was selected from the Background card.
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Thread table = selecting this box makes it possible to create a list of
threads that you wish to use in the embroidery, taken from the various
thread tables available:

-

The Add button opens the Threads window:

from which it is possible to select a thread table and therefore, one at a
time, the different threads that are to be inserted in the list.
The Delete button makes it possible to remove the selected thread
from the list.
Document thread palette = selecting this command uses the thread table
that was set in the active document when AutoPunch was being used.
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- the AutoPunch card makes it possible to set the parameters relating to
autopunching the image:

Max length jump stitch area (mm) = makes it possible to set the length
under which an area will be filled with Jumpstich Satin (default = 3 mm);
Max length stitch tatami area (mm) = makes it possible to set the length
above which an area will be filled with Tatami (default = 20 mm);
The lengths comprised between the maximum and minimum values set will
be filled by a filling which has the selected parameters.
Split complex entities = when this command is selected, the complex
areas (or shapes that have the same color) are split into several simple
areas (or shapes)
Example:
You wish to Autopunch the following image:
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If the Split complex entities command is deselected, the following result
will be obtained:

Instead, if the Split complex entities command is selected, the following
result will be obtained:

When the Split complex entities command is selected, the following
commands will be activated:
Connection running indent (mm) = in the corresponding box, set the
value of the distance, with respect to the edge of the shape to be
punched, that the stitches that are used to pass from one simple area
to another (Automatic stitch) are to have. In some special cases, the
program may force the running indent value to values that are different
from those that were set.
Example:
Indent = 0,1 mm
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Indent = 5 mm

Connection running stitch length (mm) = in the corresponding box,
set the length of the Automatic stitch that will be used to pass from one
simple area to another.
Detect ring entities = when this command is selected, the ring areas that
are identified in the image to be punched, will be filled with radial
inclinations. Otherwise, the ring shapes will be filled with parallel
inclinations as for any other shape.
Example:
You wish to Autopunch an image containing the following ring shape:
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If the Detect Ring entities command is deselected, the following result will
be obtained:

Instead, if the Detect ring entities command is selected, the following
result will be obtained:

Parallel autofill = the following two commands are available in this section
of the Autopunch card:
Automatic inclination = by checking this command, the program is
entrusted with the task of deciding which inclinations will best fill the
different areas of an image.
Inclination slope (°) = in the box corresponding to this command
(that of course is disabled when the Automatic inclination
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command is checked), it is possible to set the inclination angle (in
degrees) of the parallel filling.
Remember that an Autopunch process may be interrupted at any time by
pressing the ESC key.
Program parameters = by selecting this command, the Automatic, Satin
and Tatami work modes that will be used in autopunching will employ the
parameters that are active in the system when AutoPunch is being used.
Instead, if this command is deselected, the three buttons that make it
possible to set the parameters relating to each work mode will be activated:

Using AutoPunch
Obviously, AutoPunch requires the prior insertion of an image in the
embroidery window. To do this, select Edit>Insert>Image or Insert Image
from the contextual menu that appears by clicking with the right button of
the mouse on the embroidery window, or press the Ctrl+I keys.
Assume that we shall autopunch the following image comprising a white
background and areas with six different colors:

Remember that before starting AutoPunch it is possible to carry out a
Horizontal flip, a Vertical flip or a Calibrate Image operation on the
image or to modify its Properties (consult the chapter “How to use the
images”) by using the contextual menu that appears by clicking on the
image with the right button of the mouse.
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1)

Click on the image with the right button of the mouse and select the
AutoPunch command from the contextual menu that appears:

Two different situations may occur at this point:
- if the command
was deselected in
all the folders during the configuration phase, autopunching starts
immediately and will be carried out using the parameters that were set
during the configuration phase;

-

If the
command was selected in all
the folders (or in some of them) during the configuration phase, a
Wizard consisting of the windows which had this command selected
will be activated. Therefore, the Wizard may consist of a maximum four
of dialog windows, Image, Background, Colors-Threads and
Autopunch (substantially the same as the folders of the AutoPunch
configuration window).

-

To move from one window to the other, use the

and

buttons. The
button that makes it possible
to start the autopunching process is present in the last window of the
Wizard:
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window 1/4

window 2/4

window 3/4

window 4/4

In particular, the four dialog windows of the Wizard are equivalent to the
four folders of the AutoPunch configuration window except for some
parameters (indicated by an asterisk in the paragraph relating to
configuration) that are enabled in the case of the Wizard.
The following will consider only those parameters that are disabled during
the configuration phase, referring you to the paragraph “AutoPunch
Configuration” for all the other parameters of each single window.
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In the Image window, the Dimension X (mm), Dimension Y (mm) and
Maintain proportions commands are active and will show the values of the
image that is inserted in the embroidery window:

In the Background window, the Select color command and the Color box
are active. The list located in correspondence to the select color command
shows the main colors that the program detects in the image inserted in the
embroidery window.
From this list, the user may select the color that he wants AutoPunch to
detect as the background color (the color selected will be shown in the
Color box):
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Examples of using AutoPunch
Example 1
Assume that we want to punch the following image:
cyan

White
(background)
White (internal)

yellow

blu
red

green
black

in which it is possible to distinguish seven different colors: white, cyan,
yellow, green, red, blue and black. The background of the image is white,
as are some areas inside the image.
1st case: the entire image (including the background) is to be punched
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Select:
Use
all
regions
background color

of

2nd case: we do not wish to punch the background but only those
areas inside the image that have the same color as the background
(face and eyes of the clown)
Select:
Use internal regions of background
colors

C16-20

Millennium III

In background color section,
select:
Auto detect
Verify that the exact color is
displayed in the Color box (*).

Note that in this case, white has been detected automatically as the
background as it is the main color of the image.
In some cases, the main color may not be the background color and
therefore selecting the Auto detect command is no longer appropriate.
Let us examine this situation using two practical examples.
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Four colors may be identified in the following image (yellow, black, blue
and white) and the color that we shall use as the background color is
obviously white.
yellow
blu/white
black
white (background)
However, in this image the main color is yellow, and therefore if the Auto
detect command is selected in the Background color section, AutoPunch
will automatically detect yellow as the background color:

Therefore, in this case we must select the White command and not the
Auto detect command:
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However there are some cases where in the image to be punched, we
don’t wish to use either White or the main color as the background color:
white
orange
blu (background)
black
In fact, in this image, if the Automatic detection command is selected,
orange will be detected as the background color.
If we do not want to punch blue, we must select the Select color
command and select blue from the list of colors:
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3rd case: We do not wish to punch either the background or the areas
inside the image that have the same color as the background (face
and eyes of the clown).

From the AutoPunch Background window select the command: Do not
use regions of background color.

In the Background color section select the command: White or Auto
detect.
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Example 2
In this example we would like to explain in more detail the meaning of the
command Include one pixel line, in the Image window.

Assume that we want to punch this image in which the white stripes are
bordered on their lower side by a red one-pixel line:

If the above command has been selected, the following embroidery is obtained:

This embroidery has that
red one-pixel line punched
with an Automatic

If the above command has not been selected, the following embroidery is obtained:

This embroidery hasn’t that
red one-pixel line punched

C16-25

Millennium III

Setting the Automatic inclinations of the filling
Up until version 1.34, the fourth window of Wizard Autopunch asked you to
set the angle of inclination of the filling (Filling or Satin) of the different
areas that made up the image.
From version 1.35 on, this is still possible but the Automatic inclination
command has also been implemented, that if checked, makes it possible to
assign to the computer the task of deciding which is the most suitable angle
of inclination for the filling of the different areas of the image:

Obviously, if this command is checked, the function allowing the user to
force the angle of inclination of the filling to the desired value has been
disabled:

C16-26

Millennium III

Images with too many colors
If the image that you have decided to punch automatically contains too
many colors (as in the case of a scanned image for example) the result
may be unsatisfactory or the process may take too much time.
With images of this type, Millennium III (before starting the automatic
punching operation) will warn you with the following message: “Warning,
the image that you have decided to autopunch contains too many colors.
Do you still wish to continue?”
In general, with images of this type it is advisable to interrupt the
autopunching operation and use the tool for reducing the number of colors
as explained in the paragraph “Reducing the number of colors in an
image”

Splitting complex entities
From version 1.39 onwards, Autopunch is able to break down complex
shapes into simpler shapes. This characteristic may be activated by
checking the Split complex entities box in the Autopunch card in the
Autopunch configuration Wizard window.
This card also contains two fields for setting the parameters that connect
the two entities obtained: Connection running indent (mm) and
Connection running stitch length (mm).
For further details consult the Autopunch chapter in this manual.
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Photo Embroidery
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Punching of photographs: Photo Embroidery
The Photo Embroidery function makes it possible to punch both color
images (Color Photo Embroidery) and black and white images
(Monochrome Photo Embroidery). It is present as an option on all the
punching levels currently available in Millennium (Basic, Professional,
Advanced). If the Photo Embroidery function is not available in the program
in your possession and installation is necessary, contact your supplier for
information about the conditions and methods for doing so.
The Photo Embroidery function requires a preliminary configuration of the
executable functional parameters by selecting
Tools>Configuration>Punch or by clicking on the embroidery window
with the right button of the mouse and selecting Configuration>Punch
from the menu that appears. The following Configuration window will be
displayed:

The two Setup buttons make it possible to gain access respectively to the
window for setting the Color Photo Embroidery parameters and to the
window for setting the Monochrome Photo Embroidery parameters.
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Color Photo Embroidery
This function makes it possible to punch color images by using a
combination of four fundamental colors: blue, yellow, magenta and black.
For this reason, the best results are obtained when the image is
embroidered on a white fabric. When the Color Photo Embroidery
command is activated, the program performs a sequential analysis of the
four colors present in the image and then generates an embroidery entity
for each one in order that overlapping the four embroidery entities will
define the final effect. In particular, the embroidery obtained has a matrix
structure in which it is possible to distinguish a finite number of square
elementary areas, each of which will be filled in a different way by each of
the four threads depending on the amount of color present in the image in
correspondence to that elementary area.
To prevent the threads of different
color from overlapping, thus
compromising the final chromatic effect, each one is assigned a different
thread entry and exit point to/from the elementary area. In particular, the
blue thread has thread entry and exit points aligned horizontally, the yellow
thread has entry and exit points aligned diagonally in a north-west direction,
the magenta thread has entry and exit points aligned diagonally in a northeast direction and the black thread has entry and exit points aligned
vertically.
After having pressed the Setup button of the Configuration window, the
following window appears:
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Palette: This section of the window makes it possible to select a Color
palette to produce an embroidery that uses four differently colored threads,
or a Monochrome palette to produce an embroidery that uses one only,
as desired, of the four threads.
General: makes it possible to select the four colors of the Color Palette or
the single color of the Monochrome Palette. This section is presented in a
different way depending whether a Color Palette or a Monochrome
Palette has been selected.
If a Color Palette has been selected, the General section is presented as
follows:

By pressing one at a time the buttons
foreseen in correspondence to
each color, the Threads window will be displayed, from which it is possible
to select the type of thread and the colors to be used in the embroidery:
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Note: it is obvious that for each of the four colors (blue, yellow, magenta
and black) a different color to the one suggested may be selected in order
to obtain particular chromatic effects. We advise the user to run a few trials
to see the different chromatic effects that may be obtained by varying the
colors or the shades of the colors.
If instead, the Monochrome Palette has been selected, the General
section is presented as follows:

When the Monochrome Palette is selected, the image is punched in black
or using the thread selected in correspondence to this command in the
General section that is displayed by selecting the Color Palette.
Horizontal: By selecting this command, an embroidery composed of
horizontal stitching is obtained.
Vertical: By selecting this command, an embroidery composed of vertical
stitching is obtained.
Skew: By selecting this command, an embroidery composed of oblique
stitching in a north-west direction is obtained.
Reverse Skew: By selecting this command, an embroidery composed of
oblique stitching in a north-east direction is obtained.
C17-6

Millennium III

Invert Image: By selecting this command the dark and light areas of the
embroidery are inverted and the “negative” of the analyzed image is
obtained.
Properties: The properties section makes it possible to set the width
(Band Width) in millimeters of the square elementary areas into which the
embroidery is subdivided and the number of thread modulations within
each one.
Modulation is a parameter that basically defines the quality of the
embroidery based on terms of optical clarity; in practice it may be
compared to the definition of an image.

Preview: This button makes it possible to display the preview of the set
parameters, applied to the color photograph shown at the top right of the
Color Photo Embroidery Setup window:

Preview Color Palette:
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Preview Monochrome Palette:

Monochrome Photo Embroidery
This function, makes it possible to punch black and white images using a
single thread. Monochrome Photo Embroidery produces an embroidery
consisting of a matrix in which may be distinguished a finite number of
square elementary areas, that are filled in a different way by the single
thread used, depending on the amount of gray present in the image in
correspondence to that particular elementary area. More precisely, in
correspondence to each elementary area, zigzag stitches are deposited
whose parameters (density and width) depend on the amount of gray
presented by the image in correspondence to that area.
These zigzag stitches define the parallel stitchings that are developed
horizontally along the horizontal bands defined by the elementary areas of
the matrix; in correspondence to the darker areas the zigzag stitches are
developed in such a way as to make the thread follow a longer route
whereas in correspondence to the lighter areas the zigzag stitches are
developed in such a way as to make the thread follow a shorter route.
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After having pressed the Setup button of the Configuration window, the
following window appears:

Modulation: This section of the window makes it possible to choose the
type of development (Amplitude, Frequency, Both) of the zigzag stitches
along the horizontal bands of the embroidery:
Amplitude: By selecting this command, the zigzag stitch is developed with
a pre-set and constant frequency but is wider in the darker areas and
narrower in the lighter areas of the image. In other words, the darker areas
are embroidered with wider zigzag stitches whereas the lighter areas are
embroidered with narrower zigzag stitches.
Frequency: By selecting this command, the zigzag stitch is developed with
a pre-set and constant amplitude but has a higher frequency in the darker
areas and a lower frequency in the lighter areas. In other words, the darker
areas are embroidered with closely-packed zigzag stitches (higher density)
and the lighter areas are embroidered with sparse zigzag stitches (lower
density).
Both: By selecting this command, both the amplitude modulation rules and
the frequency modulation rules are applied simultaneously. Obviously,
when this method is applied, both the frequency and the amplitude may be
variable in size.
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Properties: This section of the window makes it possible to set the
properties relative to the horizontal bands and the relative zigzag stitches
that will define the embroidery:

Band gap: is the distance in millimeters between the horizontal bands; the
lower this value, the higher the definition of the embroidery.
Band Width: is the width in millimeters of each horizontal band of the
embroidery and the width of each square elementary area.
Modulations: is a parameter that basically defines the quality of the
embroidery in terms of optical clarity; in practical terms it may be compared
to the definition of an image.
Frequency: may be set only when amplitude modulation is selected and is
the number of zigzag stitches contained in each elementary area of the
embroidery.
Thread Color: By pressing the
button the Threads window appears,
from which it is possible to select the type and color of thread to be used in
the embroidery:
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Invert Image: By selecting this command the dark and light areas of the
embroidery are inverted and the embroidery obtained is basically the
“negative” of the analyzed image is obtained.
Preview: This button makes it possible to display the preview of the set
parameters, applied to the black and white photograph shown in the top
right of the Monochrome Photo Embroidery window:

Preview Amplitude modulation:

Preview Frequency modulation:

Preview Amplitude and Frequency modulation:
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Use of the Photo Embroidery function
To use the Photo Embroidery function it is necessary first of all to insert
the photograph to be punched in the embroidery window by selecting
Edit>Insert>Image or by using the shortcut keys Ctrl+I. At this point the
Photo Embroidery function may be recalled by simply clicking the right
button of the mouse on the image to be punched. The following contextual
menu will be displayed:

The Calibrate Image command makes it possible to set the size in
millimeters of the image inserted in the embroidery window. The use of this
tool is the same as that of the size measurement tool (F7 key) except that
in this case, after the reference
points have been positioned, a window
is displayed where the distance in millimeters, that the image or part of the
image contained within the two reference points must assume after the OK
button has been pressed, must be inserted:

C17-12

Millennium III

The Monochrome Photo Embroidery and the Color Photo Embroidery
commands make it possible to start respectively the two different automatic
punching processes of the photograph inserted in the embroidery window.
During this process, the duration of which depends on the complexity and
number of colors in the image, the following window appears:

that gives the User information about each operation that is performed and
on the progress of these operations. This process may be interrupted at
any moment.
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Millennium III Hot Keys
File
New
Open
Save
Import
 Floppy Disk
 Tape Reader
Export
 File
 Floppy Disk
 Embroidery machine
 Tape puncher
Print

Ctrl+N
Ctrl+O
Ctrl+S
Ctrl+D
Ctrl+B
Ctrl+Shift+F
Ctrl+Shift+D
Ctrl+Shift+E
Ctrl+Shift+B
Ctrl+P

Edit
Undo
Redo
Cut
Copy
Paste
Select All
Insert image
Insert embroidery
Insert Frame
Insert Machine Frame
Insert HPGL File

Ctrl+Z
Ctrl+Y
Ctrl+X
Ctrl+C
Ctrl+V
Ctrl+F
Ctrl+I
Ctrl+M
Ctrl+F
Ctrl+K
Ctrl+H

Display
Measure
Slow Draw
Zoom
Adapt to window
Increase Zoom
Decrease Zoom

F7
F8
F9
F10
F11
F12
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View
Redraw
Sequins

F5
F6

Embroidery
Properties
Draw shapes
Automatic
Column
Fill
Tatami
Background
Motif on curve
Text

Ctrl+G
Alt+Shift+D
Alt+1
Alt+2
Alt+3
Alt+4
Alt+5
Alt+6
Ctrl+T

Draw
Activate shape
Curve
Ellipse
Polygon
Rectangle
Outline

Alt+Shift+A
Ctrl+1
Ctrl+2
Ctrl+3
Ctrl+4
Ctrl+9

Selection
Simple
Extended
Stitches

Ctrl+Q
Ctrl+W
Ctrl+E

Generic
Add Inclinations
Close curve (rounded off)
Close curve (not rounded off)
Move thread exit symbol
Move tatami reference
Properties (of a selected entity)

Ctrl+A
Ctrl+<+>
<+>
Space bar
Ctrl+R
F2
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CHAPTER 18

True Type Lettering
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DESCRIPTION
The True Type Lettering tool allows you to automatically create embroidery
by using the True Type fonts outline.
The current version uses a True Type outline to position the satin or fill
stitches.

Creation method
To create an object using the True Type Lettering tool, you must activate
the creation menu window, which may be activated via the Embroidery
menu command, or via the modes listbox, as shown in the figures below.

The True Type Lettering window, shown on the next page, allows you to:
• enter the text to be positioned;
• select the font to be used;
• select the font height;
• select a reference line for the positioning;
• vary the distance or spacing between the characters;
• select and set punching parameters (for big or small sized characters);
• select the type of stitch to be used in the fill.
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The processing of the embroidery may take a few seconds if the font or the
characters have never been used before.
At the end of the calculation process, the requested embroidery will be
displayed on screen.

Sometimes, the automatic stitch development mechanism is not able to
produce a good result, in which case it will be necessary to intervene
manually to tell the program which is the preferred and/or correct punching
mode.
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If a character is not calculated, the stitch development procedure will in any
case create a text object and insert a rectangle as a place marker instead of
the missing character; the contextual menu associated to the place marker
, will allow the activation of the character editor tool and the subsequent
development of the text object.

From the contextual menu, select Char Editor to display the Polygon
Splitter function.
Attention: remember that to select a single character (or as in this
case, the place marker rectangle), press the Ctrl key on the
keyboard, keep it pressed and click with the left button
mouse at the same time.
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Editing tool: Char Editor
This tool allows you to indicate to the stitch development program, how you
would like to carry out the punching of each character.
The modifications are permanent and are saved in the autofont punching
data (config/Autofont folder).
As everyone knows, the punching of a character may change depending on
the size used, for this reason the Char Editor editing tool keeps the data for
punching small characters separate from the data for punching big
characters (consider for example the punching of “grazie” using a font such
as Ms Serif).

Tool description: Graphic interface
This tool allows you to subdivide the outline of a character into polygons
and to indicate the slants that the stitches must follow when filling each
polygon.
It contains the following tools:
: tool for describing the cutting lines;
: tool for describing the slants for positioning the stitches;
: tool for describing the entry polygon;
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: tool for describing the exit polygon.
The function of the remaining buttons is as follows:
: allows you to add cutting or slant lines;
: eliminates all the cutting or slant lines from the document.
Tool description: Operating mode
The cutting lines (red color), describe how we would like the outline to be
subdivided.
A cutting line is always anchored to two outline points.
WRONG

CORRECT

The slant lines (blue color), describe the slants of the embroidery stitches.
A slant line must always intersect two outline points.
CORRECT

CORRECT

CORRECT
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WRONG

WRONG

The entry and exit points indicate how the embroidery thread enters or exits
from the character during punching.
To indicate the entry point, click
second time inside the outline.
To indicate the exit point, click
second time inside the outline.

once on the

button, then click

a

once on the

button, then click

a

At the end of these operations the modifications may be saved and
made operational by selecting “Save And Exit” from the File menu.
Editing a cutting line
Select the Cutter, button
been pressed:

, and make sure that the

button has not

•

click
the mouse once on a red line to select the cutting line to be
edited;

•

click
the mouse a second time in correspondence with one of the
ends of the selected line and drag it to edit the orientation of the line.
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Inserting a cutting line
Select the Cutter, button
pressed:
•
•

, and make sure that the

button has been

click
the mouse once in correspondence to a point on the outline;
drag the mouse pointer to a second point on the outline to finish the
description of the cutting line.

Deleting a cutting line
Select the Cutter, button
been pressed:
•
•

, and make sure that the

button has not

click
the mouse once on a red line to select the cutting line to be
deleted;
use the DELETE key on the keyboard to delete the cutting line.

Editing a slant line
Select the Slant, button
been pressed:

, and make sure that the

button has not

•

click
the mouse once on a blue line to select the slant line to be
edited;

•

click
the mouse a second time in correspondence with one of the
ends of the selected line and drag it to edit the orientation of the line.

Inserting a slant line
Select the Slant, button
pressed:
•
•

, and make sure that the

button has been

click
the mouse once close to the outline;
drag the mouse pointer to finish the description of the slant line.
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Deleting a slant line
Select the Slant, button
been pressed.
•
•

, and make sure that the

button has not

click
the mouse once on a blue line to select the slant line to be
deleted;
use the DELETE key on the keyboard to delete the slant line.
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Edit font outline
It is possible that the outline of single characters doesn’t always develop
perfectly (for example, there may be some small deformations, or the shape
of the character may not be linear), in this case, not being able to correct it
manually, use the Text Outline function to edit the height of the font until the
outline is displayed perfectly without any imperfections.
The figure below shows the example of an embroidered character developed
using the True Type Lettering tool; as you may notice, development did not
occur correctly in this case, in fact the outline shown in the highlighted
section is not linear.

The imperfection may be seen more clearly by activating the Polygon Splitter
function, as described earlier.
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While keeping the character selected, activate the Text Outline function from
the Draw menu.

The Font Dialog window appears.

Edit the height of the font until the outline is displayed correctly.
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From the contextual menu associated to the selected font , select the
Update True Type Lettering Outlines command to update the outline of the
initial font.

Attention: remember that to select a single character (or as in this
case, the place marker rectangle), press the Ctrl key on the
keyboard, keep it pressed and click with the left button
mouse at the same time.
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